Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge xorg fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
alibengali
n00b
n00b


Joined: 23 Nov 2003
Posts: 4

PostPosted: Wed Jan 11, 2006 5:17 pm    Post subject: emerge xorg fails Reply with quote

hi,

trying to emerge xorg fails with the following error:

making all in programs/glxinfo...
make[4]: Entering directory `/var/tmp/portage/xorg-x11-6.8.2-r6/work/xc/programs/glxinfo'
i686-pc-linux-gnu-gcc -O3 -march=athlon-xp -fomit-frame-pointer -pipe -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -DDO_GLU -c -o glxinfo.o glxinfo.c
rm -f glxinfo
i686-pc-linux-gnu-gcc -o glxinfo -O3 -march=athlon-xp -fomit-frame-pointer -pipe -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -L../../exports/lib glxinfo.o -lGLU -lGL -lXext -lX11 -lpthread -lm -Wl,-rpath-link,../../exports/lib
../../exports/lib/libGLU.so: undefined reference to `operator delete(void*)@GLIBCXX_3.4'
../../exports/lib/libGLU.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info@CXXABI_1.3'
../../exports/lib/libGLU.so: undefined reference to `operator delete[](void*)@GLIBCXX_3.4'
../../exports/lib/libGLU.so: undefined reference to `operator new[](unsigned int)@GLIBCXX_3.4'
../../exports/lib/libGLU.so: undefined reference to `operator new(unsigned int)@GLIBCXX_3.4'
../../exports/lib/libGLU.so: undefined reference to `__cxa_pure_virtual@CXXABI_1.3'
../../exports/lib/libGLU.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info@CXXABI_1.3'
../../exports/lib/libGLU.so: undefined reference to `vtable for __cxxabiv1::__class_type_info@CXXABI_1.3'
../../exports/lib/libGLU.so: undefined reference to `__gxx_personality_v0@CXXABI_1.3'
collect2: ld returned 1 exit status
make[4]: *** [glxinfo] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r6/work/xc/programs/glxinfo'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r6/work/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r6/work/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r6/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.2-r6 failed.
!!! Function build, Line 973, Exitcode 2


i understand that there are some glibc-functions are not found, but the glibc is brandnew and emerged fine.
since i'm not really a programmer, i can't see what exactly is going wrong. can anybody help me or point me to some documentation
where to solve this issue?

thanks in advance,

ali
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Wed Jan 11, 2006 6:53 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 354405
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum