Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenyOffice.org java dependenc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Fri Jan 13, 2006 12:56 pm    Post subject: OpenyOffice.org java dependenc Reply with quote

I just tried to emerge openoffice. It attempted to fetch ibm's java kit and said to manually emerge ibm's java kit, place it somewhere in portage, then do something else. Is blackdown java kit sufficient for openoffice? If so, why is portage attempting to fetch ibm's kit?

Also, whenever I do revdep-rebuild after updating world, java blackdown always comes up. On a separate, but sort of relevant, side note, what is a good java configuration to have on ppc for someone who wants to begin programming (in Java of course)?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Fri Jan 13, 2006 1:12 pm    Post subject: Reply with quote

Code:
emerge --pretend openoffice

yields:
Code:
Calculating dependencies ...done!
[ebuild  N    ] sys-libs/lib-compat-1.4 
[ebuild  N F  ] dev-java/ibm-jre-bin-1.4.2.03 
[ebuild  N F  ] dev-java/ibm-jdk-bin-1.4.2.03 
[ebuild  N    ] x11-libs/startup-notification-0.8 
[ebuild  N    ] app-shells/tcsh-6.14-r2 
[ebuild  N    ] app-office/openoffice-1.1.4-r1

_________________
gentoo good to be true
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Jan 13, 2006 2:34 pm    Post subject: Reply with quote

IBM's Java is the only Java JDK/JRE that's really supported on PPC. Blackdown/PPC is extremely old and most programs in portage don't work with that JDK.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Fri Jan 13, 2006 9:09 pm    Post subject: Reply with quote

tcsh is needed to install openoffice?
Code:
$ java-config --list-available-vms
[blackdown-jre-1.3.1] "Blackdown JRE 1.3.1" (/etc/env.d/java/20blackdown-jre-1.3.1)
[blackdown-jdk-1.3.1] "Blackdown JDK 1.3.1" (/etc/env.d/java/20blackdown-jdk-1.3.1) *

Should I "emerge --unmerge blackdown-jre" and "emerge --unmerge blackdown-jdk" and then follow the instructions for Java in the Desktop User Configuration gentoo docs? Or should I go about removing them another way? Also, It seems like I would mess up some dependencies by unmerge'ing blackdown. Is there an easy way to point all the confused programs in the right direction once ibm java is on my system?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
talipdx
n00b
n00b


Joined: 13 Jan 2006
Posts: 7

PostPosted: Fri Jan 13, 2006 10:13 pm    Post subject: Reply with quote

as far as I understand it you can have both blackdown and ibm-jdk on your system without confliction, I have a G3 ibook and am taking java devel classes at school.

I went with ibm-jdk just because blackdown is old and out of date (and alot slower from what I hear) and yes you have to goto ibm, register, and then download the package etc.

and place it in said directory then emerge ibm-jdk

my main problem right now is getting eclispe installed, altho I downloaded it from their site since I heard you have to manually install as portage doesnt have a solution as of yet that works on the ppc platform

I have it OpenOffice running fine with ibm-jdk 1.4*
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum