Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Where did PHP 5 go...?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Iron_DragonLord
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 273

PostPosted: Fri Jan 13, 2006 5:24 pm    Post subject: Where did PHP 5 go...? Reply with quote

Last I knew of, PHP (mod_php and dev-php/php) had version 5 and I originally didn't want it so I masked it. But now I need it and the version only goes up to 4.

Where did it go...?
Back to top
View user's profile Send private message
beandog
Bodhisattva
Bodhisattva


Joined: 04 May 2003
Posts: 2066
Location: /usa/utah

PostPosted: Fri Jan 13, 2006 5:41 pm    Post subject: Reply with quote

php5 is in dev-lang/php. It replaces dev-php/mod_php and dev-php/php
_________________
If it ain't broke, tweak it. dvds | blurays | blog | wiki
Back to top
View user's profile Send private message
Iron_DragonLord
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 273

PostPosted: Fri Jan 13, 2006 5:51 pm    Post subject: Reply with quote

beandog wrote:
php5 is in dev-lang/php. It replaces dev-php/mod_php and dev-php/php


So, they kind of combined them both into one ebuild?

See I tried looking for this info but it wasn't anywhere... It just seemed to randomly happen to me. And I was used to mod_php too.

All I need to do is emerge the dev-lang ebuild then right?
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 275

PostPosted: Fri Jan 13, 2006 7:25 pm    Post subject: Reply with quote

yes, but make sure you look at the use flags first, a lot of functionality that was in dev-php/php and mod_php is now optional by use flags. for example, no cli interpreter if you dont enable USE="cli", no apache module unless you have USE="apache2"
Back to top
View user's profile Send private message
Iron_DragonLord
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 273

PostPosted: Fri Jan 13, 2006 8:36 pm    Post subject: Reply with quote

Awesome, thanks!

Now I just need to look into getting both PHP4+5 working...
Back to top
View user's profile Send private message
llongi
Retired Dev
Retired Dev


Joined: 15 Apr 2004
Posts: 459
Location: Switzerland

PostPosted: Fri Jan 13, 2006 11:23 pm    Post subject: Reply with quote

It was mentioned once in the GWN and a number of times in the devs blogs, but atm the only "official" info/guide can be found at the PHP Overlay: http://svn.gnqs.org/projects/gentoo-php-overlay/file/docs/php-upgrading.html?format=raw
PHP4+PHP5 (possible combos etc.) are explained at the following link: http://svn.gnqs.org/projects/gentoo-php-overlay/file/docs/php4-php5-configuration.html?format=raw
We'll try to get that soon up on gentoo.org as well (like the Apache docs are now).
_________________
Best regards, Luca.
Back to top
View user's profile Send private message
Iron_DragonLord
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 273

PostPosted: Sat Jan 14, 2006 5:27 pm    Post subject: Reply with quote

Awesome!

Those helped a lot. I've got my stuff running perfectly now.

I hope they do get on the main page. Thanks. :D
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Feb 21, 2006 10:24 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum