Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem booting new install of Gentoo on dual-boot machine
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Ripster
n00b
n00b


Joined: 14 Jan 2006
Posts: 60
Location: In a flat spin mainly...

PostPosted: Sat Jan 14, 2006 3:51 pm    Post subject: Problem booting new install of Gentoo on dual-boot machine Reply with quote

Hello all

I'm having some problems installing Gentoo on a Compaq Presario 1609UK desktop. It has:

Sempron 3000+ processor
512 RAM
160 GB IDE drive (hda)
30 GB IDE drive (hdb)
Lite-On DVD+- writer
Creative CD-ROM
Built-in multimedia card reader

Win XP is installed on hda

I installed Gentoo onto the 30 gig drive using the Gentoo 2005.1 Universal install CD. Drive was partitioned as hdb1 50MB /boot, hdb2 1GB swap, hdb3 remaining space for / partition. Inbstallation was done exactly as per the guide at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml, except that I installed to hdb rather than hda (GRUB is on hda).

On final reboot I got this error:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Setting /sbin/udevsend as hotplug agent [OK]
Mounting devpts at /dev/pts [OK]
Activating (possible) swap [OK]
Remounting root filesystem read-only (if necessary) [OK]
Checking root filesystem...

fsck. ext3: No such file or directory while trying to open /dev/ROOT
/dev/ROOT:

The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:

e2fsk -b 8193 <device>

* Filesystem couldn't be fixed :(
Give root password for maintenance
(or type Control-D to continue):_ <blinking>

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


I tried editing /etc/fstab to read /dev/hdb3 instead of /dev/ROOT with nano but was told:

error writing /etc/fstab: read-only file system

Also, should the filesystem for / be ext2 rather than ext3? The installation guide states ext3, but the error described above suggests to me that it should be ext2...


This is the /etc/fstab listing:

# /etc/fstab: static file system information.
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.18.4.1 2005/01/31 23:05:14 vapier Exp $
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# See the manpage fstab(5) for more information.

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/BOOT /boot ext2 defaults,noatime 1 2
/dev/ROOT / ext3 noatime 0 1
/dev/SWAP none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,user 0 0
/dev/cdroms/cdrom1 /mnt/cdrom auto noauto,user
#/dev/fd0 /mnt/floppy auto noauto 0 0

# NOTE: The next line is critical for boot!
proc /proc proc defaults 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0


This is the /grub/grub.conf lisitng:

default 0
timeout 30
splashimage=(hd1,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.14-r5
root (hd1,0)
kernel /boot/kernel-genkernel-x86-2.6.14-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 udev
initrd /boot/initramfs-genkernel-x86-2.6.14-gentoo-r5

title=Windows XP
root (hd0,1)
makeactive
chainloader +1

title=Windows recovery
root (hd0,0)
makeactive
chainloader +1

WinXP boots fine from Grub. If after trying to boot Gentoo I then type halt at the command line (after the error described above has occured) the system will not shut down, I have to use the power key...

Output is:

Failed to cache service dependencies
error running '/sbin/depscan.sh'!
Please correct any problems above.
INIT: no more processes left in this runlevel

I've used Mandrake in the past, but have decided to switch to Gentoo, partly because Mdk 10 won't load on this new machine (I get a no CDROM found error - Mdk 9.2 will install just fine though). Knoppix 4.0 also runs fine, I'm using it now. Apologies for the long post but thought I should provide some detail. The command line is still something of a black art to me though so please be gentle!

Regards

Graham
_________________
Regards

Graham 'Rip' Townsend
Registered Linux user #254111

If at first you don't succeed, destroy any evidence that you ever tried
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Jan 14, 2006 3:56 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
Moved in favour of this thread
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum