Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -uD world, error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Sat Jan 14, 2006 7:02 pm    Post subject: emerge -uD world, error Reply with quote

How do i get past this?

Code:
# emerge -uD world
Calculating world dependencies ...done!

!!! Error: the <app-text/xpdf-3.01-r4 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.


Here is "emerge -uD world -p"

Code:
# emerge -uD world -p

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r4)
[ebuild     U ] sys-devel/gnuconfig-20051223 [20051113]
[ebuild     U ] sys-devel/gcc-config-1.3.13-r1 [1.3.12-r4]
[ebuild  N    ] virtual/libintl-0
[ebuild     U ] sys-libs/timezone-data-2005r [2005q]
[ebuild     U ] sys-libs/glibc-2.3.6-r2 [2.3.5-r3]
[ebuild     U ] sys-apps/man-pages-2.18 [2.17]
[ebuild  N    ] perl-core/Test-Simple-0.62
[ebuild     U ] dev-perl/Locale-gettext-1.05 [1.03]
[ebuild  N    ] app-misc/ca-certificates-20050804
[ebuild     U ] sys-apps/module-init-tools-3.2.1 [3.0-r2]
[ebuild     U ] sys-devel/libtool-1.5.22 [1.5.20]
[ebuild     U ] sys-process/psmisc-21.9 [21.6]
[ebuild     U ] app-editors/nano-1.3.9 [1.3.7]
[ebuild     U ] dev-libs/libgcrypt-1.2.2-r1 [1.2.1]
[ebuild  N    ] media-fonts/gnu-gs-fonts-std-8.11
[ebuild  N    ] x11-libs/cairo-1.0.2
[ebuild  N    ] dev-libs/glib-2.8.4
[ebuild  N    ] dev-libs/atk-1.10.3
[ebuild  N    ] x11-libs/pango-1.10.2
[ebuild  N    ] dev-perl/XML-Parser-2.34
[ebuild  N    ] dev-util/intltool-0.34.1
[ebuild  N    ] x11-misc/shared-mime-info-0.16
[ebuild  N    ] x11-libs/gtk+-2.8.8
[ebuild  N    ] app-text/ghostscript-esp-7.07.1-r8
[ebuild  N    ] app-text/poppler-0.4.3-r4
[ebuild     U ] net-print/cups-1.1.23-r7 [1.1.23-r4]
[ebuild     U ] perl-core/Storable-2.15 [2.13]
[ebuild     U ] dev-perl/PlRPC-0.2018 [0.2016-r1]
[ebuild     U ] dev-perl/DBI-1.48 [1.46]
#


EDIT: Do I need the ebuilds N? Can't I just install the packages that need updating?
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sat Jan 14, 2006 7:11 pm    Post subject: Reply with quote

About the blocking problem:

https://forums.gentoo.org/viewtopic-t-417036-highlight-xpdf+poppler.html
https://forums.gentoo.org/viewtopic-t-422757-highlight-xpdf+poppler.html
https://forums.gentoo.org/viewtopic-t-419844-highlight-xpdf+poppler.html
https://forums.gentoo.org/viewtopic-t-417872-highlight-xpdf+poppler.html

About the deps, you should use emerge -pv to see the use flags that you have activated. If you have USE="cairo" then there is nothing strange with that output. Emerge -pvt can help you determine wich packages are pulling all these New packages.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Jan 14, 2006 8:08 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum