Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge kdelibs?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Wed Jan 18, 2006 10:20 am    Post subject: emerge kdelibs? Reply with quote

hello all im having trouble emergeing kdelibs this is the error message i get, i think it might have something to do with my use flags:

.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_implE132_NS_14StdSynthModuleE+0xa8): undefined reference to `virtual thunk to Arts::StdSynthModule::start()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_implE132_NS_14StdSynthModuleE+0xac): undefined reference to `virtual thunk to Arts::StdSynthModule::stop()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_implE132_NS_14StdSynthModuleE+0xb0): undefined reference to `virtual thunk to Arts::StdSynthModule::streamInit()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_implE132_NS_14StdSynthModuleE+0xb4): undefined reference to `virtual thunk to Arts::StdSynthModule::streamStart()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_implE132_NS_14StdSynthModuleE+0xb8): undefined reference to `virtual thunk to Arts::StdSynthModule::streamEnd()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xe8): undefined reference to `virtual thunk to Arts::StdSynthModule::autoSuspend()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xec): undefined reference to `virtual thunk to Arts::StdSynthModule::start()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xf0): undefined reference to `virtual thunk to Arts::StdSynthModule::stop()'
.libs/kdatarequest_impl.o:(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xf8): undefined reference to `virtual thunk to Arts::StdSynthModule::streamStart()'
collect2: ld returned 1 exit status
make[3]: *** [libartskde.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3/arts/kde'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3/arts'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3'
make: *** [all] Error 2


this is my make.conf:

USE="
aac alsa
bmp bzip2
cdr cups cdinstall
dvd dvdr
encode
ffmpeg flac ftp
gif glut gnome gphoto gtk gtk2 gtkhtlm
ieee1394 imlib
java jpeg
mp3 mozilla mpeg msn mysql mono
ncurses
ogg ogvorbis openal opengl
pdflib php pic png python
quicktime
sdl soap spell svg
tiff truetype
usb
vcd videos vorbis win32codecs wmf
xine X xml xml2 xmms xpm xvid
"


cheers
Back to top
View user's profile Send private message
Hawkee
n00b
n00b


Joined: 20 Jun 2004
Posts: 50

PostPosted: Wed Jan 18, 2006 10:43 pm    Post subject: Reply with quote

Compiling kdelibs worked, but for some reason it tries to link against some ARTS libs.

Maybe an ebuild bug, or something wrong with your use flags.... maybe you used the "arts" flag once but changed it?

You should use "-arts" in /etc/make.conf and try to fix your system.

Code:
emerge --newuse world


and then

Code:
revdep-rebuild


might help. Be sure you dont have any "arts" flags specified in /etc/portage/package.use
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6378
Location: Graz / EU

PostPosted: Wed Jan 18, 2006 11:25 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

KDE 3.4.3 upgrade problems should help with your problem.
_________________
Dinosaur week! (Ok, this thread is so last week)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum