Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge unmerge xfce4 :-( [OPGELOST]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Wed Jan 18, 2006 7:23 pm    Post subject: emerge unmerge xfce4 :-( [OPGELOST] Reply with quote

Hoi,


Ik heb ooit xfce4 gebruikt, het ging allemaal goed. Toen had xfce4 weer verwijdert door emerge unmerge xfce4 uit te voeren, en nu wil ik weer xfce4 installieren. Hij installiert hem wel en hij start hem ook. De installatie process gaat heel snel , hij compielt niks.

Quote:

--- Invalid atom in /etc/portage/package.unmask: kde-base/kdeedu-meta-3.4.0
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta
Calculating dependencies ...done!
>>> emerge (1 of 1) xfce-base/xfce4-4.2.0 to /
>>> md5 files ;-) xfce4-4.2.1.1.ebuild
>>> md5 files ;-) xfce4-4.2.0.ebuild
>>> md5 files ;-) xfce4-4.0.6.ebuild
>>> md5 files ;-) xfce4-4.2.2.ebuild
>>> md5 files ;-) ChangeLog
>>> md5 files ;-) metadata.xml
>>> md5 files ;-) xfce4-4.2.1.ebuild
>>> md5 files ;-) files/digest-xfce4-4.0.6
>>> md5 files ;-) files/digest-xfce4-4.2.0
>>> md5 files ;-) files/digest-xfce4-4.2.1
>>> md5 files ;-) files/digest-xfce4-4.2.2
>>> md5 files ;-) files/digest-xfce4-4.2.1.1
>>> Unpacking source...
>>> Source unpacked.
* Meta Build, Nothing to compile.
>>> Test phase [not enabled]: xfce-base/xfce4-4.2.0

>>> Install xfce4-4.2.0 into /var/tmp/portage/xfce4-4.2.0/image/ category xfce-base
* Meta Build, Nothing to install.
man:
prepallstrip:
strip: i686-pc-linux-gnu-strip --strip-unneeded
>>> Completed installing xfce4-4.2.0 into /var/tmp/portage/xfce4-4.2.0/image/

>>> Merging xfce-base/xfce4-4.2.0 to /



De reden wrom in het begin geeft ie aan dat:

--- Invalid atom in /etc/portage/package.unmask: kde-base/kdeedu-meta-3.4.0
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta

omdat, ik heb het vervolgens geprobeerd om kde te installieren door het upgraden, ik volgd deze HOWTO upgrade from 3.3 to 3.4 of 3.5 http://gentoo-wiki.com/HOWTO_Update_KDE_3.3_to_KDE_3.4 . Maar het ging allemaal niet goed.

Kortom , ik heb het uitgepruts :x , in mijn xdm.log file heb de volgende gevonden:

Quote:

xf86AutoConfig: Primary PCI is 1:0:0
Running "/usr/bin/getconfig -X 60802000 -I /etc/X11,/usr/X11R6/etc/X11,/usr/lib/modules,/usr/X11R6/lib/X11/getconfig -v 0x10$
getconfig.pl: Version 1.0.
getconfig.pl: Xorg Version: 6.8.2.0.
getconfig.pl: 23 built-in rules.
getconfig.pl: rules file '/usr/X11R6/lib/X11/getconfig/xorg.cfg' has version 1.0.
getconfig.pl: 1 rule added from file '/usr/X11R6/lib/X11/getconfig/xorg.cfg'.
getconfig.pl: Evaluated 24 rules with 0 errors.
getconfig.pl: Weight of result is 500.
New driver is "nv"
(==) Using default built-in configuration (53 lines)
(EE) open /dev/fb0: Unknown error 999
sessions: SessionTypes=Xsession,kde-3.3.2,
Changing kdmrc in /usr/kde/*
/etc/X11/xdm/Xsetup_0: line 25: cd: /usr/kde/*/share/config/kdm: No such file or directory
Changing kdmrc in /usr
/etc/X11/xdm/Xsetup_0: line 25: cd: /usr/share/config/kdm: No such file or directory
xdm error (pid 6770): Trouble getting network interface configurationxdm error (pid 6770): Trouble getting network interface$




Het lijkt alsof de belangrike configuratie bestanden zijn verwijdert :wink: In iederee gevaal , als ik xfce4 weer verwijder door emerge unmerge xfce4 en dan als ik hem weer wil opstarten dan start hij hem ook op, dus hij deinstalliert hem niet helemaal. :( . Nou mijn vraag is eigenlijk hoe kan ervoor zorgen dat ik een schoone PC heb. Ik wil het even alle oudere configuratie bestanden verwijderen zowel kde en xfce4, en vervolgens opnieuw installieren zonder einige error.

En ik wil ook van die melding af:


--- Invalid atom in /etc/portage/package.unmask: kde-base/kdeedu-meta-3.4.0
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta
--- Invalid atom in /etc/portage/package.unmask: =kde-base/kde-meta

Ik heb het geprobeer om die pakketen van kde te unmasken, maar dat lukt mij nog steeds niet. :evil:

Can enyone help?

:o :o


Last edited by Azerix on Thu Jan 26, 2006 7:25 pm; edited 3 times in total
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Wed Jan 18, 2006 7:34 pm    Post subject: Reply with quote

De invalid atom dingen hebben hier niks mee te maken. De xfce4 ebuild is een meta ebuild die er alleen voor zorgt dat alle xfce4 packages worden geinstalleerd. Als je hem dus unmerged unmerged ie alleen deze meta ebuild die eigenlijk niks doet. Hij emerged niet de geinstalleerde xfce4 packages. Daarom ook als je hem her-emerged ziet ie dat alle onderdelen al geinstalleerd zijn en doet ie verder dus niks.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Wed Jan 18, 2006 8:10 pm    Post subject: Reply with quote

Klopt, de invalid atom heeft me niks mee te maken. Dat probleem heb ik al opgelost door de regel te verwijderen in /etc/portage/package.unmask.

Maar hoe zit dat met kde en xfce4 ? ik wil ze helemaal van PC uninstallen en verwijderen en vervolgens opneiuw installieren.
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Wed Jan 18, 2006 8:13 pm    Post subject: Reply with quote

kde:
Code:
equery list kde-base/ | grep kde | xargs emerge --unmerge --pretend

Remove the pretend once you checked the list

xfce4:
Code:
equery list xfce-base/ | grep xf | xargs emerge --unmerge --pretend

Remove the pretend once you checked the list

Edit: Various mistakes
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Wed Jan 18, 2006 8:24 pm    Post subject: Reply with quote

Hehe , :) nu verwijdert hij hem well, eindelijk :P . Maar hoe komt dat dat niet verijderd door uit te voeren emerge unmerge kde?
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Wed Jan 18, 2006 8:29 pm    Post subject: Reply with quote

Omdat kde dus een meta packages is. Op het moment heeft portage nog geen reverse dependency checking. Bv

Stel we hebben package A dat depend op package B. Als je nu package A emerged dan haalt ie meteen package B ook binnen. Als je nu package A unmerged dan blijft package B staan ookal heb je dat niet meer nodig. Dit is omdat er ook een package C kan zijn dat op package B depend, je kan dus niet zonder meer package B weghalen.

Package kde is dus gewoon een ebuild die depend op alle verschillende kde packages, dus als je kde emerged dan emerged ie alle aparte kde packages (omdat kde daarop depend), maar als je kde nu unmerged unmerged ie niet alle kde packages.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Wed Jan 18, 2006 8:52 pm    Post subject: Reply with quote

Oohh zo :o , dus zo werkt het eingelijk, eindelijk van die probleem af :P

Weer wat geleerd, voor de volgende keer als ik zelfde problemen krijg met andere software die meta packages zijn. :wink:

Dankje well
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Thu Jan 19, 2006 8:03 am    Post subject: Reply with quote

Help het dan niet als je emerge laat scannen op overbodige pakketten?
Dan zou je je systeem toch kunnen opschonen van overbodige pakketten waaronder dan alle dependencies van KDE?

Of werkt dat niet op die manier?
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Thu Jan 19, 2006 10:34 am    Post subject: Reply with quote

Ja je kan ook alle overbodige dingen weghalen met emerge depclean, dit kan alleen soms gevaarlijk zijn, vooral als je use flags hebt verandert etc. De goede manier om dat te doen is:
Code:
emerge --newuse world
emerge depclean -p
emerge depclean
revdep-rebuild -p
revdep-rebuild
Dubbel check de output (hij wil nog weleens dhcpcd deinstalleren, omdat die vroeger in de system pacakges zat en nu niet meer). Voordat je dit doet kan je nog even de world file (/var/lib/portage/world) editten en alle packages die je wil deinstalleren eruit gooien.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Thu Jan 19, 2006 2:30 pm    Post subject: Reply with quote

Ik heb het nog een probleem met emerge, ik wil ethereal installieren, maar ik krijg error 404.

Quote:

Calculating dependencies ...done!
>>> emerge (1 of 1) net-analyzer/ethereal-0.10.11 to /
>>> Downloading ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/ethereal- 0.10.11.tar.bz2
--16:11:46-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/ethereal-0. 10.11.tar.bz2
=> `/usr/portage/distfiles/ethereal-0.10.11.tar.bz2'
Resolving ftp.snt.utwente.nl... 130.89.175.1, 2001:610:1908:8000::175:1
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/os/linux/gentoo/distfiles ... done.
==> PASV ... done. ==> RETR ethereal-0.10.11.tar.bz2 ...
No such file `ethereal-0.10.11.tar.bz2'.

>>> Downloading http://www.ethereal.com/distribution/ethereal-0.10.11.tar.bz2
--16:11:47-- http://www.ethereal.com/distribution/ethereal-0.10.11.tar.bz2
=> `/usr/portage/distfiles/ethereal-0.10.11.tar.bz2'
Resolving www.ethereal.com... 65.208.228.223
Connecting to www.ethereal.com[65.208.228.223]:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:11:48 ERROR 404: Not Found.

!!! Couldn't download ethereal-0.10.11.tar.bz2. Aborting.



Ik heb in ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/ gekeken, en versie 11 is niet meer beschikbaar, alleen
0.10.13 en 14, ik denk ik moet mijn systeem update , zo dat ie de nieuwste versie pakt :? Moet ik mijn systeem updaten zo wel ? of weer een andere commando opgeven om te installieren :o ?
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Thu Jan 19, 2006 2:49 pm    Post subject: Reply with quote

De makkelijkste weg is inderdaad een emerge sync draaien.
De moeilijkere weg is het zoeken op internet of je nog ergens een versie 11 kunt bemachtigen. Deze dan handmatig in /usr/portage/distfiles zetten. Emerge kijkt daar altijd eerst voor het begint te downloaden.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Thu Jan 19, 2006 2:53 pm    Post subject: Reply with quote

Ik heb het ooit geprobeerd om ebuild voor mailscanner te platsen en het ging niet makkelijk, maar is emerge sync veilig? :o
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Thu Jan 19, 2006 3:03 pm    Post subject: Reply with quote

8O 8O 8O 8O 8O
Ooit je systeem geupdated????

Ik zou het maar gewoon proberen. Zal je verassen hoe ver je systeem achterloopt bij de huidige stand der techniek.

emerge sync vertaald zich als emerge synchronize. Het update je portage tree zodat het weet wat er te krijgen is in de wereld. Daarna even
Code:
emerge -Dup system
en
emerge -Dup world
en
etc-update

uitvoeren en je systeem werkt weer met de nieuwste pakketjes.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Thu Jan 19, 2006 3:20 pm    Post subject: Reply with quote

Nee , dit is voor het eerst keer dat ik mijn systeem update :D

Maar ik kreeg naar emerge syn het volgende bericht:

Quote:


>>> Updating Portage cache: 90%!!! Cannot resolve a virtual package name to an ebuild.
!!! This is a bug, please report it. (virtual/libintl-0)


Ik weet niet of het normaal is omdat bericht te krijgen, maar in iederee gevaal paar paketten zijn geupdate.
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Fri Jan 20, 2006 7:49 am    Post subject: Reply with quote

check eens emerge -Dup system en kijk of daar portage tussen staat. Dan kun je die namelijk beter als eerste even updaten door emerge -Du portage. Vervolgens opnieuw emerge sync uitvoeren. Dit kun je in principe ongelimiteerd doen. De meeste sync servers blokken je overigens als je dit meer dan 10 keer per uur doet :P

De foutmelding is niet goed, maar aangezien je met een nog relatief oud systeem van portage lijkt te werken kan deze bug al zijn opgelost.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 22, 2006 12:42 am    Post subject: Reply with quote

Ik krijg nog steeds de zelfde bericht.
Quote:


>>> Updating Portage cache: 90%!!! Cannot resolve a virtual package name to an ebuild.
!!! This is a bug, please report it. (virtual/libintl-0)

Maar ik ben toch door gaan met installatie van kde, Ik had emerge kde-meta uitgevoerd, maar hij is opgegeven moment gestopt en kree de volgende error:

Quote:

In file included from opener.cpp:72:
/usr/include/linux/if_ppp.h:90: error: use of enum `NPmode' without previous
declaration
/usr/include/linux/if_ppp.h:95: error: syntax error before `*' token
/usr/include/linux/if_ppp.h:96: error: '__u32' is used as a type, but is not
defined as a type.
/usr/include/linux/if_ppp.h:101: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:102: error: field `stats' has incomplete type
/usr/include/linux/if_ppp.h:106: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:107: error: field `stats' has incomplete type
opener.cpp: In function `int checkForInterface()':
opener.cpp:659: error: aggregate `ifreq ifr' has incomplete type and cannot be
defined
make[3]: *** [opener.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kppp-3.4.3 failed.
!!! Function kde_src_compile, Line 175, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.



Ik denk dat het heeft temaken met updaten van systeem. :? Of er is iets dat blokeert hem om die pakketen te installieren. Want als ik deze opdracht geef emerge --pretend kde | less om te zien wat ie allemaal installiert, zo te zien er zijn paar paketten die worden geblokeert

Quote:

[blocks B ] =kde-base/kget-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/kdnssd-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/krfb-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/krdc-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/librss-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/dcoprss-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/ksirc-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/kdict-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/kdenetwork-filesharing-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/knewsticker-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/ktalkd-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/kopete-3.4* (is blocking kde-base/kdenetwork-3.4.3)
[blocks B ] =kde-base/khexedit-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kjots-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kgpg-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/klaptopdaemon-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kmilo-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kedit-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kdf-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kcalc-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kfloppy-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kregexpeditor-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kcharselect-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kwalletmanager-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/ktimer-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/ark-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/ksim-3.4* (is blocking kde-base/kdeutils-3.4.3-r1)
[blocks B ] =kde-base/kalzium-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/keduca-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kvoctrain-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kverbos-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/libkdeedu-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kiten-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kbruch-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kig-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kstars-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/ktouch-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/klatin-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kmplot-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kdeedu-applnk-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kturtle-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kwordquiz-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/khangman-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/klettres-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kmessedwords-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[blocks B ] =kde-base/kpercentage-3.4* (is blocking kde-base/kdeedu-3.4.3-r10)
[ebuild U ] sys-libs/cracklib-2.8.5 [2.7-r11]
[ebuild U ] sys-libs/pam-0.78-r3 [0.77-r6]
[ebuild N ] kde-base/kdebase-pam-6
[ebuild N ] sys-apps/eject-2.0.13-r2
[ebuild N ] kde-base/kdebase-3.4.3-r1
[ebuild N ] dev-libs/pth-1.4.0
[ebuild N ] app-crypt/gpgme-1.0.2
[ebuild N ] kde-base/kdepim-3.4.3
[ebuild N ] kde-base/kdegames-3.4.3
[ebuild N ] kde-base/kdeartwork-3.4.3
[ebuild N ] kde-base/kdenetwork-3.4.3
[ebuild U ] sys-devel/automake-1.9.6-r1 [1.9.5]
[ebuild N ] app-text/poppler-0.4.3-r4
[ebuild N ] dev-libs/fribidi-0.10.4
[ebuild N ] media-libs/giflib-4.1.4
[ebuild N ] media-libs/imlib-1.9.14-r3
[ebuild N ] kde-base/kdegraphics-3.4.3-r3
[ebuild N ] kde-base/kdetoys-3.4.3
[ebuild N ] kde-base/kdeutils-3.4.3-r1
[ebuild N ] kde-base/kdewebdev-3.4.3-r1
[ebuild N ] kde-base/kdeadmin-3.4.3
[ebuild N ] dev-lang/nasm-0.98.39-r1
[ebuild N ] media-libs/libsdl-1.2.8-r1
[ebuild N ] gnome-base/orbit-2.12.3
[ebuild N ] gnome-base/gconf-2.10.1-r1
[ebuild N ] media-libs/gstreamer-0.8.10
[ebuild N ] media-libs/gst-plugins-0.8.10
[ebuild N ] media-plugins/gst-plugins-ogg-0.8.10
[ebuild N ] media-plugins/gst-plugins-oss-0.8.10
[ebuild N ] media-libs/libao-0.8.5
[ebuild N ] media-sound/vorbis-tools-1.0.1
[ebuild N ] media-sound/lame-3.96.1
[ebuild N ] sci-libs/fftw-3.0.1-r2
[ebuild N ] media-libs/libsamplerate-0.1.1-r1
[ebuild N ] media-plugins/gst-plugins-vorbis-0.8.10
[ebuild N ] media-libs/taglib-1.4
[ebuild N ] media-sound/cdparanoia-3.9.8-r2
[ebuild N ] media-plugins/gst-plugins-mad-0.8.10
[ebuild N ] kde-base/kdemultimedia-3.4.3
[ebuild N ] kde-base/kdeaddons-3.4.3
[ebuild N ] kde-base/kdeedu-3.4.3-r10
[ebuild N ] kde-base/kde-3.4.3


:? :?
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Sun Jan 22, 2006 8:52 pm    Post subject: Reply with quote

Probeer eens kde 3.5.0? Werkt prima hierzo.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 22, 2006 9:23 pm    Post subject: Reply with quote

Maar om naar KDE 3.5 te upgraden, ik moet wel eerst KDE geinstalleerd hebben, anders kan ik niet upgraden en als ik emerge kde-base -p uitvoer, dan pakt hij automatisch 3.4 . Ik heb geen 3.5 in de portage tree, denk ik. :?
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Sun Jan 22, 2006 10:58 pm    Post subject: Reply with quote

je moet kde-meta gebruiken. Kde probeert de monolithic build te bouwen, terwijl je ze te zien al hoop pakketen van de gesplitste ebuild hebt geinstalleerd
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 22, 2006 11:42 pm    Post subject: Reply with quote

doe ik ook, ik geef deze opdracht emerge kde-meta :? Hij installeert hem niet helemaal, hij stopt en ik krijg een error :

Quote:

In file included from opener.cpp:72:
/usr/include/linux/if_ppp.h:90: error: use of enum `NPmode' without previous
declaration
/usr/include/linux/if_ppp.h:95: error: syntax error before `*' token
/usr/include/linux/if_ppp.h:96: error: '__u32' is used as a type, but is not
defined as a type.
/usr/include/linux/if_ppp.h:101: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:102: error: field `stats' has incomplete type
/usr/include/linux/if_ppp.h:106: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:107: error: field `stats' has incomplete type
opener.cpp: In function `int checkForInterface()':
opener.cpp:659: error: aggregate `ifreq ifr' has incomplete type and cannot be
defined
make[3]: *** [opener.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kppp-3.4.3 failed.
!!! Function kde_src_compile, Line 175, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.

Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Mon Jan 23, 2006 10:58 am    Post subject: Reply with quote

Azerix wrote:
Maar om naar KDE 3.5 te upgraden, ik moet wel eerst KDE geinstalleerd hebben, anders kan ik niet upgraden en als ik emerge kde-base -p uitvoer, dan pakt hij automatisch 3.4 . Ik heb geen 3.5 in de portage tree, denk ik. :?

Uhm, je moet kde 3.5 even unmasken.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Mon Jan 23, 2006 6:04 pm    Post subject: Reply with quote

Ik doe het volgens de handleiding, ik voer deze opdrachten:
Quote:

echo "=kde-base/kde-meta-3.5.0" >> /etc/portage/package.unmask

Quote:

echo "kde-base/kde-meta-3.5.0" >> /etc/portage/package.keywords


en als ik vervolgens emerge -u kde-meta uitvoer, dan pakt hij zo en zo kde-base/kde-meta-3.4.3. kan het zijn dat de systeem is niet goed geupdate?
:?
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Mon Jan 23, 2006 7:56 pm    Post subject: Reply with quote

Azerix wrote:
Ik doe het volgens de handleiding, ik voer deze opdrachten:
Quote:

echo "=kde-base/kde-meta-3.5.0" >> /etc/portage/package.unmask

Quote:

echo "kde-base/kde-meta-3.5.0" >> /etc/portage/package.keywords


en als ik vervolgens emerge -u kde-meta uitvoer, dan pakt hij zo en zo kde-base/kde-meta-3.4.3. kan het zijn dat de systeem is niet goed geupdate?
:?

1. de tweede echo heb je fout, je vergeet een =
2. kde meta bestaat uit zo'n ~300 pakketjes, waarvan kde-meta zelf dus alleen maar een meta ebuild is.
Dit is de lijst, copy-paste hem in je package.keywords en dat komt verder wel goed.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Mon Jan 23, 2006 8:11 pm    Post subject: Reply with quote

Ok , nu pakt hij 3.5.0 versie, alleen ik hoop dat ik niet de zelfde error krijg toen die 3.4 installerde

Quote:

In file included from opener.cpp:72:
/usr/include/linux/if_ppp.h:90: error: use of enum `NPmode' without previous
declaration
/usr/include/linux/if_ppp.h:95: error: syntax error before `*' token
/usr/include/linux/if_ppp.h:96: error: '__u32' is used as a type, but is not
defined as a type.
/usr/include/linux/if_ppp.h:101: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:102: error: field `stats' has incomplete type
/usr/include/linux/if_ppp.h:106: error: field `b' has incomplete type
/usr/include/linux/if_ppp.h:107: error: field `stats' has incomplete type
opener.cpp: In function `int checkForInterface()':
opener.cpp:659: error: aggregate `ifreq ifr' has incomplete type and cannot be
defined
make[3]: *** [opener.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3/kppp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kppp-3.4.3/work/kppp-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kppp-3.4.3 failed.
!!! Function kde_src_compile, Line 175, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


Dat ie eene pakket niet wou installeren
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Mon Jan 23, 2006 8:17 pm    Post subject: Reply with quote

Azerix wrote:
Ok , nu pakt hij 3.5.0 versie, alleen ik hoop dat ik niet de zelfde error krijg toen die 3.4 installerde

Quote:

Blablabla

!!! ERROR: kde-base/kppp-3.4.3 failed.

Blablabla


Dat ie eene pakket niet wou installeren

Probeer eens kppp 3.5.0?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum