Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
samba/cups pulls Xorg [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
elagano
n00b
n00b


Joined: 24 Jan 2006
Posts: 2

PostPosted: Tue Jan 24, 2006 3:14 am    Post subject: samba/cups pulls Xorg [SOLVED] Reply with quote

I've seen some topics on this issue, but none of the solutions provided worked for me.

When I try to emerge samba and/or cups, portage tries to pull some X11 stuff, which I obviously do not need.
Any ideas on why this might be happening:

srv data # emerge -pvt cups

These are the packages that I would merge, in reverse order:

Calculating dependencies ...done!
[ebuild N ] net-print/cups-1.1.23-r7 -cjk -gnutls +nls +pam -samba -slp +ssl 8,501 kB
[ebuild N ] media-libs/tiff-3.7.3 1,242 kB
[ebuild N ] app-text/poppler-0.4.3-r4 -cairo +jpeg +zlib 806 kB
[ebuild U ] sys-devel/automake-1.9.6-r1 [1.9.5] 747 kB
[ebuild N ] app-text/ghostscript-esp-7.07.1-r8 -X -cjk +cups -emacs +gtk 5,273 kB
[ebuild N ] media-fonts/gnu-gs-fonts-std-8.11 3,664 kB
[ebuild N ] x11-libs/gtk+-2.8.8 -debug -doc +jpeg -tiff 11,627 kB
[ebuild N ] x11-misc/shared-mime-info-0.16 735 kB
[ebuild N ] dev-libs/libxml2-2.6.23 -debug -doc -ipv6 +python +readline 3,338 kB
[ebuild N ] dev-util/intltool-0.34.1 127 kB
[ebuild N ] dev-perl/XML-Parser-2.34 224 kB
[ebuild N ] x11-libs/pango-1.10.2 -debug -doc 1,141 kB
[ebuild N ] dev-libs/atk-1.10.3 -debug -doc -static 529 kB
[ebuild N ] x11-terms/xterm-207 -Xaw3d -doc -toolbar +truetype +unicode 727 kB
[ebuild N ] sys-apps/utempter-0.5.5.6 20 kB
[ebuild N ] app-arch/rpm2targz-9.0-r3 2 kB
[ebuild N ] virtual/x11-6.8 0 kB
[ebuild N ] x11-base/xorg-x11-6.8.2-r6 -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -insecure-drivers -ipv6 -minimal -mmx +nls -nocxx +opengl +pam -sdk -sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 45,134 kB
[ebuild N ] x11-base/opengl-update-2.2.1 38 kB
[ebuild N ] x11-apps/ttmkfdir-3.0.9-r3 19 kB
[ebuild N ] dev-libs/glib-2.8.5 -debug -doc -hardened 2,532 kB
[ebuild N ] x11-libs/cairo-1.0.2 -X -doc -glitz +png 1,424 kB
[ebuild N ] media-libs/libpng-1.2.8 -doc 375 kB
[ebuild N ] media-libs/fontconfig-2.2.3 732 kB
[ebuild N ] media-libs/freetype-2.1.9-r1 -bindist -doc +zlib 969 kB
[ebuild N ] media-libs/jpeg-6b-r5 598 kB

I do not see a tree here on the forum, while I do see it while editing this message :-O

srv data # cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-Os -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="-tcltk -eds -X -ipv6 -motif unicode"
Back to top
View user's profile Send private message
elagano
n00b
n00b


Joined: 24 Jan 2006
Posts: 2

PostPosted: Tue Jan 24, 2006 3:23 am    Post subject: Reply with quote

-gtk did it.

Sorry
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Jan 24, 2006 3:30 am    Post subject: Reply with quote

Sent to Duplicates in favour of https://forums.gentoo.org/viewtopic.php?t=53808
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum