Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg 6.9 Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
SolidSnakex28
Apprentice
Apprentice


Joined: 03 Sep 2005
Posts: 269
Location: New York

PostPosted: Fri Jan 27, 2006 6:04 am    Post subject: Xorg 6.9 Error Reply with quote

Whenever I try to emerge xf86-video-vesa, I get the following:

Code:
Error: the <=x11-base/xorg-x11-6.9 package conflicts with another package. both can't be installed on the same system together.


I don't have xorg installed anymore, and the one I just unmerged was 6.8! What's going on?
Back to top
View user's profile Send private message
Mr. Ego
n00b
n00b


Joined: 18 Jul 2005
Posts: 24
Location: Czech Republic

PostPosted: Fri Jan 27, 2006 7:08 am    Post subject: Reply with quote

I'm not much experienced with Gentoo, but i think xf86-video-vesa depends on x11-base/xorg-x11-6.9 or higher (it should, its description says that it's "X.Org driver for vesa cards". That means some package blocks x11-base/xorg-x11-6.9. You can find it with emerge --pretend --verbose xf86-video-vesa.
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Fri Jan 27, 2006 5:07 pm    Post subject: Reply with quote

Up to R6.9, X.org was one huge package. From R7 on, it's split in hundreds of small ones. So, if you have xorg-x11-6.8 installed, you don't need it.
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 29, 2006 12:37 am    Post subject: Reply with quote

i am getting the same error, i am trying to install xdm, but i get this error

Quote:

Calculating dependencies ...done!
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.4)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libICE-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libSM-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXt-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xdm-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXext-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXmu-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrdb-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-wm/twm-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xinit-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xclock-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbfile-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXft-2.1.8.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXpm-3.5.4.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXaw-1.0.1)
[ebuild U ] sys-apps/man-1.6b-r2 [1.5p] +nls 233 kB
[ebuild U ] dev-util/pkgconfig-0.20 [0.17.2-r1] -hardened 947 kB
[ebuild N ] x11-proto/kbproto-1.0.2 56 kB
[ebuild N ] x11-proto/xextproto-7.0.2 66 kB
[ebuild N ] x11-proto/xproto-7.0.4 124 kB
[ebuild N ] x11-proto/xf86bigfontproto-1.1.2 36 kB
[ebuild N ] x11-misc/util-macros-1.0.1 37 kB
[ebuild N ] x11-proto/inputproto-1.3.2 45 kB
[ebuild N ] x11-libs/libXau-1.0.0 206 kB
[ebuild N ] x11-proto/bigreqsproto-1.0.2 35 kB
[ebuild N ] x11-libs/libXdmcp-1.0.0 205 kB
[ebuild N ] x11-proto/xcmiscproto-1.1.2 35 kB
[ebuild N ] x11-libs/xtrans-1.0.0 86 kB
[ebuild N ] x11-libs/libX11-1.0.0 +ipv6 1,365 kB
[ebuild N ] x11-libs/libICE-1.0.0 +ipv6 232 kB
[ebuild N ] x11-libs/libSM-1.0.0 +ipv6 213 kB
[ebuild N ] x11-libs/libXt-1.0.0 483 kB
[ebuild N ] x11-libs/libXext-1.0.0 242 kB
[ebuild N ] x11-libs/libXmu-1.0.0 +ipv6 272 kB
[ebuild N ] x11-apps/xrdb-1.0.1 83 kB
[ebuild N ] x11-wm/twm-1.0.1 218 kB
[ebuild N ] x11-libs/libxkbfile-1.0.1 252 kB
[ebuild N ] x11-proto/renderproto-0.9.2 39 kB
[ebuild N ] x11-libs/libXrender-0.9.0.2 213 kB
[ebuild N ] x11-libs/libXft-2.1.8.2 239 kB
[ebuild N ] x11-libs/libXpm-3.5.4.2 342 kB
[ebuild N ] sys-apps/ed-0.2-r6 181 kB
[ebuild N ] x11-libs/libXaw-1.0.1 -xprint 505 kB
[ebuild N ] x11-apps/xclock-1.0.1 -xprint 97 kB
[ebuild N ] x11-apps/xinit-1.0.1 90 kB
[ebuild N ] x11-apps/xdm-1.0.1 +ipv6 +pam -xprint 332 kB

Total size of downloads: 7,526 kB

!!! Error: The above package list contains packages which cannot be installed
!!! on the same system.



:?
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Sun Jan 29, 2006 12:39 am    Post subject: Reply with quote

Can you please add -tv to the emerge options?
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 29, 2006 12:48 am    Post subject: Reply with quote

emerge -atv xdm

Quote:

Calculating dependencies ...done!
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXaw-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXpm-3.5.4.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXft-2.1.8.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbfile-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xclock-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xinit-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-wm/twm-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrdb-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXmu-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXext-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xdm-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXt-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libSM-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libICE-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.4)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.2)
[ebuild N ] x11-apps/xdm-1.0.1 +ipv6 +pam -xprint 332 kB
[ebuild N ] x11-apps/xinit-1.0.1 90 kB
[ebuild N ] x11-apps/xclock-1.0.1 -xprint 97 kB
[ebuild N ] x11-libs/libXaw-1.0.1 -xprint 505 kB
[ebuild N ] sys-apps/ed-0.2-r6 181 kB
[ebuild N ] x11-libs/libXpm-3.5.4.2 342 kB
[ebuild N ] x11-libs/libXft-2.1.8.2 239 kB
[ebuild N ] x11-libs/libXrender-0.9.0.2 213 kB
[ebuild N ] x11-proto/renderproto-0.9.2 39 kB
[ebuild N ] x11-libs/libxkbfile-1.0.1 252 kB
[ebuild N ] x11-wm/twm-1.0.1 218 kB
[ebuild N ] x11-apps/xrdb-1.0.1 83 kB
[ebuild N ] x11-libs/libXmu-1.0.0 +ipv6 272 kB
[ebuild N ] x11-libs/libXext-1.0.0 242 kB
[ebuild N ] x11-libs/libXt-1.0.0 483 kB
[ebuild N ] x11-libs/libSM-1.0.0 +ipv6 213 kB
[ebuild N ] x11-libs/libICE-1.0.0 +ipv6 232 kB
[ebuild N ] x11-libs/libX11-1.0.0 +ipv6 1,365 kB
[ebuild N ] x11-libs/xtrans-1.0.0 86 kB
[ebuild N ] x11-proto/xcmiscproto-1.1.2 35 kB
[ebuild N ] x11-libs/libXdmcp-1.0.0 205 kB
[ebuild N ] x11-proto/bigreqsproto-1.0.2 35 kB
[ebuild N ] x11-libs/libXau-1.0.0 206 kB
[ebuild N ] x11-proto/inputproto-1.3.2 45 kB
[ebuild N ] x11-misc/util-macros-1.0.1 37 kB
[ebuild N ] x11-proto/xf86bigfontproto-1.1.2 36 kB
[ebuild N ] x11-proto/xproto-7.0.4 124 kB
[ebuild N ] x11-proto/xextproto-7.0.2 66 kB
[ebuild N ] x11-proto/kbproto-1.0.2 56 kB
[ebuild U ] dev-util/pkgconfig-0.20 [0.17.2-r1] -hardened 947 kB
[ebuild U ] sys-apps/man-1.6b-r2 [1.5p] +nls 233 kB

Total size of downloads: 7,526 kB

!!! Error: The above package list contains packages which cannot be installed
!!! on the same system.

Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Sun Jan 29, 2006 1:20 am    Post subject: Reply with quote

There's a Modular X Upgrade HOWTO - Try following that.

Allen
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Sun Jan 29, 2006 1:36 pm    Post subject: Reply with quote

I am folowing the howto, at the end of step 2 emerge xorg-x11 But i get 2 errors:

Quote:


mkfontscale.c:34:21: X11/Xos.h: No such file or directory
make[1]: *** [mkfontscale-mkfontscale.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mkfontscale-1.0.1/work/mkfontscale-1.0.1'
make: *** [all] Error 2

!!! ERROR: x11-apps/mkfontscale-1.0.1 failed.
!!! Function x-modular_src_make, Line 241, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.



Same error if i wont to install kdm,

ct file: No such file or directory
configure: error: /usr/kde/3.5/bin/kde-config --prefix outputed the non existant prefix '' for kdelibs.
This means it has been moved since you installed it.
This won't work. Please recompile kdelibs for the new prefix.


!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/kdm-3.5.0/work/kdm-3.5.0/config.log

!!! ERROR: kde-base/kdm-3.5.0 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
linear
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 220

PostPosted: Thu Mar 23, 2006 12:35 am    Post subject: Reply with quote

So, let me see if I understand this correctly:

If you currently have a version of xorg-x11 that is before 6.9.x, you will not be able to install any new packages until you upgrade your entire xorg to the Modularized X.

Is this correct?
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Thu Mar 23, 2006 12:47 am    Post subject: Reply with quote

No. Monolithic X still works fine.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
linear
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 220

PostPosted: Thu Mar 23, 2006 9:53 pm    Post subject: Reply with quote

Hmmmm...

Then something seems to be wrong here.

We have several systems here running Gentoo and all of them running xorg-x11 <=6.8.2. I went to build xdm on one of the systems and was getting the following errors:
Code:
ssrv1 cfgs # emerge -pv xdm
These are the packages that I would merge, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "xdm" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-apps/xdm-1.0.1 (masked by: ~amd64 keyword)
# Donnie Berkholz <spyderous@gentoo.org> (07 Aug 2005)
# Modularized X, upstream release candidates


For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

ssrv1 cfgs # ACCEPT_KEYWORDS="~amd64" emerge -pv xdm

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xdm-1.0.1)
[ebuild  N    ] x11-apps/xdm-1.0.1  USE="ipv6 pam xprint -debug" 0 kB

Total size of downloads: 0 kB
ssrv1 cfgs #


I get similar results when I do a check to build it on any of the Gentoo systems we have. So, what exactly is going on here?

And is Modular X considered truly stable yet?
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Thu Mar 23, 2006 10:02 pm    Post subject: Reply with quote

Modular X is in ~arch for most arches (since today). It is not stable on any arch.

xdm is part of monolithic X; you don't need to emerge it separately.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
linear
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 220

PostPosted: Thu Mar 23, 2006 11:46 pm    Post subject: Reply with quote

Ah, yes....

Confusing home (where I built Xgl) with here.

Thanks for the quick answers! :)

/bk
Back to top
View user's profile Send private message
Fraggy
n00b
n00b


Joined: 23 Sep 2003
Posts: 13
Location: Harrisonburg, VA

PostPosted: Mon Mar 27, 2006 7:19 pm    Post subject: Reply with quote

I've experienced a similar problem, though I would very much like to stay with the stable version of xorg. Here is the output of my 'emerge -uvp world'

Code:
Calculating world dependencies /
!!! Packages for the following atoms are either all
!!! masked or don't exist:
x11-misc/e17genmenu

... done!

[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-elographics-1.0.0.5)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[...]
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-mutouch-1.0.0.5)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-apm-1.0.1.5)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-mouse-1.0.4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-i810-1.4.1.3)
INCOMPLETE MERGE: /var/db/pkg/sys-devel/-MERGING-gnuconfig-20051223
[ebuild     U ] sys-apps/portage-2.1_pre7-r2 [2.1_pre7-r1] USE="-build -doc" 0 kB
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.16  USE="-build -doc -symlink" 0 kB
[ebuild     U ] media-libs/alsa-lib-1.0.11_rc4 [1.0.11_rc3] USE="-doc -jack" 687 kB
[ebuild     U ] media-sound/alsa-utils-1.0.11_rc4 [1.0.11_rc2] USE="nls" 964 kB
[ebuild     U ] net-www/netscape-flash-7.0.63 [7.0.61] 997 kB
[ebuild     U ] app-cdr/mdf2iso-0.3.0-r1 [0.3.0] 0 kB
[ebuild  N    ] x11-misc/linuxwacom-0.7.2  USE="gtk gtk2 usb -dlloader -sdk -tcltk" 763 kB
[ebuild  N    ] x11-misc/util-macros-1.0.1  USE="-debug" 37 kB
[ebuild  N    ] x11-proto/xproto-7.0.4  USE="-debug" 124 kB
[ebuild  N    ] x11-proto/inputproto-1.3.2  USE="-debug" 45 kB
[...]
[ebuild  N    ] x11-drivers/xf86-input-mutouch-1.0.0.5  USE="-debug" 219 kB
[ebuild  N    ] x11-drivers/xf86-video-apm-1.0.1.5  USE="-debug" 252 kB
[ebuild  N    ] x11-drivers/xf86-input-mouse-1.0.4  USE="-debug" 245 kB
[ebuild  N    ] x11-drivers/xf86-video-i810-1.4.1.3  USE="dri -debug" 368 kB
[ebuild     U ] x11-base/xorg-x11-7.0-r1 [6.8.2-r6] INPUT_DEVICES="-acecad% -aiptek% -calcomp% -citron% -digitaledge% -dmc% -dynapro% -elo2300% -elographics% -evdev% -fpit% -hyperpen% -jamstudio% -joystick% -keyboard% -magellan% -magictouch% -microtouch% -mouse% -mutouch% -palmax% -penmount% -spaceorb% -summa% -synaptics% -tek4957% -ur98% -vmmouse% -void% -wacom%" VIDEO_CARDS="-apm% -ark% -ati% -chips% -cirrus% -cyrix% -dummy% -fbdev% -fglrx% -glint% -i128% -i810% -mga% -neomagic% -nv% -nvidia% -rendition% -s3% -s3virge% -savage% -siliconmotion% -sis% -sisusb% -tdfx% -tga% -trident% -tseng% -v4l% -vesa% -vga% -via% -vmware% -voodoo%" 0 kB
[ebuild     U ] media-video/nvidia-glx-1.0.8178-r1 [1.0.8178] USE="-dlloader" 0 kB
[ebuild     U ] sys-devel/gcc-3.4.6 [3.4.5] USE="fortran gtk nls -bootstrap -boundschecking -build -doc% -gcj -hardened -ip28 -multislot -nocxx -nopie -nossp -objc -vanilla" 27,653 kB
[ebuild     U ] x11-wm/fluxbox-0.9.15 [0.9.14-r1] USE="imlib nls -disableslit -gnome -kde* -truetype -xinerama" 669 kB
[ebuild  NS   ] sys-kernel/ck-sources-2.6.16_p1  USE="-build -ck-server -doc -symlink" 49 kB
[ebuild  NS   ] dev-db/phpmyadmin-2.8.0.2  USE="-vhosts" 1,963 kB
[ebuild     U ] sys-libs/readline-5.1_p4 [5.1_p3] 2 kB
[ebuild     U ] www-client/mozilla-launcher-1.51 [1.50] 5 kB
[ebuild     U ] sys-apps/shadow-4.0.15 [4.0.14-r3] USE="nls pam -nousuid -skey" 1,264 kB
[ebuild     U ] x11-libs/cairo-1.0.4 [1.0.2] USE="X png -doc -glitz" 1,441 kB
[ebuild     U ] net-irc/xchat-2.6.2 [2.6.1] USE="nls perl python ssl -dbus -debug -ipv6 -tcltk -xchatnogtk -xchattext" 1,022 kB

Total size of downloads: 89,665 kB


I have reduced significantly the number of entries (approximately 100 N packages and blocks total each) as I'm certain listing them here would be excessive, and I'm sure you get the point (there is an xterm update in the midst of all that too, just FYI). The way I would go about fixing this is to close down X and unmerge it, then emerge world, and have it go through this long, seemingly unnecessary process. But I honestly am not sure if I need all these packages. I certainly don't have all those video cards and input devices that portage apparently wants to say that I have. I have done a fair amount of poking around on my own and I'm not particularly stupid, but perhaps I could get a slight push in the right direction? Thanks!
_________________
Mobo: ASUS A8N-SLI Deluxe NVIDIA nForce4
Vid: MSI Geforce 6800 128MB DDR PCIX x16
Proc: AMD Athlon 64 3700+ 1GHz HT
Mem: OCZ 1GB DDR 600 (PC 4800) Dual Channel

Snow and adolescence are the only problems that disappear if you ignore them long enough.
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Mon Mar 27, 2006 9:13 pm    Post subject: Reply with quote

If you don't want to upgrade to Xorg 7.0 yet, just mask it.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
Fraggy
n00b
n00b


Joined: 23 Sep 2003
Posts: 13
Location: Harrisonburg, VA

PostPosted: Mon Mar 27, 2006 9:36 pm    Post subject: Reply with quote

ah, does that mean that 7.0 *is* modular X?
_________________
Mobo: ASUS A8N-SLI Deluxe NVIDIA nForce4
Vid: MSI Geforce 6800 128MB DDR PCIX x16
Proc: AMD Athlon 64 3700+ 1GHz HT
Mem: OCZ 1GB DDR 600 (PC 4800) Dual Channel

Snow and adolescence are the only problems that disappear if you ignore them long enough.
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Mon Mar 27, 2006 9:53 pm    Post subject: Reply with quote

Yes. 6.9 and older are monolithic; 7.0 and all future versions are modular.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
Fraggy
n00b
n00b


Joined: 23 Sep 2003
Posts: 13
Location: Harrisonburg, VA

PostPosted: Mon Mar 27, 2006 9:56 pm    Post subject: Reply with quote

thanks.. yeah I went and looked it up after I posted it and was coming back to edit, sorry about that!
_________________
Mobo: ASUS A8N-SLI Deluxe NVIDIA nForce4
Vid: MSI Geforce 6800 128MB DDR PCIX x16
Proc: AMD Athlon 64 3700+ 1GHz HT
Mem: OCZ 1GB DDR 600 (PC 4800) Dual Channel

Snow and adolescence are the only problems that disappear if you ignore them long enough.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jun 05, 2006 7:28 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of xorg-x11-6.9 -> xorg-x11-7.0-r1 everything blocked.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum