Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Boot problems after system install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nagual
n00b
n00b


Joined: 15 Jan 2006
Posts: 34

PostPosted: Fri Jan 27, 2006 6:45 pm    Post subject: Boot problems after system install Reply with quote

This is the inital boot after my base install. Here is the error message I get.

*Checking root filesystem ...

ext2fs_check_if_mount: No such file or directory while determining whether /dev/ROOT is mounted.
fsck.ext3: No such file or directory while trying to open to open /dev/ROOT
/dev/ROOT:
The superblock could not be read or does not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

* Filesystem couldn't be fixed :( [ !! ]

Give root password for maintenance
(or type Contol-D to continue):

Any suggestions on a fix for this?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43016
Location: 56N 3W

PostPosted: Fri Jan 27, 2006 6:51 pm    Post subject: Reply with quote

nagual,

You didn't edit your /etc/fstab to reflect reality.

Boot the liveCD.
mount your root partition on /mnt gentoo
Code:
nano -w /mnt/gentoo/etc/fstab

Now remove the words, ROOT, BOOT and SWAP and replace them with your actual partitions.
Also make sure the filesystem types are correct for your install.

If you get that right, your system will boot.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nagual
n00b
n00b


Joined: 15 Jan 2006
Posts: 34

PostPosted: Fri Jan 27, 2006 6:59 pm    Post subject: Reply with quote

That worked. Thanks.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Jan 27, 2006 7:16 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See here
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum