Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with DWL-122, no connection [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sat Jan 28, 2006 11:36 am    Post subject: Problem with DWL-122, no connection [SOLVED] Reply with quote

Hi, I'm running Gentoo on a PowerMac G4 and I'm trying since quite a lot of time to get wireless work. I bought a D-Link DWL-122 because I had found a lot of people who had made good experience with this.
Searching another time the forums I found a nice HOWTO that seemed to work well when I followed it step by step: http://gentoo-wiki.com/HOWTO_Prism2_USB_on_Gentoo
My kernel is configured correctly, then I installed the wlan-ng packages as the DWL-122 has a prism2 chip. I set up the modules and the configs (wlancfg-SSID and wlan.conf). Then the exists are the same till I arrive to let it do dhcpcd:
Quote:
Aemilia bjosch # ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0D:93:AF:0C:74
inet addr:192.168.0.101 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1909 errors:0 dropped:0 overruns:0 frame:0
TX packets:1011 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2097824 (2.0 Mb) TX bytes:91017 (88.8 Kb)
Interrupt:41 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:900 (900.0 b) TX bytes:900 (900.0 b)

wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Aemilia bjosch # modules-update
Aemilia bjosch # modprobe prism2_usb
Aemilia bjosch # wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
message=lnxreq_ifstate
ifstate=enable
resultcode=success
Aemilia bjosch # wlanctl-ng wlan0 lnxreq_autojoin ssid=AEMILIA authtype=opensystem
message=lnxreq_autojoin
ssid='AEMILIA'
authtype=opensystem
resultcode=success
Aemilia bjosch # dhcpcd -d wlan0

Here it begins with the MAC adress, but does not give any IP-adress. After a long time it quits without any further message, but I'm not connected. Can anyone give me an advice how to proceed?
In my router the WEP-Key is the first one (Key1), but in MacOS X choosing Key1 gave no result, at the end it worked smoothly with Key0, so I tried both in Gentoo, but it did not help.
I appreciate any hint! Thanks.


Last edited by Bjosch on Wed Jun 07, 2006 7:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Mon Feb 20, 2006 11:25 am    Post subject: Reply with quote

OK, here an update: the connection works fine when WEP is disabled. Of course I want to use at least WEP, but as soon as I enable it in the router, I can't connect any longer as described in my previous post above. I tried with key 0 and key 1 but neither worked. Any ideas?
Back to top
View user's profile Send private message
Jimmers
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 145

PostPosted: Tue Feb 21, 2006 3:34 am    Post subject: Reply with quote

I wrestled with linux-wlan-ng for about a year on my 12" ibook, and could never get WEP to work. I don't have the link, but I seem to remember someone posting that the last version of wlan-ng to work with WEP was x.x.x-pre16. That version has been gone from portage for a while now, but you can still grab the source and build it yourself. I finally got WEP goodness with the bcm43xx projects' native linux AE drivers.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Tue Feb 21, 2006 8:15 am    Post subject: Reply with quote

I think, actually the wlan chip in Apple notebooks requires bcm43xx and it's not since long that it works at all. But as far as I know it supports only broadcom 43xx based wlan, mine has a prism2 chip. As far as the older wlan-ng version I don't know but in the howto and other posts I always read that the newest version is recommended.
Back to top
View user's profile Send private message
Jimmers
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 145

PostPosted: Tue Feb 21, 2006 11:13 am    Post subject: Reply with quote

Before the bcm43xx drivers became functional, I used a DWL-122 for networking. Now I use the built-in wireless.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sat Feb 25, 2006 11:07 am    Post subject: Reply with quote

Sorry, maybe I did not understand you well, but the DWL-122 you got working with the bcm43xx driver? My Mac has no built in card, so I have to set up the DWL-122.
Back to top
View user's profile Send private message
Jimmers
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 145

PostPosted: Mon Feb 27, 2006 11:01 pm    Post subject: Reply with quote

Bjosch wrote:
Sorry, maybe I did not understand you well, but the DWL-122 you got working with the bcm43xx driver? My Mac has no built in card, so I have to set up the DWL-122.


No. bcm43xx = AirportX; linux-wlan-ng=DWL-122. I've had many questions answered in these forums concerning linux-wlan-ng. If you search for posts by me, there will be plenty of information.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sun Mar 05, 2006 11:45 am    Post subject: Reply with quote

Thanks. I looked through your comments and the discussion threats but actually there was no new information related to my WEP problem. I have no idea about where in the configs might be the problem. Maybe when I have some money I will try out another kind of wireless card, otherwise I will just stick to my normal LAN accepting that I can't get wireless working.. Thank you anyway.
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Tue May 09, 2006 9:38 am    Post subject: Reply with quote

I'm not sure which revision you have, but here we are still debugging the new rt73 part of rt2x00 project.
For me it still doesn't work, wether ppc or x86.
Only a matter of time, the team is working everyday on it.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
jerry arns
Tux's lil' helper
Tux's lil' helper


Joined: 13 Dec 2003
Posts: 95
Location: France

PostPosted: Fri Jun 02, 2006 4:30 am    Post subject: Reply with quote

I use net-wireless/linux-wlan-ng-0.2.3-r1 and WEP works.

My router is a linksys wrt54g. I enabled WEP, generated 4 keys, and copy paste them in /etc/conf.d/wlancfg-NAME_OF_MY_LAN

Code:

 #=======USER MIB SETTINGS=============================
# You can add the assignments for various MIB items
#  of your choosing to this variable, separated by
#  whitespace.  The wlan-ng script will then set each one.
# Just uncomment the variable and set the assignments
#  the way you want them.

#USER_MIBS="p2CnfRoamingMode=1 p2CnfShortPreamble=mixed"

#=======WEP===========================================
# [Dis/En]able WEP.  Settings only matter if PrivacyInvoked is true
lnxreq_hostWEPEncrypt=true     # true|false
lnxreq_hostWEPDecrypt=true     # true|false
dot11PrivacyInvoked=true        # true|false
dot11WEPDefaultKeyID=0          # 0|1|2|3
dot11ExcludeUnencrypted=true    # true|false, in AP this means WEP is required.

# If PRIV_GENSTR is not empty, use PRIV_GENTSTR to generate
#  keys (just a convenience)
# add-ons/ in the tarball contains other key generators.
PRIV_GENERATOR=/sbin/keygen     # nwepgen, Neesus compatible
PRIV_KEY128=false               # keylength to generate
PRIV_GENSTR=""

# or set them explicitly.  Set genstr or keys, not both.
dot11WEPDefaultKey0=*** copy here ***              # format: xx:xx:xx:xx:xx   or
dot11WEPDefaultKey1=*** copy here   ***           #         xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
dot11WEPDefaultKey2= ***copy here ***              #  e.g.   01:20:03:40:05   or
dot11WEPDefaultKey3=  ***copy here ***           #         01:02:03:04:05:06:07:08:09:0a:0b:0c:0d
#=======SELECT STATION MODE===================
IS_ADHOC=n                      # y|n, y - adhoc, n - infrastructure

#======= INFRASTRUCTURE STATION  ===================
# What kind of authentication?
AuthType="opensystem"           # opensystem | sharedkey (requires WEP)

#======= ADHOC STATION ============================
BCNINT=100                      # Beacon interval (in Kus)
CHANNEL=6                       # DS channel for BSS (1-14, depends
                                #   on regulatory domain)
BASICRATES="2 4"                # Rates for mgmt&ctl frames (in 500Kb/s)
OPRATES="2 4 11 22"             # Supported rates in BSS (in 500Kb/s)

_________________
Left handed, right minded.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Tue Jun 06, 2006 4:01 pm    Post subject: Reply with quote

I do not really know why, but now it works! After doing
Quote:
/etc/init.d/wlan start

I get the same error messages as before and first there is no connection. But after opening wlassistant and clicking on the essid-entry it connects. Now I have to work on how to get it during booting, doing a
Quote:
rc-update add wlan default

did not help, I have to connect it with the same procedure manually. But at least it's working fine!
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Tue Jun 06, 2006 4:46 pm    Post subject: Reply with quote

I continued trying...
First I have chosen ifplugd as running during the boot process:
Code:
rc-update del net.eth0 default
rc-update del wlan default
rc-update add ifplugd default

Now booting the system does not halt waiting for a connection that does not exist yet. But unfortunately neither wlan is brought up. So first of all I have to unplug and replug the usb wlan device! I don't know why, otherwise it does not seem to work, but it is not recognised by iwconfig.
Quote:
Aemilia bjosch # /etc/init.d/wlan stop
* Shutting Down WLAN Devices ... [ ok ]
Aemilia bjosch # /etc/init.d/wlan start
* Starting WLAN devices ...
message=lnxreq_ifstate
ifstate=fwload
resultcode=success
Reading S-record file /lib/firmware/prism2_ru.hex...
NIC ID: 0x8026 v1.0.0
MFI ID: 0x1 v1 1->1
CFI ID: 0x2 v2 1->1
PRI ID: 0x3 v1 1->4
Version: ID 0x1f 1.8.3
Compat: Role 0 Id 0x4 v3 1->15
Compat: Role 0x1 Id 0x1 v1 1->1
Compat: Role 0x1 Id 0x2 v2 1->1
Compat: Role 0x1 Id 0x3 v1 4->4
Seq: 0
Platform: ID 0x800a 1.0.0
Platform: ID 0x800f 1.0.0
Platform: ID 0x8010 1.0.0
Platform: ID 0x8011 1.0.0
Platform: ID 0x801e 1.0.0
Platform: ID 0x801f 1.0.0
Platform: ID 0x8020 1.0.0
Platform: ID 0x8025 1.0.0
Platform: ID 0x8026 1.0.0
Platform: ID 0x8027 1.0.0
prism2dl: warning: Failed to find PDR for plugrec 0x0405.
prism2dl: warning: Failed to find PDR for plugrec 0x0406.
prism2dl: warning: Failed to find PDR for plugrec 0x0302.
prism2dl: warning: Failed to find PDR for plugrec 0x0303.
prism2dl: warning: Failed to find PDR for plugrec 0x0412.
prism2dl: warning: Failed to find PDR for plugrec 0x0414.
prism2dl: finished. [ ok ]
Aemilia bjosch # dhcpcd -d wlan0
dhcpcd: MAC address = 00:11:95:93:a7:39
dhcpcd: your IP address = 192.168.0.100
Aemilia bjosch # ping -c3 www.google.de
PING www.l.google.com (66.249.93.104) 56(84) bytes of data.
64 bytes from 66.249.93.104: icmp_seq=1 ttl=242 time=76.3 ms
64 bytes from 66.249.93.104: icmp_seq=2 ttl=242 time=78.3 ms
64 bytes from 66.249.93.104: icmp_seq=3 ttl=242 time=79.3 ms

--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2008ms
rtt min/avg/max/mdev = 76.312/78.007/79.331/1.280 ms

All this is quite annoying, but at least I got it working, maybe I find some hint in the forum..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum