Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mod_php wouldn't emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
m@o
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 184
Location: /eu/at/grz

PostPosted: Sat Jan 28, 2006 4:29 pm    Post subject: mod_php wouldn't emerge Reply with quote

i jsut did an update of my apache2 to 2.0.54 my mod_php was 4.3.9

i unmerged mod_php. and now mod_php 4.4.0 doesn't want to emerge. i tried all r1 to r9.
cleared the distfiles.

while installation it says:
Code:

 * Due to some previous bloopers with PHP and slotting, you may have
 * multiple instances of mod_php installed. Please look at the autoclean
 * output at the end of the emerge and unmerge all but relevant
 * instances.


how can i clean up my system from php file survivors, that were not deleted by emerge -C mod_php?

and it ends up with:
Code:

configure: error: can not run test program while cross compiling

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/mod_php-4.4.0-r9/work/php-4.4.0/config.log

!!! ERROR: dev-php/mod_php-4.4.0-r9 failed.
!!! Function econf, Line 495, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


please give me any hints for installing php correctly by portage.

thx
Back to top
View user's profile Send private message
tukachinchila
Apprentice
Apprentice


Joined: 11 Mar 2005
Posts: 274
Location: Oregon

PostPosted: Sun Jan 29, 2006 2:04 am    Post subject: Reply with quote

I would stay away from mod_php. Try adding "cli session pcre php apache2" to your use-flags, then:
Code:
echo >=dev-lang/php-5.0.0 >> /etc/portage/package.mask
echo dev-php/php >> /etc/portage/package.mask
echo dev-php/mod_php >> /etc/portage/package.mask
emerge dev-lang/php

The idea is that dev-lang/php replaces dev-php/php and dev-php/mod_php. If you only need the PHP Apache module and not the PHP command line client, then you shouldn't actually need "cli" in your use-flags.
Back to top
View user's profile Send private message
mariourk
l33t
l33t


Joined: 11 Jul 2003
Posts: 807
Location: Urk, Netherlands

PostPosted: Sun Jan 29, 2006 1:57 pm    Post subject: Reply with quote

Re-emerge net-libs/libwww, it worked fine for me :)

source
_________________
If there is one thing to learn from history, it's that we usualy don't learn anything from it, at all.
Back to top
View user's profile Send private message
dougco
n00b
n00b


Joined: 06 Jul 2004
Posts: 47
Location: San Francisco

PostPosted: Tue Feb 21, 2006 12:23 am    Post subject: worked for me too [Solved] Reply with quote

I got the same error, and I didn't believe the re-emerging of libwww would work since my version was only slightly out-of-date from the recent one. But indeed that did the trick!
_________________
--
If you're reading this, then you've gone too far.
Back to top
View user's profile Send private message
mariourk
l33t
l33t


Joined: 11 Jul 2003
Posts: 807
Location: Urk, Netherlands

PostPosted: Tue Feb 21, 2006 8:34 am    Post subject: Reply with quote

Glad I could help :)
_________________
If there is one thing to learn from history, it's that we usualy don't learn anything from it, at all.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Feb 21, 2006 10:22 pm    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum