Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with compiling kdelibs on ibook
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
verschdl
n00b
n00b


Joined: 31 Jan 2004
Posts: 61

PostPosted: Thu Feb 02, 2006 5:42 pm    Post subject: problems with compiling kdelibs on ibook Reply with quote

Hi,

I get an segfault when compiling kdelibs

--- snip ---
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3-r1/work/kdelibs-3.4.3/kio/httpfilter'
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3-r1/work/kdelibs-3.4.3/kio'
Making all in dnssd
make[2]: Entering directory `/var/tmp/portage/kdelibs-3.4.3-r1/work/kdelibs-3.4.3/dnssd'
../kdecore/kconfig_compiler/kconfig_compiler ./kcm_kdnssd.kcfg ./settings.kcfgc; ret=$?; \
if test "$ret" != 0; then rm -f settings.h ; exit $ret ; fi
/bin/sh: line 1: 6003 Segmentation fault ../kdecore/kconfig_compiler/kconfig_compiler ./kcm_kdnssd.kcfg ./settings.kcfgc
make[2]: *** [settings.h] Error 139
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3-r1/work/kdelibs-3.4.3/dnssd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3-r1/work/kdelibs-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kdelibs-3.4.3-r1 failed.
!!! Function kde_src_compile, Line 182, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.
--- snip ---

May you please provide me an hint, what I've messed up?

Thanks
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Feb 02, 2006 6:02 pm    Post subject: Reply with quote

Make sure you have kernel preemption turned off.
http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml#gccsegfaults
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
kenyon
Apprentice
Apprentice


Joined: 23 Dec 2004
Posts: 155
Location: Southern California

PostPosted: Thu Mar 23, 2006 8:50 am    Post subject: Reply with quote

I'm having exactly the same problem, except on x86! It is not gcc that is segfaulting, it is this kconfig_compiler script for some reason.

Code:
/var/tmp/portage/kdelibs-3.5.1-r1/work/kdelibs-3.5.1/dnssd # ../kdecore/kconfig_compiler/kconfig_compiler
Segmentation fault


verschdl, did you solve this?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum