Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge wants to install gnome-themes for no apparent reason
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Feb 02, 2006 9:45 pm    Post subject: emerge wants to install gnome-themes for no apparent reason Reply with quote

Hi,

I am in a boot of cleaning useless stuff from my iMac G4. After doing
doing "equery d gtk-engines" I saw that "gnome-themes" was depending
on it. Doing an equery on gnome-themes revealed that it didn't have
any further dependancies so I proceded to remove both.
After removal I did an "emerge -puDv world" to see if everything was
all right and I didn't remove anything necessary. To my surprise it
wanted to re-install gnome-thems and consequentely gtk-engines.
So I did:
Code:
emerge -tuDv world
>>> --tree implies --pretend... adding --pretend to options.

These are the packages that I would merge, in reverse order:

Calculating world dependencies ...done!
[ebuild  N    ] x11-themes/gnome-themes-2.12.1  -accessibility -debug 2,501 kB
[ebuild  N    ]  x11-themes/gtk-engines-2.6.7  +accessibility -debug 468 kB

Total size of downloads: 2,969 kB

Which leaves me puzzled. What makes me even more puzzled is if I do
an "emerge -teD world" these 2 packages don't even figure in the tree!
Code:
emerge -teD world | grep themes
[ebuild  N    ] x11-themes/thinkeramik-3.2.1
[ebuild  N    ] x11-themes/lush-0.1.0-r1
[ebuild  N    ] kde-base/kdeartwork-iconthemes-3.4.3
[ebuild  N    ] x11-themes/korilla-1.3.4
[ebuild  N    ] x11-themes/gtk-engines-qt-0.6-r2
[ebuild  N    ] x11-themes/alloy-0.5.2
[ebuild  N    ] x11-themes/golden-xcursors-0.8
[ebuild  N    ] x11-themes/blueglass-xcursors-0.4
[ebuild  N    ] x11-themes/nuvola-1.0-r1
[ebuild  N    ] x11-themes/knifty-0.4.2
[ebuild  N    ] x11-themes/fusionx-aqua-1.1
[ebuild  N    ] x11-themes/silver-xcursors-0.4

So what is pulling this ebuild? I have a -gnome in my use flags and a few gnome libs
installed as necessary, but it looks like gnome-themes shouldn't be needed.
Can someone solve this mystery :?
Francois
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Thu Feb 02, 2006 10:00 pm    Post subject: Reply with quote

It's probably from libgnomeui; libgnomeui has a PDEPEND on gnome-themes, which emerge and equery don't handle all that well.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
ikshaar
Veteran
Veteran


Joined: 23 Jul 2002
Posts: 1339
Location: Baltimore, MD

PostPosted: Thu Feb 02, 2006 10:05 pm    Post subject: Reply with quote

I got a similar problem once... the -t option of portage does not seem fully reliable.

To determine which package start it, you can add the packages to the mask. Add to /etc/portage/package.mask
Code:
x11-themes/gnome-themes

Next emerge will complain of missing package and tell you which package requires it. Repeat until you reach the "root" of it.

I think my problem was an old software which no longer had an ebuild or was changed to a new category...
_________________
"May God stands between you and harm in all the empty places where you must walk" - Babylon 5
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Feb 02, 2006 11:32 pm    Post subject: Reply with quote

OK thanks to the masking tip it appears that "gtkhtml" is pulling
gnome-themes, for all I know it is also needed by libgnomeui but
gtkhtml is the first one to complain. After inspection libgnomeui
is a dependancy of gtkhml so it may be a dependancy of gtkhml
from there.

Thanks for the help,
Francois
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Fri Feb 03, 2006 6:13 am    Post subject: Reply with quote

Moved from Gentoo on PPC to Portage & Programming.

Edit: And from there to Duplicate Threads in favour of Unneeded packages being reinstalled. --Maedhros
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum