Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
insecure RUNPATH problem with blas-atlas package
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
spinner
n00b
n00b


Joined: 30 Sep 2005
Posts: 46

PostPosted: Thu Dec 15, 2005 4:57 pm    Post subject: insecure RUNPATH problem with blas-atlas package Reply with quote

Quote:
>>> Test phase [not enabled]: sci-libs/blas-atlas-3.6.0

>>> Install blas-atlas-3.6.0 into /var/tmp/portage/blas-atlas-3.6.0/image/
>>> category sci-libs
man:
prepallstrip:
strip: powerpc-unknown-linux-gnu-strip --strip-unneeded
usr/lib/blas/atlas/libblas.so.0.0.0
usr/lib/blas/atlas/libcblas.so.0.0.0
usr/lib/libatlas.so.0.0.0
making executable: /usr/lib/libatlas.so.0.0.0

QA Notice: the following files contain insecure RUNPATH's
Please file a bug about this at https://bugs.gentoo.org/
For more information on this issue, kindly review:
https://bugs.gentoo.org/81745
/var/tmp/portage/blas-atlas-3.6.0/work/ATLAS/gentoo/libs
usr/lib/blas/atlas/libblas.so.0.0.0
/var/tmp/portage/blas-atlas-3.6.0/work/ATLAS/gentoo/libs
usr/lib/blas/atlas/libcblas.so.0.0.0



I have been compiling this packages on a mac mini for about 7 hours and I got this message.
I opened the link but I did not find any solution for this package.
All these with latest portage (and latest emerge)

Any ideas on how to fix that ?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Dec 17, 2005 11:01 am    Post subject: Reply with quote

You can ignore it. The QA message means that a developer should take another good look at the package.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
spinner
n00b
n00b


Joined: 30 Sep 2005
Posts: 46

PostPosted: Tue Dec 20, 2005 3:20 pm    Post subject: Reply with quote

nixnut wrote:
You can ignore it. The QA message means that a developer should take another good look at the package.


how can i ignone it ?
It stops the installation of the compilation of the other deps and so I cannot compile Octave :(
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Dec 20, 2005 7:20 pm    Post subject: Reply with quote

spinner wrote:
nixnut wrote:
You can ignore it. The QA message means that a developer should take another good look at the package.


how can i ignone it ?
It stops the installation of the compilation of the other deps and so I cannot compile Octave :(

:oops: Sorry, I thought it was just a QA warning. Didn't realise it would choke and die on it.
Well, not much you can do. It's known problem https://bugs.gentoo.org/show_bug.cgi?id=114587. And it's not solved yet.
So unless you can fix it, you are not going to get it working.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Wed Dec 21, 2005 9:36 pm    Post subject: Reply with quote

Wait a minute there, I have compiled it and installed
on my iMac G4 without trouble (on the 10th of May 2005
I believe from the time stamp on my computer).
What change occured that made it non-buildable?
Octave is working on my machine.
Code:
emerge -pv octave

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sci-mathematics/octave-2.1.69  +blas -emacs +hdf5 (-ifc) -mpi +readline -static +tetex +zlib 0 kB

Total size of downloads: 0 kB

emerge -pv blas-atlas

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sci-libs/blas-atlas-3.6.0  -doc 0 kB

Total size of downloads: 0 kB

I would package it and make it available to you but
I don't have anywhere to post it.

Francois
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 360
Location: Oleiros

PostPosted: Sun Jan 29, 2006 1:48 pm    Post subject: Reply with quote

Did you manage to solve the problem?
I emerged blas-atlas months ago with no problems. I tried to reemerge it now, and I encountered with this problem.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Sun Jan 29, 2006 8:22 pm    Post subject: Reply with quote

mani001 wrote:
Did you manage to solve the problem?
I emerged blas-atlas months ago with no problems. I tried to reemerge it now, and I encountered with this problem.

Same here. I get emerge problems because it has been masked. Keywording it to
x86 to get 3.6.0-r1 ended with compilations problems (not install) trying to key it ~x86
to get 3.7.x also ended up with compilation problem.
My current 3.6.0 install works fine however.
Back to top
View user's profile Send private message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Fri Feb 03, 2006 11:18 am    Post subject: Reply with quote

I seems like dozends of packages are affected by the insecure runpath issue. Bugzilla bursts from new entries every day, but no one seems to care...
The only inepensive solution for me was to downgrade to portage 2.0.51.22-r3, and everything's working fine again.
_________________
http://blog.selbsthilfenetzwerk-cannabis-medizin.de
Back to top
View user's profile Send private message
spinner
n00b
n00b


Joined: 30 Sep 2005
Posts: 46

PostPosted: Fri Feb 03, 2006 2:27 pm    Post subject: Reply with quote

I sold my mac mini and i cannot test any more :(
Back to top
View user's profile Send private message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Fri Feb 03, 2006 2:59 pm    Post subject: Reply with quote

lol!
never mind, seems to hit several architectures (also amd64) ;-)
_________________
http://blog.selbsthilfenetzwerk-cannabis-medizin.de
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Fri Feb 03, 2006 10:10 pm    Post subject: Reply with quote

I don't know about other arch but blas-atlas in particular has been patched and
keyworded back to ppc and it works as I rebuild the package succesfully a few days ago.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum