Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Formac Display & Geforce 4mx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Feb 05, 2006 9:41 am    Post subject: Formac Display & Geforce 4mx Reply with quote

I have a slight problem with my display in xorg, My panel is a Formac 17" ADC with a resolution of 1280x1024 @ 75hz
on a GeForce 4mx 32mb. When in X the display is shifted by about 5mm to the right, Which gives me a small column of the righthand side of the screen on the left hand side. When i move a window off the right side of the screen it appears in the left hand column.

I have set openfirmware and nvidia framebuffer options in the kernel.
heres my dxorg driver section:
Code:
Section "Device"
   Identifier   "Card0"
   ### Available Driver options:
   #Option "HWcursor"   "true"  # Use Hardware Cursor
   #Option "NoAccel"   "false" # Disable Hardware Acceleration
#   Option "UseFBDev"   "true"
        Option "FlatPanel"  "true"
   ### See "man nv" for additional options
   Driver   "nv"


I dont have this on my mini which use the ATI FB with the same panel, though i use formac's ADC to DVI adapter, Which i've tried on the DVI port on this card, But that doesn't give me any display at all, Even at boot.

I've searched the forums for this and can't find anything.
Back to top
View user's profile Send private message
qleak
n00b
n00b


Joined: 17 Jun 2005
Posts: 67

PostPosted: Sun Feb 05, 2006 3:53 pm    Post subject: Re: Formac Display & Geforce 4mx Reply with quote

cybermonkey wrote:
...
on a GeForce 4mx 32mb. ...
I have set openfirmware and nvidia framebuffer options in the kernel.


I'm not sure that is the correct framebuffer for a GeForce card... I'm assuming that you are using ppc so you can't use nvidia's binary driver.
If I remember right, I think all the GeForce cards are on rivafb. Here's a snippet from the kernel config:
Code:

 CONFIG_FB_RIVA:                                                         
                                                                         
 This driver supports graphics boards with the nVidia Riva/Geforce       
 chips.                                   


Code:

 CONFIG_FB_NVIDIA:                                           

This driver supports graphics boards with the nVidia chips, TNT         
  and newer. For very old chipsets, such as the RIVA128, then use         
  the rivafb.


But to be honest, I'm not sure this sounds like a kernel problem at all. My system won't even boot with the wrong fb device.
Have you checked your /var/log/Xorg.0.log
?
Perhaps the "nv" driver does not support the video mode / refresh rate you are setting for your monitor.
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Feb 05, 2006 4:20 pm    Post subject: Reply with quote

Thanks for the reply, i've unchecked openfirmware and tried just the nvidia framebuffer but with DDC enabled and still the same. i never thought of using the rivafb one as it's for older Geforce cards but i'll give it a shot.
Back to top
View user's profile Send private message
cybermonkey
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 194

PostPosted: Sun Feb 05, 2006 6:16 pm    Post subject: Reply with quote

No joy i'm afraid.

I've tried a dozen different options in the kernel
selecting riva and nvidia as modules with openfirmware built in but still same prob.

The closest i came was moving the ADC to the DVI via the converter and having openfirware built in and rivafb as a module
This solved the problem in X but the console on boot was completly unreadable which just isn't an option if reiser finds problems on shutdown.

I tried just havingrivafb compiled in on it's own on the DVI port and i'm back to square one.

I think i might just use my Dual867 G4 as a server and use me mini.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum