Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Openoffice-bin and revdep-rebuild problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
kg4ojl
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2005
Posts: 91

PostPosted: Mon Feb 06, 2006 6:10 pm    Post subject: Reply with quote

I also keep having problems with this package "openoffice-bin 2.0.1. revdep-rebuild keeps trying to re-emerge it, because of python libs.

revdep-rebuild -p
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
(/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
(/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/_bsddb.so (requires libdb-3.1.so)
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/_tkinter.so (requires libBLT24.so libtcl8.3.so libtk8.3.so)
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/bz2.so (requires libbz2.so.0)
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/dbm.so (requires libgdbm.so.2)
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/gdbm.so (requires libgdbm.so.2)
broken /usr/lib/openoffice/program/python-core-2.3.4/lib/lib-dynload/readline.so (requires libreadline.so.4)
done.
(/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
(/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
(/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p =app-office/openoffice-bin-2.0.1

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild R ] app-office/openoffice-bin-2.0.1
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.

after i let it emerge it, and run revdep-rebuild again, it was to emerge it again. What it the deal?
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Feb 07, 2006 7:53 am    Post subject: Reply with quote

Duplicate of https://forums.gentoo.org/viewtopic-t-193202.html

This was split-off from https://forums.gentoo.org/viewtopic.php?t=430425.html because it was an unrelated issue.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum