Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mod_php emerge error...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zambizzi
Guru
Guru


Joined: 28 Aug 2004
Posts: 581
Location: Boise Idaho

PostPosted: Thu Jan 20, 2005 7:05 pm    Post subject: mod_php emerge error... Reply with quote

It seems like I'm having a lot of problems installing software these days where it used to go very smoothly!?

Anyhow, just got an error trying to emerge mod_php 5.0.3. I realize it's masked (not hard masked) but I should *at least* be able to emerge it successfully, shouldn't I?

In fact, now that I think of it, I was able to emerge 5.0.3 just a few days ago (as an update).

If this helps, here's a snippet:

Code:

...
checking for Informix support... no
checking for Ingres II support... no
checking for InterBase support... yes
checking for isc_detach_database in -lfbclient... no
checking for isc_detach_database in -lgds... no
checking for isc_detach_database in -lib_util... no
configure: error: libgds, libib_util or libfbclient not found! Check config.log for more information.

!!! ERROR: dev-php/mod_php-5.0.3 failed.
!!! Function econf, Line 449, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


I can go back further in the list if need be, just let me know.

Thanks!

-v
Back to top
View user's profile Send private message
zambizzi
Guru
Guru


Joined: 28 Aug 2004
Posts: 581
Location: Boise Idaho

PostPosted: Thu Jan 20, 2005 7:29 pm    Post subject: removed interbase Reply with quote

I got it to emerge finally by removing the interbase flag from my use-flags....however, this would still appear to be a bug, anyone agree?
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Thu Jan 20, 2005 9:53 pm    Post subject: Reply with quote

It does look like a dependancy error, but then, I haven't looked too deep since I don't use apache much. You could always post it to https://bugs.gentoo.org and see what the devs think.
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
mlivingstone
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2005
Posts: 125
Location: Gold Coast, Australia

PostPosted: Mon Feb 13, 2006 11:21 am    Post subject: Reply with quote

I just got similar complaints about libfbclient.so.1 being missing (and it was) when I started apache2 (-D PHP4)

I removed firebird USE flag from php & mod_php and remerged and when I restarted apache2, it was all ok.

IIRC, firebird used to be Interbase didn't it?

HTH

MarkL
Back to top
View user's profile Send private message
zambizzi
Guru
Guru


Joined: 28 Aug 2004
Posts: 581
Location: Boise Idaho

PostPosted: Mon Feb 13, 2006 12:53 pm    Post subject: Reply with quote

mlivingstone wrote:

IIRC, firebird used to be Interbase didn't it?


Correct, Borland open-sourced it in 2000 when it became Firebird. Remember that there are two USE flags, one for "firebird" and one for "interbase"...you're most likely to use the "firebird" unless you're working w/ legacy applications that used Interbase.
Back to top
View user's profile Send private message
thorpe
l33t
l33t


Joined: 09 May 2005
Posts: 618
Location: Sydney, Australia.

PostPosted: Mon Feb 13, 2006 12:57 pm    Post subject: Reply with quote

Shouldn't we be using dev-lang/php now?
Back to top
View user's profile Send private message
alistair
Retired Dev
Retired Dev


Joined: 15 Jul 2005
Posts: 869

PostPosted: Mon Feb 13, 2006 11:50 pm    Post subject: Reply with quote

thorpe wrote:
Shouldn't we be using dev-lang/php now?


You should at least be looking that way. but the last i heard dev-lang/php is still ~ and until its unmasked ppl wont change unless they want to.
_________________
______________
Help the gentoo-java project. Visit Gentoo Java Project

what good are admin powers if you don't abuse them for personal gain - mark_alec
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Mon Feb 13, 2006 11:57 pm    Post subject: Reply with quote

alistair wrote:
thorpe wrote:
Shouldn't we be using dev-lang/php now?


You should at least be looking that way. but the last i heard dev-lang/php is still ~ and until its unmasked ppl wont change unless they want to.


dev-lang/php is no longer masked and is now the recommended method of installation as I understand it.

Allen
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
andreask
Apprentice
Apprentice


Joined: 09 Sep 2003
Posts: 282
Location: Aachen, Germany

PostPosted: Tue Feb 14, 2006 12:51 pm    Post subject: Reply with quote

thorpe wrote:
Shouldn't we be using dev-lang/php now?

Definitly! Old dev-php/[mod_php|php|php-cli] packages are not supported anymore. Everybody should upgrade as soon as possible to dev-lang/php, because old style packages will be removed from portage soon!

alistair wrote:
You should at least be looking that way. but the last i heard dev-lang/php is still ~ and until its unmasked ppl wont change unless they want to.

dev-lang/php and the packages around it were marked stable in the meantime!

GWN 2006-01-30 wrote:
PHP Herd's January meeting

[...] The most notable decision made from a users point of view forces users to migrate from dev-php/php to dev-lang/php as soon as possible as the PHP Herd decided to no longer support them. [...]

http://www.gentoo.org/news/en/gwn/20060130-newsletter.xml#doc_chap1_sect3

Gentoo PHP Overlay wrote:
What Happens To The Old Packages?

The old-style dev-php/php packages are no longer supported. Users must migrate to dev-lang/php to get support. If you use these packages on your servers, migrate to the dev-lang/php packages as soon as possible. The old-style dev-php/{mod_php,php,php-cgi} packages will be package.masked around February 1, 2006 (as soon as keywording is finished/sorted out on all ARCHs). We'll provide a three month window for users to migrate over to the new dev-lang/php package. The old-style dev-php/php packages will be removed from Portage on the 1st May 2006.

http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/RetiringTheOldPackages#WhatHappensToTheOldPackages

There is an Upgrading Guide to help you:
http://www.gentoo.org/proj/en/php/php-upgrading.xml

There is also a preview for an Installing Guide, created for people who install PHP from scratch: http://svn.gnqs.org/projects/gentoo-php-overlay/browser/docs/html/php-installing.html?format=raw
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Feb 21, 2006 10:25 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum