Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lombard 2.6.14+ kernel problems
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 12 Feb 2006
Posts: 1

PostPosted: Sun Feb 12, 2006 9:36 am    Post subject: Lombard 2.6.14+ kernel problems Reply with quote

I have a PowerBoox G3 Lombard that I have been running Gentoo on for quite some time using a 2.6.10 kernel.

I have recently tried to update to either a stable 2.6.14 or later kernel. I've tried gentoo-sources-2.6.14-r5 and 2.6.15-r1.

They both boot fine, but I'm encountering two different problems when I try to use them:
1) When I insert my orinioco pcmcia card, I get an oops, but things keep running other than the pcmcia

2) When I try to emerge splashutils, I get lots of errors about missing files in the kernel's include/asm/ directory. For instance errno.h doesn't exist in /usr/src/linux-2.6.14-gentoo-r5/include/asm/. If I put the files there it finds them, but there are several that I will need to go through.

Here is the oops I see with 2.6.14-r5 when I try to use the orinoco gold card.
Oops: machine check, sig: 7 [#1]
NIP: D591D094 LR: D591D068 SP: CE877C10 REGS: ce877b60 TRAP: 0200 Not tainted
MSR: 00049030 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
TASK = d33db810[6390] 'modprobe' THREAD: ce876000
Last syscall: 128
GPR00: 000000FF CE877C10 D33DB810 D58BE000 00000014 00000070 00000002 CE877C90
GPR08: D33DC258 D58BF000 00000040 00001000 22002242 1001E288 D5890000 CE877D50
GPR16: D3BD92E0 D3BD92E0 01000000 FD000000 00000000 00200000 D5890000 00080000
GPR24: CE877C90 00000021 00000002 CE968C2C 00000000 00000000 00000002 CE877C90
NIP [d591d094] pcmcia_read_cis_mem+0x160/0x1c4 [pcmcia_core]
LR [d591d068] pcmcia_read_cis_mem+0x134/0x1c4 [pcmcia_core]
Call trace:
[d591d3f4] read_cis_cache+0x16c/0x170 [pcmcia_core]
[d591d7c8] pccard_get_next_tuple+0xec/0x454 [pcmcia_core]

I'll post more if necessary. It looks like it is all part of the init_pcmcia_bus.

Any suggestions would be appreciated.
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Feb 12, 2006 4:52 pm    Post subject: Reply with quote

For the pcmcia oops, make sure that the settings in /etc/pcmcia/config.opts are set correctly for your computer. Getting a machine check like that means that it's trying to access a port or memory that doesn't exist.

The other issue is due to the header merge between ppc and ppc64 in the kernel and is unrelated to Gentoo. 2.6.15 is slightly better and 2.6.16 should resolve the rest of the header issues (hopefully!).
Gentoo PPC FAQ:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum