Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libstdc++.la searched at wrong place
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nyk
Guru
Guru


Joined: 28 Aug 2004
Posts: 527
Location: Bern (Switzerland)

PostPosted: Mon Feb 13, 2006 2:29 pm    Post subject: libstdc++.la searched at wrong place Reply with quote

I have this problem: "/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la: No such file or directory" while compiling.
First I had it when trying to compile mod_php, then I tried dev-lang/php and got the same error when compiling the dependency gd. The path should be "/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la", but where do I have to set it?

This is happening on a freshly installed i686 system, everything else is already installed (apache, sendmail, zope, ...) and working.
Back to top
View user's profile Send private message
gwolf
Guru
Guru


Joined: 05 May 2005
Posts: 374
Location: Estonia

PostPosted: Mon Feb 13, 2006 2:44 pm    Post subject: Reply with quote

You probably need to use the /sbin/fix_libtool_files.sh script to fix this. Don't remember the exact syntax, but you can search in forums a little, there's been similar problems from time to time.

Regards,
gwolf
_________________
War is peace. Freedom is slavery. Ketchup is a vegetable.
Back to top
View user's profile Send private message
Sedrik
l33t
l33t


Joined: 08 Apr 2005
Posts: 655
Location: Uppsala, Sweden

PostPosted: Mon Feb 13, 2006 2:48 pm    Post subject: Reply with quote

If you solve it, plz post youre solution, got problems with the same library
Back to top
View user's profile Send private message
gwolf
Guru
Guru


Joined: 05 May 2005
Posts: 374
Location: Estonia

PostPosted: Mon Feb 13, 2006 3:00 pm    Post subject: Reply with quote

Hi again!
You could read https://forums.gentoo.org/viewtopic-t-335978.html, the syntax is current case probably
Code:
fix_libtool_files.sh 3.3.5-20050130 -oldarch i386-pc-linux-gnu

_________________
War is peace. Freedom is slavery. Ketchup is a vegetable.
Back to top
View user's profile Send private message
nyk
Guru
Guru


Joined: 28 Aug 2004
Posts: 527
Location: Bern (Switzerland)

PostPosted: Mon Feb 13, 2006 3:11 pm    Post subject: Reply with quote

Yeah this worked!
I actually did
fix_libtool_files.sh .3.5-20050130 --oldarch i386-pc-linux-gnu

and then, when I noticed the copy-paste mistake ".3.5" instead of "3.3.5" I did also:
fix_libtool_files.sh 3.3.5-20050130

...and then it worked!
Thanks, now I see how the fix-script works, just strange that this was already broken on a FRESH install!
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Mon Feb 13, 2006 3:46 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of the FAQ GF18: Emerge fails after upgrading gcc. libstdc++.la missing.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum