Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfce taskbar does not clip text
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 399
Location: Switzerland

PostPosted: Tue Feb 14, 2006 11:35 pm    Post subject: xfce taskbar does not clip text Reply with quote

i've been made aware by a user of a strange behaviour of XFCE after some of the later updates. the error manifestates as the text on the buttons in the taskbar representing running applications is not clipped to the button. hence by applications with long names like firefox with an open web page this results in the text of all the buttons in the taskbar mixing up turning totally unreadable. now i have two questions.

1) somebody has a similar problem and knows if this is XFCE problem or GTK+ problem? somebody knows a fix?

2) if not which XFCE/GTK+ version does not have this bug for sure ( so i can downgrade if possible ) ?

system info:
Code:
[ebuild  N    ] xfce-base/xfce4-4.2.2 
[ebuild  N    ]  xfce-base/xffm-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-systray-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-trigger-launcher-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-iconbox-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-toys-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-icon-theme-4.2.2 
[ebuild  N    ]  xfce-base/xfprint-4.2.2 
[ebuild  N    ]   app-text/a2ps-4.13c-r2 
[ebuild  N    ]    app-text/ghostscript-esp-7.07.1-r8 
[ebuild  N    ]     net-print/cups-1.1.23-r7 
[ebuild  N    ]      app-text/poppler-0.5.0-r4 
[ebuild  N    ]     media-fonts/gnu-gs-fonts-std-8.11 
[ebuild  N    ]    dev-util/gperf-3.0.1 
[ebuild  N    ]   app-text/psutils-1.17 
[ebuild  N    ]  xfce-extra/xfce4-appfinder-4.2.2 
[ebuild  N    ]  xfce-base/xfce4-session-4.2.2 
[ebuild  N    ]   xfce-base/xfce-utils-4.2.2 
[ebuild  N    ]  xfce-extra/xfwm4-themes-4.2.2 
[ebuild  N    ]  xfce-base/xfdesktop-4.2.2 
[ebuild  N    ]  xfce-base/xfwm4-4.2.2 
[ebuild  N    ]  xfce-extra/xfce4-mixer-4.2.2 
[ebuild  N    ]  xfce-extra/xfcalendar-4.2.2 
[ebuild  N    ]   xfce-base/xfce4-panel-4.2.2 
[ebuild  N    ]    xfce-base/xfce-mcs-plugins-4.2.2 
[ebuild  N    ]     xfce-base/xfce-mcs-manager-4.2.2 
[ebuild  N    ]      xfce-base/libxfce4mcs-4.2.2 
[ebuild  N    ]       xfce-base/libxfcegui4-4.2.2-r1 
[ebuild  N    ]       xfce-base/libxfce4util-4.2.2 
[ebuild  N    ]   x11-themes/gtk-engines-xfce-2.2.7-r1 
[ebuild  N    ]   dev-libs/dbh-1.0.24 
[ebuild  N    ]   x11-libs/gtk+-2.8.8 
[ebuild  N    ]    x11-misc/shared-mime-info-0.16 
[ebuild  N    ]     dev-libs/libxml2-2.6.23 
[ebuild  N    ]     dev-util/intltool-0.34.1 
[ebuild  N    ]      dev-perl/XML-Parser-2.34 
[ebuild  N    ]    x11-libs/pango-1.10.2 
[ebuild  N    ]    dev-libs/atk-1.10.3 
[ebuild  N    ]    dev-libs/glib-2.8.5 
[ebuild  N    ]    media-libs/tiff-3.7.3 
[ebuild  N    ]     media-libs/jpeg-6b-r5 
[ebuild  N    ]    x11-libs/cairo-1.0.2 
[ebuild  N    ]   x11-libs/startup-notification-0.8

_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
beandog
Developer
Developer


Joined: 04 May 2003
Posts: 2065
Location: /usa/utah

PostPosted: Wed Feb 15, 2006 12:27 am    Post subject: Reply with quote

It's a GTK bug. Do an emerge sync, get the latest (stable) gtk libs, and then RE-emerge all your XFCE4 apps. That worked for me.
_________________
If it ain't broke, tweak it. dvds | blurays | blog | wiki
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 399
Location: Switzerland

PostPosted: Wed Feb 15, 2006 1:21 am    Post subject: Reply with quote

i did a simple emerge --sync and emerge -avuD world . it did not re-ermege xfce or gtk but the bug vanished. i suspect one of the dependencies of gtk ( most probably pangoo or some text layout stuff ) cause the bug. more precisely i can't pinpoint it right now.
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed Feb 15, 2006 6:09 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-406823.html
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum