Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound defaults to mute when TiBook wakes from sleep FIXED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Wed Feb 15, 2006 4:45 pm    Post subject: Sound defaults to mute when TiBook wakes from sleep FIXED Reply with quote

Sound defaults to mute when my TiBook wakes from sleep.

/etc/conf.d/alsasound
Code:

RESTORE_ON_START="yes"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="yes"


/etc/pbbuttonsd.conf
Code:

[MODULE MIXER]
SoundSystem           = auto      ; 'none', 'auto', 'OSS' or 'ALSA'
OSS_Device            = "/dev/mixer"
OSS_Channels          = "volume, speaker"
Volume                = 20      ; initial volume level
Speakers_muted        = no      ; mute after startup?
VolumeUpKey           = 115
VolumeDownKey         = 114
MuteKey               = 113
MixerInitDelay        = yes
ALSA_Card             = "default"
ALSA_Elements         = "Master, 'PC Speaker'"


Notice that volume fails to set when going into sleep mode or from waking up
#dmesg
Code:
Advanced Linux Sound Architecture Driver Version 1.0.10rc1 (Mon Sep 12 08:13:09 2005 UTC).
ALSA device list:
  #0: PowerMac Snapper (Dev 26) Sub-frame 0
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 6, 262144 bytes)
TCP established hash table entries: 262144 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
ip_conntrack version 2.3 (8192 buckets, 65536 max) - 216 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 17
RAMDISK: Couldn't find valid RAM disk image starting at 0.
ReiserFS: hda4: found reiserfs format "3.6" with standard journal
ReiserFS: hda4: using ordered data mode
ReiserFS: hda4: journal params: device hda4, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda4: checking transaction log (hda4)
ReiserFS: hda4: Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 200k init 4k chrp 8k prep
NET: Registered protocol family 1
Adding 524280k swap on /dev/hda3.  Priority:-1 extents:1 across:524280k
hda: Enabling Ultra DMA 4
cdrom: open failed.
eth1: New link status: Connected (0001)
eth1: New link status: Connected (0001)
eth1: New link status: Disconnected (0002)
eth1: New link status: Connected (0001)
agpgart: Putting AGP V2 device at 0000:00:0b.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:00:10.0 into 4x mode
[drm] Loading R200 Microcode
agpgart: Putting AGP V2 device at 0000:00:0b.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:00:10.0 into 4x mode
[drm] Loading R200 Microcode
failed to set volume
eth1: Airport entering sleep mode
eth0: suspending, WakeOnLan disabled
radeonfb (0000:00:10.0): suspending to state: 2...
uninorth-agp: disabling AGP on device 0000:00:10.0
uninorth-agp: disabling AGP on bridge 0000:00:0b.0
radeonfb (0000:00:10.0): switching to D2 state...
radeonfb (0000:00:10.0): resuming from state: 2...
radeonfb (0000:00:10.0): switching to D0 state...
agpgart: Putting AGP V2 device at 0000:00:0b.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:00:10.0 into 4x mode
eth1: get_wireless_stats() called while device not present
eth0: resuming

At one time my sound work ok after sleep mode but the last few months I am having this problem.


Last edited by heavyt on Thu Feb 16, 2006 3:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Wed Feb 15, 2006 7:22 pm    Post subject: Reply with quote

I have the same problem with kernel 2.6.14 and 2.6.15.
A work around
Code:
# amixer sset 'Master',0 unmute
or insert it in a power management script.

It is fixed in 2.6.16-rc2
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Thu Feb 16, 2006 2:50 am    Post subject: Reply with quote

bz31 wrote:
I have the same problem with kernel 2.6.14 and 2.6.15.
A work around
Code:
# amixer sset 'Master',0 unmute
or insert it in a power management script.

It is fixed in 2.6.16-rc2


I upgraded to 2.6.16-rc3. That seem to have fixed the mute problem but I still have no sound after sleep because, "PC Speaker" option in alsamixer or gnome-alsa-mixer is deselected. Everytime after sleep I have to reselect "PC Speaker", I would love to know what is resetting it! :?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Thu Feb 16, 2006 6:26 am    Post subject: Reply with quote

Have you AutoMute in alsamixer ?
Quote:
OO
<Auto Mut>
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Thu Feb 16, 2006 1:00 pm    Post subject: Reply with quote

bz31 wrote:
Have you AutoMute in alsamixer ?
Quote:
OO
<Auto Mut>


It does not automute, the problem is PC Speaker not staying selected.
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Thu Feb 16, 2006 1:20 pm    Post subject: Reply with quote

heavyt wrote:
bz31 wrote:
Have you AutoMute in alsamixer ?
Quote:
OO
<Auto Mut>


It does not automute, the problem is PC Speaker not staying selected.

Sorry for my english.
I must use (turn on) automute. If not, I have the same problem as you.
My setting : http://bb.zhang.free.fr/alsamixer.jpg
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Thu Feb 16, 2006 3:16 pm    Post subject: Reply with quote

bz31 wrote:
heavyt wrote:
bz31 wrote:
Have you AutoMute in alsamixer ?
Quote:
OO
<Auto Mut>


It does not automute, the problem is PC Speaker not staying selected.

Sorry for my english.
I must use (turn on) automute. If not, I have the same problem as you.
My setting : http://bb.zhang.free.fr/alsamixer.jpg


Your english is just fine, turning on automute fixed my problem thank you. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum