Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
help install gentoo in powerbook 12" 1.5Ghz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
terry
n00b
n00b


Joined: 27 Jul 2002
Posts: 64
Location: Korea Seoul

PostPosted: Tue May 09, 2006 5:56 am    Post subject: help install gentoo in powerbook 12" 1.5Ghz Reply with quote

Hi, I recently buy last powerbook 12' 1.5Gh

When I try to install Gentoo,
there is emere error
That is something like
(a little big program, gcc.. xorg.... etc)
Code:
/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.5/../../../../powerpc-unknown-linux-gnu/bin/ld: BFD 2.16.1 internal error, aborting at /var/tmp/portage/binutils-2.16.1/work/binutils-2.16.1/bfd/elflink.c line 6437 in elf_link_output_extsym

/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.5/../../../../powerpc-unknown-linux-gnu/bin/ld: Please report this bug.

collect2: ld returned 1 exit status
make[1]: *** [testscanw] Error 1
make[1]: Leaving directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/test'
make: *** [all] Error 2


I just know most that case is cause by preempt enable.
but I don't enable that. even live install cd also make that error.

I did memtest by JoseIX's advise. but that didn't find any memory error.

how can I solove this problem?
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1564
Location: Germany

PostPosted: Wed May 10, 2006 6:05 am    Post subject: Reply with quote

Ok, you should give us your cflags, or better the make.conf.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
terry
n00b
n00b


Joined: 27 Jul 2002
Posts: 64
Location: Korea Seoul

PostPosted: Wed May 10, 2006 7:29 am    Post subject: Reply with quote

paoleela wrote:
Ok, you should give us your cflags, or better the make.conf.


Thanks,

I didn't edit default CFLAGS in Gentoo 2006.0 install cd. with stage3 for G4.
That is CFLAGS="-O2 -mcpu=G4 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"

I am try to install "Gentoo 2005.1 install cd with stage3 for ppc"
I did emerge sync and change cflage to "CFLAGS="-O2 -mcpu=G4 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"

now I am doing emrege -e system.
That emerge isn't finish, so i am not sure but gcc is emerged without error.(I hope it will work)
Now under emrge glibc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum