Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Modular Xorg Block (6.9->7)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Tue Apr 11, 2006 9:30 pm    Post subject: Reply with quote

Let's put this in code-tags, so one can actually see the intendations...

Code:
Darkness / # emerge -uDpvt world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xkill-1.0.1)
[blocks B     ] x11-libs/libXft (is blocking x11-base/xorg-x11-6.9.0)
[nomerge      ] x11-apps/xkill-1.0.1  USE="-debug"
[nomerge      ] kde-base/kdemultimedia-3.5.2  USE="alsa arts encode gstreamer kdeenablefinal mp3 vorbis -audiofile -debug -flac -musicbrainz -theora -xine -xinerama"
[nomerge      ]  kde-base/kdebase-3.5.2  USE="arts cups hal java kdeenablefinal lm_sensors opengl pam samba ssl -debug -ieee1394 -ldap -logitech-mouse -openexr -xcomposite -xinerama -xscreensaver -zeroconf"
[ebuild     U ]   media-video/nvidia-glx-1.0.8756 [1.0.8178-r1] USE="-dlloader" 9,717 kB
[ebuild     U ]    media-video/nvidia-kernel-1.0.8756 [1.0.8178-r3] 0 kB
[nomerge      ] x11-terms/xterm-207  USE="truetype unicode -Xaw3d -doc -toolbar"
[ebuild  N    ]   virtual/x11-6.8  0 kB
[ebuild     UD]    x11-base/xorg-x11-6.9.0 [7.0-r1] USE="bitmap-fonts% ipv6% nls% opengl% pam% truetype-fonts% type1-fonts% xv% -cjk% -debug% -doc% -font-server% -insecure-drivers% -minimal% -nocxx% -sdk% -static% -xprint%" 46,864 kB
[ebuild  N    ]     x11-apps/ttmkfdir-3.0.9-r3  19 kB
[nomerge      ] media-plugins/gst-plugins-alsa-0.8.11
[nomerge      ]  media-libs/gst-plugins-0.8.11  USE="alsa -debug -esd -oss"
[nomerge      ]   gnome-base/gconf-2.12.1  USE="-debug -doc"
[nomerge      ]    x11-libs/gtk+-2.8.12  USE="jpeg tiff -debug -doc -xinerama"
[ebuild     U ]     x11-libs/cairo-1.0.4 [1.0.2] USE="X png -doc -glitz" 1,441 kB
[ebuild     U ] sys-apps/man-pages-2.28 [2.27] USE="nls" 1,733 kB
[ebuild     U ] sys-apps/portage-2.1_pre7-r5 [2.1_pre7-r4] USE="-build -doc" 0 kB
[nomerge      ] app-admin/perl-cleaner-1.01
[nomerge      ]    dev-libs/openssl-0.9.7i  USE="zlib -bindist -emacs -test"
[nomerge      ]     dev-lang/perl-5.8.7-r3  USE="berkdb -build -debug -doc -gdbm -ithreads -minimal -perlsuid"
[nomerge      ]      sys-libs/db-4.2.52_p2-r1  USE="java -bootstrap -doc -nocxx -tcltk"
[nomerge      ]       dev-java/blackdown-jdk-1.4.2.03-r2  USE="X alsa -browserplugin -doc -mozilla -nsplugin"
[nomerge      ]        media-libs/alsa-lib-1.0.10  USE="-doc -jack"
[nomerge      ]         sys-kernel/ck-sources-2.6.16_p3  USE="symlink -build -ck-server -doc"
[nomerge      ]          sys-fs/udev-079-r1
[ebuild     U ]           sys-apps/baselayout-1.11.14-r7 [1.11.14-r6] USE="unicode -bootstrap -build -static" 0 kB
[nomerge      ]     sys-apps/diffutils-2.8.7-r1  USE="nls -static"
[nomerge      ]      sys-devel/gettext-0.14.4  USE="nls -doc -emacs"
[nomerge      ]       sys-libs/glibc-2.3.5-r2  USE="nls nptl nptlonly* userlocales -build -erandom -glibc-compat20 -glibc-omitfp -hardened -linuxthreads-tls -pic -profile"
[ebuild     U ]        sys-devel/gcc-3.4.5 [3.4.4-r1] USE="fortran gtk nls -bootstrap -boundschecking -build -doc% -gcj -hardened -ip28 -multislot -nocxx -nopie -nossp -objc -vanilla" 0 kB

Total size of downloads: 59,776 kB


Looks like you need to add virtual/x11 to your package.keywords.
Back to top
View user's profile Send private message
destr0yr
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2003
Posts: 80
Location: Kelowna, BC.

PostPosted: Tue May 02, 2006 10:56 am    Post subject: Reply with quote

UncleOwen wrote:
Looks like you need to add virtual/x11 to your package.keywords.

I'm curious if somebody could explain what adding "virtual/x11" to package.keywords will actually do? Simply adding "<=virtual/x11-6.8" to package.mask seems to be working alright for me (when I do emerge -uDav world). Does adding virtual/x11 to package.keyword break dependancy checking?
Back to top
View user's profile Send private message
astaines
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2004
Posts: 91
Location: Ireland

PostPosted: Sat Jun 17, 2006 8:56 pm    Post subject: vritual/xft is also helpful Reply with quote

I has a similar set of problems - several dozen x11 packages blocked by '<=x11-base/xorg-x11-6.9' which were not cured by putting virtual/x11 in /etc/portage/packages/keywords.

Just adding virtual/xft however, did the trick.

Worth trying?

Anthony
Back to top
View user's profile Send private message
kbps
n00b
n00b


Joined: 06 Mar 2006
Posts: 38
Location: Vladivostok, Russia

PostPosted: Thu Jun 29, 2006 10:09 am    Post subject: Reply with quote

I fix this much blocks (6.9 -> 7)

Code:

echo "virtual/xft ~x86" >> /etc/portage/package.keywords

Back to top
View user's profile Send private message
arantius
n00b
n00b


Joined: 03 Jan 2004
Posts: 64

PostPosted: Mon Jul 10, 2006 5:50 pm    Post subject: Reply with quote

You need to properly migrate from 6.9 to 7.0, as the project has changed dramatically:

http://gentoo-wiki.com/HOWTO_Modular_Xorg
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Jul 20, 2006 4:18 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of xorg-x11-6.9 -> xorg-x11-7.0-r1 everything blocked (solved).
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum