Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Huge problem with Portage ... invalid ./configure features?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mvibe
n00b
n00b


Joined: 10 Dec 2005
Posts: 51
Location: Atlanta, GA

PostPosted: Sun Feb 19, 2006 2:29 pm    Post subject: Huge problem with Portage ... invalid ./configure features? Reply with quote

Not sure where things went wrong...
I believe the problem is with the latest Portage release but I cannot pin point it.

Everything I try to emerge ends with 1 of 3 error messages or which all end with the same 'ebuild.sh' error ....

After sync'ing the tree ... I tried to emerge libperl, perl, and python to ensure I had the latest.
All three ended with:

Code:

configure: error: expected an absolute directory name for --datadir"


or

Code:

configure: error: invalid feature


then ending with

Code:

!!! ERROR: <packagedir>/<package_name> failed.
Call Stack:
    ebuild.sh, line 1894:    Called dyn_compile
    ebuild.sh, line 941:      Called src_compile

!!! econf failed
!!! If you need support ... blah blah


Any ideas?
Back to top
View user's profile Send private message
yamakawa
Guru
Guru


Joined: 28 Jul 2003
Posts: 340

PostPosted: Sun Feb 19, 2006 2:48 pm    Post subject: Reply with quote

could be this bug
Back to top
View user's profile Send private message
mvibe
n00b
n00b


Joined: 10 Dec 2005
Posts: 51
Location: Atlanta, GA

PostPosted: Sun Feb 19, 2006 4:11 pm    Post subject: Reply with quote

yamakawa wrote:
could be this bug


Yep .. that looks like it.

I just copied 5.93 expr to my laptop overwrote both system copies ... re-emerged coreutils-5.93.

So far so good.
Coreutils is compiling ...

Final test will be when I try to emerge something else.

J

Edit February 19, 2006 11:16am

Yep .. all is good!!
Thanks!
I guess I just needed to explore search expressions a bit more ... :P
Back to top
View user's profile Send private message
alterself.com
Apprentice
Apprentice


Joined: 13 Nov 2003
Posts: 175
Location: Iowa

PostPosted: Sun Feb 19, 2006 4:54 pm    Post subject: Reply with quote

coreutils-5.94 is highly unstable, i cannot emerge anything on all my systems, various different errors relating to expr. have tried to downgrade to coreutils-5.93 w/o any success.

any idea when an 'official' fix will be around?
_________________
Gentoo ROCKS!
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3829
Location: Essen, Germany

PostPosted: Sun Feb 19, 2006 5:32 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of: https://forums.gentoo.org/viewtopic-t-435291.html
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum