Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge issue! please help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 12:53 am    Post subject: emerge issue! please help Reply with quote

hey guys, question... i solved my problem of not wanting to install x-org in my emerge -uavDN world .... it was compiling gcc.. for some reason and older version 3.3.6 maybe.. no idea what happened, now i can't even re-emerge, use python, any c functions... compiler done, this is the build error. please help? thanks in advance.
and i'm using putty under kde, so i can't copy the error in...

python stuff doesn't work, nothing at all..... how can i figure out what just happened... where to go from here.. thanks!
Back to top
View user's profile Send private message
smitty_one_each
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2004
Posts: 94
Location: Right coast, halfway up

PostPosted: Tue Feb 21, 2006 12:59 am    Post subject: Reply with quote

Can you boot the system?
Can you emerge --info?
You may need a live CD for forensics.
_________________
I'm just looking for clues at the scene of the crime.--Walsh
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 1:03 am    Post subject: Reply with quote

no, i haven't rebooted it yet.... it seemes like it installed the wrong version of the gcc compiler... is there a logfile someplace that emerge keeps, emerge doesn't work equery... python error while loading shared libraries: libstdc++.so.6 cannot open shared object for object file. no such file or directory

where is a logfile ??? thanks man!
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Tue Feb 21, 2006 1:29 am    Post subject: Reply with quote

I understand the problem. When you upgraded gcc you did not follow the upgrade path. You are missing libstdc++-v3. See if you can find a fix in https://forums.gentoo.org/viewtopic-t-407840.html
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 1:35 am    Post subject: Reply with quote

hmmmmm... looking through there having problems finding because it's such a pain in the ass i can't copy\paste... what would i need to do...
thanks!

i am fiddling with gcc-config -l
and the first entry is
/usr/bin/gcc-config line 652 /etc/env.d/gcc/i386-pc-linux-gnu-3.4.4: no such file or directory..
so i ran gcc-config -f 1
it changed it to the old enviroment

then i ran source /etc/profile.. and it still gives me an error referring to 3.4.4 when i run g++...
what else am i missing?


Last edited by xtlosx on Tue Feb 21, 2006 1:43 am; edited 1 time in total
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Tue Feb 21, 2006 1:42 am    Post subject: Reply with quote

Try doing the following and then doing gcc-config -l

Code:
# env-update; source /etc/profile
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 1:44 am    Post subject: Reply with quote

when i run that, i get the python error referring to libstdc++.so.6.. cannot open shared object files....
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Tue Feb 21, 2006 1:46 am    Post subject: Reply with quote

I have no idea what you can do because you are missing a major lib (libstdc++-v3). I personally don't know of any other fix than re-installing gentoo. But I am sure someone else knows a way.
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 1:47 am    Post subject: Reply with quote

well couldn't i just switch to that profile.... use the livecd someway? there's got to be something other than reinstalling the base operating system.


now it's saying this when i try to do gcc-config -f 1

Code:

zabno gcc # gcc-config -f 1
 * Switching cross-compiler to i386-pc-linux-gnu-3.3.6 ...

 * env-update failed to work properly; making sure ld.so.conf paths
 * are setup properly.  Please rerun gcc-config with the -f option.
                                                                                             [ ok ]

 * If you intend to use the gcc from the new profile in an already
 * running shell, please remember to do:

 *   # source /etc/profile

zabno gcc #


and one which is the right one..... anyone please???
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 2:41 am    Post subject: Reply with quote

FIXED!
https://forums.gentoo.org/viewtopic.php?t=133018

changed the chost in my make.conf , env-update and ldconfig and it works now :P using 3.3.6 again


one question.... now when i try and run emerge -uavDN it doesn't list 3.4.4 anymore... could i just run it again and proceed.. but in the listing it shows 3.3.6 and the same python i have now with an R in front of them.... would this be a wise decision?
Back to top
View user's profile Send private message
xtlosx
Apprentice
Apprentice


Joined: 14 Jan 2006
Posts: 219
Location: Chicago

PostPosted: Tue Feb 21, 2006 8:52 pm    Post subject: Reply with quote

anyone have an ideas?
Back to top
View user's profile Send private message
soigres
l33t
l33t


Joined: 09 Dec 2004
Posts: 648
Location: Milano, Italy

PostPosted: Tue Feb 28, 2006 11:31 am    Post subject: Reply with quote

xtlosx wrote:
FIXED!
https://forums.gentoo.org/viewtopic.php?t=133018

changed the chost in my make.conf , env-update and ldconfig and it works now :P using 3.3.6 again


one question.... now when i try and run emerge -uavDN it doesn't list 3.4.4 anymore... could i just run it again and proceed.. but in the listing it shows 3.3.6 and the same python i have now with an R in front of them.... would this be a wise decision?
i have emerged 3.4.5 and unmerged 3.3.6 before updating system and others... so i have the same error... what do i have to change in my CHOST?
thanks!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Feb 28, 2006 11:11 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of this FAQ: Error while loading shared libraries: libstdc++.so.5.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum