Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error on ./configure on any packet
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
SirDzstic
n00b
n00b


Joined: 21 Feb 2006
Posts: 10

PostPosted: Tue Feb 21, 2006 9:09 am    Post subject: Error on ./configure on any packet Reply with quote

Hi,

since yesterday, Portage stops on any packet that has a configure script.
Configure always reports an error about the command line options that
differ from packet to packet.

Example 1: sys-libs/glibc

Example 2: (sys-devel/autoconf)
Quote:
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/autoconf-2.59-r7/work/autoconf-2.59 ...
* econf: updating autoconf-2.59/config/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating autoconf-2.59/config/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --program-suffix=-2.59 --build=i686-pc-linux-gnu
configure: error: expected an absolute directory name for --datadir:

!!! ERROR: sys-devel/autoconf-2.59-r7 failed.
Call stack:
ebuild.sh, line 1894: Called dyn_compile
ebuild.sh, line 941: Called src_compile
autoconf-2.59-r7.ebuild, line 31: Called econf 'compile'

Note that configure indeed gets an absolute directory for --datadir

The last properly merged packets were:
Quote:
Sun Feb 19 01:35:22 2006 >>> sys-libs/glibc-2.3.6-r3
Sun Feb 19 01:43:10 2006 >>> sys-apps/coreutils-5.94
Sun Feb 19 01:43:46 2006 >>> sys-apps/baselayout-1.12.0_pre16-r1
Sun Feb 19 01:44:11 2006 >>> app-misc/pax-utils-0.1.10


I have ACCEPT_KEYWORDS="~x86" in my make.conf, but removing it doesn't help.

I'd be grateful for any help.
Back to top
View user's profile Send private message
Anaki
n00b
n00b


Joined: 06 Nov 2005
Posts: 34
Location: Hungary

PostPosted: Tue Feb 21, 2006 9:25 am    Post subject: Reply with quote

Hi!

I had the same problem when (yesterday) i decided to rebuild my system, and recompiled glibc with USE-flag "nptl nptlonly" :?
Back to top
View user's profile Send private message
SirDzstic
n00b
n00b


Joined: 21 Feb 2006
Posts: 10

PostPosted: Tue Feb 21, 2006 9:30 am    Post subject: Reply with quote

Taking nptl and nptlonly out of my USE flags didn't help :/
Back to top
View user's profile Send private message
Anaki
n00b
n00b


Joined: 06 Nov 2005
Posts: 34
Location: Hungary

PostPosted: Tue Feb 21, 2006 10:27 am    Post subject: Reply with quote

Yes, i know, now I have started from scratch, with "nptl", without "nptlonly". Now compiling glibc... :roll:
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Feb 21, 2006 10:33 am    Post subject: Reply with quote

coreutils-5.94 is broken. See this thread: https://forums.gentoo.org/viewtopic-t-435291.html
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
SirDzstic
n00b
n00b


Joined: 21 Feb 2006
Posts: 10

PostPosted: Tue Feb 21, 2006 10:45 am    Post subject: Reply with quote

Replacing the expr binary resolved the issue. Thanks a lot.

I'll add coreutils-5.94 to my package.mask and pray that it'll be fine in the next release :)
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Feb 21, 2006 10:49 am    Post subject: Reply with quote

SirDzstic wrote:
I'll add coreutils-5.94 to my package.mask and pray that it'll be fine in the next release :)

It's already been masked, and coreutils-5.94-r1 has been released which seems to fix the issue. :D
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
SirDzstic
n00b
n00b


Joined: 21 Feb 2006
Posts: 10

PostPosted: Tue Feb 21, 2006 10:51 am    Post subject: Reply with quote

That's even better :D
Back to top
View user's profile Send private message
Anaki
n00b
n00b


Joined: 06 Nov 2005
Posts: 34
Location: Hungary

PostPosted: Tue Feb 21, 2006 12:01 pm    Post subject: Reply with quote

:D
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Feb 21, 2006 1:10 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum