Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge freezes during --sync on PowerMac MT
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
flaffer
n00b
n00b


Joined: 25 Jan 2003
Posts: 7

PostPosted: Mon Feb 27, 2006 3:23 pm    Post subject: Emerge freezes during --sync on PowerMac MT Reply with quote

Greetings!

I am having a strange issue with emerge on a PowerMac Mini Tower with 384meg RAM and a 500MHz G3 upgrade CPU. I cannot get an emerge --sync to finish.

I first noticed the issue when I would setup some downloads that would be going all night and when I wake up the next morning, the box had rebooted. I traced the issue to a particular time every night which screamed CRON! Checked cron and I had an emerge --sync job running nightly to keep my ebuild list up-to-date. I was able to replicate by running emerge --sync from command line. All of sudden, in the media section of the rsync, the output would freeze and then, a minute or so later (possibly longer), I would get a reboot.

Sometimes, though, I just get the freeze and I have to power reset. I cannot get emerge --sync to finish once.

Other things I tried:

1) I run VNC with Windowmaker and I usually run emerge from the xTerm windown in VNC. I thought that this may be an issue so after rebooting, I did not start X but ran the emerge from SSH command line. Still freezes.

2) I switched kernels since the only major change I can think of was that I upgraded the kernel from 2.6.9, I believe, to 2.6.14 or something to that affect. The freeze happens on both kernels.

3) I ran emerge --refresh which completed successfully with no errors. Did not seem to make a difference.

Any ideas?

More Information:

Here is my emerge --info:

---------Begin Output------------

Portage 2.0.53 (default-linux/ppc/2005.1/ppc, gcc-3.4.4, glibc-2.3.5-r3, 2.6.9 ppc)
=================================================================
System uname: 2.6.9 ppc 7400, altivec supported
Gentoo Base System version 1.6.14
dev-lang/python: 2.3.5, 2.4.2
sys-apps/sandbox: 1.2.12
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils: 2.16.1
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-mcpu=G3 -O3 -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=G3 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ http://mirror.datapipe.net/gentoo http://prometheus.cs.wmich.edu/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X alsa audiofile berkdb bitmap-fonts bzip2 cdr crypt cups dvd eds emboss esd exif expat fam fortran gdbm gif glut gpm gstreamer gtk2 idn ipv6 jpeg kde lcms libwww mad mng motif mp3 mpeg ncurses nls ogg oggvorbis opengl pam pcre pdflib perl png python qt readline spell ssl tcpd tiff truetype truetype-fonts type1-fonts udev unicode vorbis xml2 xv zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

---------End output-----------



Here is a snippet showing where the last emerge --sync failed:

---------Begin Output-----------

media-gfx/enblend/Manifest
1580 100% 0.00kB/s 0:00:00
media-gfx/enblend/metadata.xml
254 100% 0.00kB/s 0:00:00
media-gfx/ephoto/ChangeLog
344 100% 0.00kB/s 0:00:00
media-gfx/ephoto/Manifest
media-plugins/gst-plugins-v4l2/files/
media-plugins/gst-plugins-vorbis/
1109 100% 0.00kB/s 0:00:00
media-gfx/ephoto/ephoto-9999.ebuild
media-plugins/gst-plugins-vorbis/files/
media-plugins/gst-plugins-xvideo/
media-plugins/gst-plugins-xvideo/files/
485 100% 0.00kB/s 0:00:00
media-gfx/ephoto/files/digest-ephoto-9999
0 100% 0.00kB/s 6:04:48
media-gfx/ephoto/metadata.xml
221 100% 0.00kB/s 0:00:00
media-gfx/f-spot/ChangeLog
1382 100% 0.00kB/s 0:00:00
media-gfx/f-spot/Manifest
media-plugins/libvisual-plugins/
3561 100% 0.00kB/s 0:00:00

---------End Output------------
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Feb 27, 2006 3:30 pm    Post subject: Reply with quote

It's hard to say to be honest. Are you sure that the machine isn't overheating? It could also be the PMU in this system. If it detects an error, or there is too much delay in updating it, it will reset the computer. Are you sure that your disks are okay? Have you tried copying large files around? I think your machine is a B+W G3 (right?) if so, there are issues with the IDE controller on these machines, if you have more than one disk on either IDE channel, there can be problems too.

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
flaffer
n00b
n00b


Joined: 25 Jan 2003
Posts: 7

PostPosted: Mon Feb 27, 2006 4:07 pm    Post subject: Emerge freezes during --sync on PowerMac MT Reply with quote

Code:
It's hard to say to be honest. Are you sure that the machine isn't overheating? It could also be the PMU in this system. If it detects an error, or there is too much delay in updating it, it will reset the computer. Are you sure that your disks are okay? Have you tried copying large files around? I think your machine is a B+W G3 (right?) if so, there are issues with the IDE controller on these machines, if you have more than one disk on either IDE channel, there can be problems too.


I will run fsck on the disks. I have seen no issues. I downloaded about 1.8gig from the box the other day, and have been downloading and writing to the disk from downloads for a long time now. I did have some burning DVD issues but it is hard to say if this is related.

I do not believe it is heat as I have the box running 24/7 and I download gigs a week. But it could be that the emerge is doing processing that my other programs do not (running Firefox, K3b, and BitTornado, X, etc.).

I am intimately familiar with the IDE issues. In fact, I moved from ext3 to reiserfs to (hopefully) get around the issue. SO far, I have had solid stability BESDIES this issue. I had gotten lots of kernel panics before, as well as FS fragging which caused me to rebuild the machine several times.

Its weird that emerge itself is the only app to have a problem but nothing else does (except for the K3B issue where it would freeze when switching from writing to verifying.

Thanks,

Flaffer
Back to top
View user's profile Send private message
flaffer
n00b
n00b


Joined: 25 Jan 2003
Posts: 7

PostPosted: Mon Feb 27, 2006 8:49 pm    Post subject: Emerge freezes during --sync on PowerMac MT Reply with quote

Additional Information:

I tried to emerge ntp and got the following output:

Code:
emerge ntp   
Calculating dependencies ...done!
>>> emerge (1 of 3) dev-lang/swig-1.3.21 to /
>>> Downloading http://gentoo.chem.wisc.edu/gentoo/distfiles/swig-1.3.21.tar.gz
--07:06:50--  http://gentoo.chem.wisc.edu/gentoo/distfiles/swig-1.3.21.tar.gz
           => `/usr/portage/distfiles/swig-1.3.21.tar.gz'
Resolving gentoo.chem.wisc.edu... 128.104.70.13
Connecting to gentoo.chem.wisc.edu|128.104.70.13|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,023,025 (1.9M) [application/x-tar]

100%[==================================================================>] 2,023,025    160.30K/s    ETA 00:00

07:07:03 (159.61 KB/s) - `/usr/portage/distfiles/swig-1.3.21.tar.gz' saved [2023025/2023025]

!!! Security Violation: A file exists that is not in the manifest.
!!! File: files/digest-swig-1.3.24


Note that it had JUST downloaded that file! How does that happen?
Flaffer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum