Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OH MY GOD! My WORLD file just vanished! PLEASE HELP!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
kEiNsTeiN
Guru
Guru


Joined: 29 Apr 2005
Posts: 361
Location: Germany

PostPosted: Fri Mar 03, 2006 1:18 am    Post subject: OH MY GOD! My WORLD file just vanished! PLEASE HELP! Reply with quote

Hi! I almost died from cardiac arrest about 5 minutes ago, when I discovered that 100% of my world-file vanished!!! I have no idea what happened, but he says I dont even have X11 or kde installed.... WTF?

Code:
veitbook veit # emerge -ep world


These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] sys-devel/patch-2.5.9-r1
[ebuild  N    ] sys-libs/zlib-1.2.3
[ebuild  N    ] sys-libs/gdbm-1.8.3-r2
[ebuild  N    ] sys-devel/binutils-config-1.8-r6
[ebuild  N    ] sys-devel/gnuconfig-20060227
[ebuild  N    ] sys-devel/binutils-2.16.1-r2
[ebuild  N    ] sys-libs/ncurses-5.5-r1
[ebuild  N    ] sys-devel/m4-1.4.4
[ebuild  N    ] sys-devel/bison-2.1
[ebuild  N    ] virtual/libintl-0
[ebuild  N    ] sys-apps/sed-4.1.4-r1
[ebuild  N    ] sys-apps/texinfo-4.8-r3
[ebuild  N    ] sys-devel/gcc-config-1.3.13-r1
[ebuild  N    ] sys-devel/gcc-3.4.5-r1
[ebuild  N    ] sys-libs/libstdc++-v3-3.3.6
[ebuild  N    ] sys-kernel/linux-headers-2.6.11-r3
[ebuild  N    ] sys-libs/timezone-data-2006a
[ebuild  N    ] sys-libs/glibc-2.3.6-r3
[ebuild  N    ] sys-devel/gettext-0.14.5
[ebuild  N    ] sys-apps/diffutils-2.8.7-r1
[ebuild  N    ] sys-apps/groff-1.19.2
[ebuild  N    ] sys-devel/libperl-5.8.8
[ebuild  N    ] dev-lang/perl-5.8.8
[ebuild  N    ] dev-libs/openssl-0.9.7i
[ebuild  N    ] sys-apps/man-1.6c
[ebuild  N    ] app-shells/bash-3.1_p10
[ebuild  N    ] app-admin/perl-cleaner-1.03
[ebuild  N    ] app-misc/ca-certificates-20050804
[ebuild  N    ] dev-libs/expat-1.95.8
[ebuild  N    ] dev-lang/python-2.4.2-r1
[ebuild  N    ] dev-python/python-fchksum-1.7.1
[ebuild  N    ] sys-apps/sandbox-1.2.17
[ebuild  N    ] app-misc/pax-utils-0.1.10
[ebuild  N    ] sys-apps/debianutils-2.15
[ebuild  N    ] dev-python/pycrypto-2.0.1-r4
[ebuild  N    ] sys-apps/portage-2.1_pre5-r2
*** Please update portage to the above version before proceeding.
    Failure to do so may result in failed or improper merges.
    A simple 'emerge -u portage' is sufficient.

[ebuild  N    ] sys-apps/man-pages-2.24
[ebuild  N    ] app-i18n/man-pages-de-0.4
[ebuild  N    ] virtual/perl-Test-Simple-0.62
[ebuild  N    ] dev-perl/Locale-gettext-1.05
[ebuild  N    ] sys-apps/help2man-1.35.1
[ebuild  N    ] sys-devel/autoconf-2.13
[ebuild  N    ] sys-devel/autoconf-wrapper-3.2
[ebuild  N    ] sys-devel/autoconf-2.59-r7
[ebuild  N    ] sys-devel/automake-1.5
[ebuild  N    ] sys-devel/automake-1.8.5-r3
[ebuild  N    ] sys-devel/automake-1.6.3
[ebuild  N    ] sys-devel/automake-1.7.9-r1
[ebuild  N    ] sys-devel/automake-1.4_p6
[ebuild  N    ] sys-devel/automake-wrapper-1-r1
[ebuild  N    ] sys-devel/automake-1.9.6-r1
[ebuild  N    ] sys-libs/cracklib-2.8.5-r1
[ebuild  N    ] sys-devel/flex-2.5.33-r1
[ebuild  N    ] dev-util/pkgconfig-0.20
[ebuild  N    ] sys-libs/pam-0.78-r4
[ebuild  N    ] sys-apps/shadow-4.0.14-r1
[ebuild  N    ] sys-devel/libtool-1.5.22
[ebuild  N    ] sys-apps/pam-login-4.0.14
[ebuild  N    ] sys-libs/com_err-1.38
[ebuild  N    ] sys-libs/ss-1.38
[ebuild  N    ] sys-fs/e2fsprogs-1.38-r1
[ebuild  N    ] app-crypt/hashalot-0.3-r2
[ebuild  N    ] sys-apps/util-linux-2.12r-r3
[ebuild  N    ] sys-apps/grep-2.5.1a
[ebuild  N    ] app-arch/gzip-1.3.5-r8
[ebuild  N    ] sys-apps/net-tools-1.60-r11
[ebuild  N    ] sys-apps/kbd-1.12-r5
[ebuild  N    ] net-misc/iputils-021109-r3
[ebuild  N    ] sys-apps/busybox-1.1.0
[ebuild  N    ] sys-process/procps-3.2.6
[ebuild  N    ] sys-libs/pwdb-0.62
[ebuild  N    ] sys-apps/gawk-3.1.5
[ebuild  N    ] app-arch/bzip2-1.0.3-r6
[ebuild  N    ] app-arch/tar-1.15.1
[ebuild  N    ] sys-process/psmisc-22.1
[ebuild  N    ] sys-libs/readline-5.1_p2
[ebuild  N    ] sys-apps/sysvinit-2.86-r5
[ebuild  N    ] sys-apps/coreutils-5.94-r1
[ebuild  N    ] sys-apps/baselayout-1.12.0_pre16-r3
[ebuild  N    ] sys-apps/hotplug-base-20040401
[ebuild  N    ] sys-fs/udev-086
[ebuild  N    ] app-editors/nano-1.3.10-r1
[ebuild  N    ] sys-apps/module-init-tools-3.2.2
[ebuild  N    ] sys-apps/file-4.16
[ebuild  N    ] sys-devel/make-3.80-r4
[ebuild  N    ] sys-kernel/gentoo-sources-2.6.15-r6
[ebuild  N    ] media-libs/libpng-1.2.8-r1
[ebuild  N    ] app-admin/eselect-1.0
[ebuild  N    ] app-admin/eselect-opengl-1.0.3
[ebuild  N    ] x11-base/opengl-update-3.0.0
[ebuild  N    ] media-libs/freetype-2.1.10
[ebuild  N    ] media-libs/fontconfig-2.3.2
[ebuild  N    ] x11-apps/ttmkfdir-3.0.9-r3
[ebuild  N    ] x11-base/xorg-x11-6.8.2-r6
[ebuild  N    ] sys-apps/which-2.16
[ebuild  N    ] app-arch/cpio-2.6-r5
[ebuild  N    ] app-arch/rpm2targz-9.0-r4
[ebuild  N    ] sys-apps/utempter-0.5.5.6
[ebuild  N    ] x11-terms/xterm-208
[ebuild  N    ] dev-libs/popt-1.7-r1
[ebuild  N    ] net-misc/rsync-2.6.6-r1
[ebuild  N    ] sys-apps/hdparm-6.3
[ebuild  N    ] sys-apps/tcp-wrappers-7.6-r8
[ebuild  N    ] net-misc/openssh-4.3_p1
[ebuild  N    ] sys-apps/findutils-4.3.0
[ebuild  N    ] net-misc/wget-1.10.2
[ebuild  N    ] x11-libs/cairo-1.0.2
[ebuild  N    ] dev-libs/glib-2.8.6
[ebuild  N    ] x11-libs/pango-1.10.3
[ebuild  N    ] sys-apps/less-394


I dont know what went wrong, but I accidently had 2 emerge syncs and emerge -uDN worlds running, which apparently killed my gentoo :(

I might have done some stupid stuff:

Code:
veitbook ~ # rm -r /var/tmp/portage/*
veitbook ~ # emerge -uDNatv world


These are the packages that would be merged, in reverse order:

Calculating world dependencies \
!!! Problems have been detected with your world file
!!! Please run emaint --check world

... done!

Total size of downloads: 0 kB

Nothing to merge; do you want me to auto-clean packages? [Yes/No]

Exiting on signal 2
veitbook ~ # emaint --check world
Checking world for problems

'net-analyzer/ethereal' is not installed
'media-sound/krecord' is not installed
'kde-base/quanta' is not installed
'kde-base/kcalc' is not installed
'media-sound/alsa-utils' is not installed
'media-sound/xmms' is not installed
'x11-themes/baghira' is not installed
'net-www/netscape-flash' is not installed
'kde-base/kedit' is not installed
'dev-db/mysql' is not installed
'media-gfx/bootsplash' is not installed
'media-libs/alsa-oss' is not installed
'kde-base/kgpg' is not installed
'media-video/mpeg4ip' is not installed
'x11-themes/lipstik' is not installed
'net-im/psi' is not installed
'app-crypt/gpg-agent' is not installed
'dev-util/subversion' is not installed
'media-tv/linuxtv-dvb-apps' is not installed
'net-www/apache' is not installed
'app-arch/unrar' is not installed
'app-crypt/pinentry' is not installed
'media-sound/amarok-svn' is not installed
'kde-base/kview' is not installed
'app-admin/syslog-ng' is not installed
'net-misc/tightvnc' is not installed
'media-video/nvidia-glx' is not installed
'net-wireless/ndiswrapper' is not installed
'app-dicts/aspell-de' is not installed
'media-sound/alsa-tools' is not installed
'net-misc/rdesktop' is not installed
'app-laptop/toshiba-utils' is not installed
'x11-libs/gtk+' is not installed
'kde-base/kontact' is not installed
'www-client/links' is not installed
'kde-base/kcontrol' is not installed
'media-libs/x264-svn' is not installed
'media-video/kaffeine' is not installed
'dev-lang/php' is not installed
'sys-process/vixie-cron' is not installed
'kde-base/kdeprint' is not installed
'media-libs/xine-lib' is not installed
'net-misc/curl' is not installed
'media-video/ffmpeg' is not installed
'net-misc/dhcpcd' is not installed
'app-portage/kuroo' is not installed
'net-p2p/azureus' is not installed
'app-laptop/laptop-mode-tools' is not installed
'kde-base/nsplugins' is not installed
'app-portage/gentoolkit-dev' is not installed
'media-video/nvidia-kernel' is not installed
'kde-base/ksnapshot' is not installed
'kde-base/kmenuedit' is not installed
'net-wireless/kdebluetooth' is not installed
'net-misc/kbandwidth' is not installed
'media-libs/libquicktime' is not installed
'games-fps/quake4-bin' is not installed
'app-text/dos2unix' is not installed
'kde-base/konq-plugins' is not installed
'media-video/lives' is not installed
'media-libs/faad2' is not installed
'app-laptop/fnfx' is not installed
'media-video/vlc' is not installed
'kde-base/kaudiocreator' is not installed
'x11-drivers/synaptics' is not installed
'media-libs/libmp4v2' is not installed
'media-plugins/gst-plugins-faad' is not installed
'media-sound/xmmsctrl' is not installed
'x11-themes/crystal' is not installed
'media-video/mplayer' is not installed
'net-misc/telnet-bsd' is not installed
'net-wireless/wpa_supplicant' is not installed
'kde-base/kicker' is not installed
'kde-base/klaptopdaemon' is not installed
'x11-themes/mplayer-skins' is not installed
'dev-python/pylibacl' is not installed
'media-plugins/xmms-alarm' is not installed
'kde-base/kdebase-startkde' is not installed
'dev-util/ccache' is not installed
'kde-base/konsole' is not installed
'media-video/xine-ui' is not installed
'app-portage/ufed' is not installed
'app-admin/webmin' is not installed
'dev-python/PyQt' is not installed
'kde-base/kopete' is not installed
'kde-base/konqueror' is not installed
'net-wireless/bluetooth-alsa-utils' is not installed
'kde-base/kmail' is not installed
'media-sound/cvoicecontrol' is not installed
'app-emulation/wine' is not installed
'kde-base/ark' is not installed
'x11-libs/qt' is not installed
'media-video/dvdrip' is not installed
'app-office/openoffice' is not installed
'sci-visualization/gnuplot' is not installed
'media-video/nvclock' is not installed
'app-misc/logitech-applet' is not installed
'app-arch/rar' is not installed
'x11-misc/dekorator' is not installed
'sys-boot/grub' is not installed
'sys-apps/slocate' is not installed
'kde-base/kpdf' is not installed
'net-wireless/bluetooth-alsa-kernel' is not installed
'media-video/realplayer' is not installed
'net-wireless/ap-utils' is not installed
'www-client/mozilla-firefox' is not installed
'app-cdr/k3b' is not installed
'x11-libs/pango' is not installed
'app-editors/joe' is not installed
'kde-base/kdialog' is not installed
'app-text/aspell' is not installed
'app-portage/gentoolkit' is not installed
'x11-libs/wxGTK' is not installed
'sys-apps/hotplug' is not installed
'app-misc/screen' is not installed


Finished

veitbook ~ # emaint --fix world
Attempting to fix world
Finished


I also did the following after I broke some packages by emerge --prune a few days ago:
Code:
emerge sync && emerge portage && emerge -uDN world && revdep-rebuild -i && emerge amarok-svn


I always do stupid stuff when I leave my PC alone to do work when I'm gone... Maybe I should tape it to my back....

Is there any way I could repair the damage? I do have emerge.log, I could post it or upload it somewhere....

Please help! I'm desperate
_________________
make me a sandwich. - what? make it yourself. - sudo make me a sandwich. - okay.


Last edited by kEiNsTeiN on Fri Mar 03, 2006 1:24 am; edited 1 time in total
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Fri Mar 03, 2006 1:21 am    Post subject: Reply with quote

You included the -e option to emerge, which means, --emptytree. You told emerge to assume that *nothing* was installed, hence the long output.

A "man emerge" might be in order.
Back to top
View user's profile Send private message
kEiNsTeiN
Guru
Guru


Joined: 29 Apr 2005
Posts: 361
Location: Germany

PostPosted: Fri Mar 03, 2006 1:24 am    Post subject: Reply with quote

Oh, yes, stupid me, but he still only lists a few packages, excluding the ones I obviously have installed....

edit: I edited the first post...

edit2: I have kuroo installed, with a database from about 4 days ago. If I dont start it, it should have a pretty accurate clue about what is installed, and what isnt. If I can keep it from synching with the world file, I might be able to use the information to rebuild it. How could I archieve that? Or are there any better ideas?
_________________
make me a sandwich. - what? make it yourself. - sudo make me a sandwich. - okay.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Fri Mar 03, 2006 1:42 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this FAQ.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum