Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-base/kdebase-3.5.1-r3 does not compile while emake
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
darkrazor
n00b
n00b


Joined: 04 Mar 2006
Posts: 9

PostPosted: Sat Mar 04, 2006 8:59 pm    Post subject: kde-base/kdebase-3.5.1-r3 does not compile while emake Reply with quote

Hi,
I was trying to emerge -uD world but it broke at compiling kdebase...

But the error it returns/and similar ones are returning more often when
compiling other (kde related) applications...

Code:

.............
_storage'
konq_sound.cc:(.text+0x7f9): undefined reference to `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'
konq_sound.cc:(.text+0x806): undefined reference to `__gnu_cxx::__exchange_and_add(int volatile*, int)'
konq_sound.cc:(.text+0x853): undefined reference to `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'
konq_sound.cc:(.text+0x860): undefined reference to `__gnu_cxx::__exchange_and_add(int volatile*, int)'
konq_sound.cc:(.text+0x8a4): undefined reference to `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'
konq_sound.cc:(.text+0x8b1): undefined reference to `__gnu_cxx::__exchange_and_add(int volatile*, int)'
.libs/konq_sound.o: In function `KonqSoundPlayerImpl::mimeTypes()':
konq_sound.cc:(.text+0xa5f): undefined reference to `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'
konq_sound.cc:(.text+0xa6f): undefined reference to `__gnu_cxx::__exchange_and_add(int volatile*, int)'
konq_sound.cc:(.text+0xb52): undefined reference to `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'
konq_sound.cc:(.text+0xb65): undefined reference to `__gnu_cxx::__exchange_and_add(int volatile*, int)'
collect2: ld returned 1 exit status
make[3]: *** [konq_sound.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdebase-3.5.1-r3/work/kdebase-3.5.1/libkonq'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdebase-3.5.1-r3/work/kdebase-3.5.1/libkonq'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdebase-3.5.1-r3/work/kdebase-3.5.1'
make: *** [all] Error 2

!!! ERROR: kde-base/kdebase-3.5.1-r3 failed.
Call stack:
  ebuild.sh, line 1933:   Called dyn_compile
  ebuild.sh, line 971:   Called src_compile
  kdebase-3.5.1-r3.ebuild, line 116:   Called kde_src_compile
  kde.eclass, line 111:   Called kde_src_compile 'compile'
  kde.eclass, line 228:   Called kde_src_compile 'all' 'myconf' 'configure'

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.


Thanks in advance for (hopingly) helping me out!

niels
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Sat Mar 04, 2006 10:43 pm    Post subject: Reply with quote

Are you using visibility support?
Because this one looks kind of like it... :idea:
Also , emerge --info would be nice.
_________________
Retired gentoo user
Back to top
View user's profile Send private message
darkrazor
n00b
n00b


Joined: 04 Mar 2006
Posts: 9

PostPosted: Sat Mar 04, 2006 10:55 pm    Post subject: Reply with quote

Tiger683 wrote:
Are you using visibility support?
Because this one looks kind of like it... :idea:
Also , emerge --info would be nice.


I'm affraid I don't really what visibility support is, I'm not really a newby but never heard about visibility support...

As far as I know I did not mess around with any USE flags so leaved the ebuild untouched..

Here is my emerge --info

Code:

Portage 2.1_pre5-r3 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r3, 2.6.15-suspend2-r1YukosBuild-B1 i686)
=================================================================
System uname: 2.6.15-suspend2-r1YukosBuild-B1 i686 Mobile AMD Sempron(tm) Processor 2800+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5-r2, 2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-Os -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts crypt cups eds emboss encode foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl tcpd truetype truetype-fonts type1-fonts vorbis xml2 xmms xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
Jeremy_Z
l33t
l33t


Joined: 05 Apr 2004
Posts: 671
Location: Shanghai

PostPosted: Sun Mar 05, 2006 10:12 am    Post subject: Reply with quote

You might have been lucky on this one, i am beginning to think that this upgrade of kdebase broke my kmail/kontact.
I am not quite sure yet but now, kmail odesn't start because it hangs while reading the dcop socket so ...
_________________
"Because two groups of consumers drive the absolute high end of home computing: the gamers and the porn surfers." /.
My gentoo projects, Kelogviewer and a QT4 gui for etc-proposals
Back to top
View user's profile Send private message
darkrazor
n00b
n00b


Joined: 04 Mar 2006
Posts: 9

PostPosted: Sun Mar 05, 2006 11:05 am    Post subject: Reply with quote

Jeremy_Z wrote:
You might have been lucky on this one, i am beginning to think that this upgrade of kdebase broke my kmail/kontact.
I am not quite sure yet but now, kmail odesn't start because it hangs while reading the dcop socket so ...


Well, but you did manage to upgrade kde-base at all.

I just want to emerge -uD world but it stops at kde-base, now I know I could mask kde-base but don't know how to manage it. It was adding a line to some file in /etc/portage...but forgotten it exactly...

Does someone knows what might be the problem?

niels
Back to top
View user's profile Send private message
Jeremy_Z
l33t
l33t


Joined: 05 Apr 2004
Posts: 671
Location: Shanghai

PostPosted: Sun Mar 05, 2006 3:50 pm    Post subject: Reply with quote

In : /etc/portage/package.mask
add : =kde-base/kdebase-3.5.1-r3

I think i will do that tomorrow and go back to r2 to see if kmail comes back.
_________________
"Because two groups of consumers drive the absolute high end of home computing: the gamers and the porn surfers." /.
My gentoo projects, Kelogviewer and a QT4 gui for etc-proposals
Back to top
View user's profile Send private message
ingemar
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2005
Posts: 83
Location: Gothenburg, Sweden

PostPosted: Thu Mar 16, 2006 10:25 pm    Post subject: Reply with quote

Have anyone got any version of kdebase-3.5.1 to compile at all? I've tried -r3, -r2 and -r1, and none of them worked. I'm running modular xorg, and has the problem described in the first post, but I don't have any version of kdebase installed previously.
_________________
iBook G4 12" & AMD X2 4200+
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed Mar 22, 2006 10:15 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-356008.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum