Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI proprietary drivers crash on xdm start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Jizackson
n00b
n00b


Joined: 31 Mar 2003
Posts: 4
Location: Dallas

PostPosted: Tue Mar 07, 2006 4:55 pm    Post subject: ATI proprietary drivers crash on xdm start Reply with quote

Hi, I've been running ati's proprietary drivers for my mobility radeon 9600 on my amd64 laptop for a few months now with no problems, but all of sudden they stopped working: X crashes upon load. I found the error msg that seems to be the cause of the crash in my Xorg.0.log:

Code:

(II) LoadModule: "fglrx"
(II) Loading /usr/lib64/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 6.8.0, module version = 8.22.5
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 0.7
[R200Setup] X version mismatch - detected X.org 7.0.-1.15, required X.org 6.8.0.0
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib64/modules/drivers/fglrx_drv.o
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)


I have v6.8.99.15-r4 installed of xorg-x11. fglrx has worked with this version before. Has anyone had this problem? Should I use v6.8.2 instead, or is there a work around for this? Here are some additional error msgs from my Xorg.0.log (there were no warnings):

Code:

grep EE /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Failed to load /usr/lib64/modules/extensions/libGLcore.so
(EE) Failed to load module "GLcore" (loader failed, 7)
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.


thanks,
Matt
Back to top
View user's profile Send private message
vinky
Apprentice
Apprentice


Joined: 24 Feb 2005
Posts: 214
Location: Sweden

PostPosted: Tue Mar 07, 2006 10:27 pm    Post subject: Reply with quote

Have you tried and reemerged ati-drivers?

This seems weird too:
Code:
[R200Setup] X version mismatch - detected X.org 7.0.-1.15, required X.org 6.8.0.0


7.0.-1.15???? -1?
Something seems quite wrong, but I guess I´m of no use here

Vinky
Back to top
View user's profile Send private message
Jizackson
n00b
n00b


Joined: 31 Mar 2003
Posts: 4
Location: Dallas

PostPosted: Tue Mar 07, 2006 10:58 pm    Post subject: Reply with quote

Yea I've tried re-emerging both ati-drivers and xorg-x11 .. to no avail. I'm starting to think this might be a bug so I think I'll go ahead and post it to bugzilla.

thanks,
Matt
Back to top
View user's profile Send private message
kovvu
n00b
n00b


Joined: 16 Mar 2006
Posts: 17

PostPosted: Sun Apr 16, 2006 12:59 am    Post subject: Reply with quote

Same problem here, very aggravating. ati-driver does not compile fglrx for xorg 7.0.0. On startup xorg detects the version as not compiled for 6.9.0 and unloads the module. I hope someone has a resolution for this soon. I had seen an earlier post referring to a bug being filed. The weird thing is that this does not occur on my other box that I upgraded from xorg 6.8.2. The one I am having the problem with is the one with a complely new modular X and ati-driver-8.23.7 (downgrade to older drivers does not work)

Code:

(EE) module ABI major version (0) doesn't match the server's version (1)
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(II) LoadModule: "mouse"


The problem seems to be with xorg-server, version 1.0.2-r2 does not do this strict checking of the driver version. :?
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Sun Apr 16, 2006 1:20 pm    Post subject: Reply with quote

Have same trouble:

Code:

(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 6.8.99.8, module version = 8.23.7
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 0.7
(EE) module ABI major version (0) doesn't match the server's version (1)
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)


:-/
Back to top
View user's profile Send private message
kovvu
n00b
n00b


Joined: 16 Mar 2006
Posts: 17

PostPosted: Sun Apr 16, 2006 1:46 pm    Post subject: Solved Reply with quote

emerge the following versions of the following:

x11-base/xorg-server-1.0.99.901

x11-drivers/xf86-input-mouse-mouse-1.0.4

x11-drivers/xf86-input-keyboard-1.0.1.3


or the downgrade your current x11-drivers as required.

The module loads just have to get direct rendering working.
Back to top
View user's profile Send private message
lowang_19
n00b
n00b


Joined: 28 Oct 2005
Posts: 66

PostPosted: Mon Apr 17, 2006 9:46 am    Post subject: Re: Solved Reply with quote

kovvu wrote:
emerge the following versions of the following:

x11-base/xorg-server-1.0.99.901

x11-drivers/xf86-input-mouse-mouse-1.0.4

x11-drivers/xf86-input-keyboard-1.0.1.3


or the downgrade your current x11-drivers as required.

The module loads just have to get direct rendering working.


this doesn't work for me, but
Code:
xorgconfig

works.
Back to top
View user's profile Send private message
xtbasic
n00b
n00b


Joined: 27 Nov 2004
Posts: 51

PostPosted: Tue Apr 18, 2006 12:25 am    Post subject: Reply with quote

I am also having this problem with the new xorg-server 1.0.99.901

Weird thing is that when i do a emerge -Duv world, it will upgrade to 1.0.99.901 w/ mesa 6.5.0-r2
then if i run emerge -Duv world again it goes back to mesa 6.5.0-r1 and the old xorg-server, and then
it just starts all over again (upgrade, then downgrade, then upgrade, then ... etc)

neither version that installs is working with my card though, they all spit out the same error at me
Back to top
View user's profile Send private message
Quoti
n00b
n00b


Joined: 18 Apr 2006
Posts: 8
Location: Amberg, Germany

PostPosted: Tue Apr 18, 2006 9:21 am    Post subject: Reply with quote

I have the same problem. A few days ago I played Supertux and suddenly mei screens turned black and one second later my computer went down. After a reboot I had the same error message.
I remerged xorg-server and mesa and then the error message changed a bit:
Code:
(EE) module ABI major version (6) is newer than the server's version (5)

After remerging xorg-server again the error occured again with (0) and (1).
I tried out the ati module, but I don't know how to tell him that i have two monitors connected and I don't want a clone on the second one but an extended screen over both of them.
Downgrade some packages as kovvu said didn't work and xorgconfig doesn't know the fglrx driver and uses the ati driver. That's the reason why it works after xorgconfig.
I also tried the new unofficial ati-drivers ebuild but it didn't work either.

I hope we can find a solution for that because I need my second screen and the direct rendering interface.
Back to top
View user's profile Send private message
fr3akX
n00b
n00b


Joined: 17 Oct 2005
Posts: 31
Location: LV

PostPosted: Tue Apr 18, 2006 5:27 pm    Post subject: Reply with quote

i have had the same problem tomorow! I downgrade to following versions:

Code:
x11-base/xorg-server-1.0.2-r3
x11-drivers/xf86-input-keyboard-1.0.1.3
x11-drivers/xf86-input-mouse-1.0.4


if dont work try rebuild ati-drivers!
all working now :D
_________________
http://chown.lv
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Tue Apr 18, 2006 7:57 pm    Post subject: Reply with quote

This problem is not isolated to AMD64, I am running a Centrino box, and I am having the same trouble.

I am trying out the rebuild on those packages, I will post my results if I get it working.
_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
Draconite
n00b
n00b


Joined: 05 Jan 2006
Posts: 20
Location: Norfolk, VA

PostPosted: Wed Apr 19, 2006 4:39 am    Post subject: Reply with quote

I've run into the same problem; Modular X won't start at all anymore. I try to start it up and....

(EE) module ABI major version (0) doesn't match the server's version (1)
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found



I've tried re-emerging pretty much the entire system, and to no avail. ati-drivers, x11, etc.

Help? :(
_________________
Interested in renting an excellent movie you havn't heard of? Try "The Dreamers"
Back to top
View user's profile Send private message
fr3akX
n00b
n00b


Joined: 17 Oct 2005
Posts: 31
Location: LV

PostPosted: Wed Apr 19, 2006 4:48 am    Post subject: Reply with quote

Quote:
I've run into the same problem; Modular X won't start at all anymore. I try to start it up and....

(EE) module ABI major version (0) doesn't match the server's version (1)
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found



I've tried re-emerging pretty much the entire system, and to no avail. ati-drivers, x11, etc.


Try to downgrade some X packages, look up![/quote]
_________________
http://chown.lv
Back to top
View user's profile Send private message
Draconite
n00b
n00b


Joined: 05 Jan 2006
Posts: 20
Location: Norfolk, VA

PostPosted: Wed Apr 19, 2006 5:39 am    Post subject: Reply with quote

That got it! Thank you :) I can login again! Woo!

Loopy Modular X to blame, I suppose.
_________________
Interested in renting an excellent movie you havn't heard of? Try "The Dreamers"
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Wed Apr 19, 2006 7:12 am    Post subject: Reply with quote

downgrading did not seem to help me at all.
_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
Quoti
n00b
n00b


Joined: 18 Apr 2006
Posts: 8
Location: Amberg, Germany

PostPosted: Wed Apr 19, 2006 9:22 am    Post subject: Reply with quote

Thank you :D Downgrading helped me a lot, now everything works fine again.
However, does anyone know when modular X will be fully implemented into the portage tree? If I want to update my system portage tells me that there is an X with a version number below 7 installed which is blocking some packages. As I have modular X 7, I think there might be a problem with that. Perhaps the same problem which has caused that module ABI error.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed May 03, 2006 7:46 am    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Duplicate Threads in favour of xorg-server-1.0.99.x ABI breaks nvidia/ati binary drivers.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum