Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
yet another weird yaboot error [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
m@o
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 184
Location: /eu/at/grz

PostPosted: Thu Mar 09, 2006 12:59 pm    Post subject: yet another weird yaboot error [solved] Reply with quote

hello world!

i've installed a gentoo on my pb G4.
now i can boot into linux. what i can't is boot into mac os x.

could somebody give me a sample yaboot.conf?

my partitions are:
Code:
/dev/hda1 partition table
/dev/hda2 boot thing
/dev/hda3 free space
/dev/hda4 mac os X
/dev/hda5 free space
/dev/hda6 home partition
/dev/hda7 swap
/dev/hda8 root


is there a default yaboot that is startet when there are faults in my config???

thx for any help


Last edited by m@o on Thu Mar 09, 2006 8:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
KeyserZero
n00b
n00b


Joined: 21 Mar 2005
Posts: 68

PostPosted: Thu Mar 09, 2006 1:10 pm    Post subject: Reply with quote

Hey!

Thats the output from cat /etc/yaboot.conf

Code:

## yaboot.conf generated by yabootconfig 1.0.8
##
## run: "man yaboot.conf" for details. Do not make changes until you have!!
##
## For a dual-boot menu, add one or more of:
## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

delay=30
boot=/dev/hda2
macosx=hd:4
ofboot=hd:2
defaultos=macosx
device=hd:
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/kernel-2.6.12
  root=/dev/hda5
  sysmap=/boot/System.map-2.6.12
  append="devfs=nomount gentoo=udev video=radeonfb:ywrap,mtrr,1280x854-32@60 splash=silent,theme:Gentoo-Hornet quiet CONSOLE=/dev/tty1"
  partition=5
  label=Linux-2.6.12
  read-only

image=/boot/kernel-dev
  root=/dev/hda5
  sysmap=/boot/System.map-2.6.15
  append="devfs=nomount gentoo=udev" #video=radeonfb:ywrap,mtrr,1280x854-32@60 splash=silent,theme:Gentoo-Hornet quiet CONSOLE=/dev/tty1"
  partition=5
  label=Linux-Dev
  read-only

enablecdboot
enableofboot

_________________
www.ruby-lang.org
Back to top
View user's profile Send private message
m@o
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 184
Location: /eu/at/grz

PostPosted: Thu Mar 09, 2006 5:40 pm    Post subject: Reply with quote

thank you for the example file!

seems to be that i had to alter the yaboot.conf file after yabootconfig, to add macox.

but after altering yaboot.conf you have to do:
Code:
ybin -v


this does an update to the right partition.
that i didn't do and therefor yaboot didn't find macosx!

hth some people who make the same mistake.
m@o
Back to top
View user's profile Send private message
KeyserZero
n00b
n00b


Joined: 21 Mar 2005
Posts: 68

PostPosted: Thu Mar 09, 2006 7:18 pm    Post subject: Reply with quote

Hehe =)

Please set the topic to solved!

Thanks

Greetz
_________________
www.ruby-lang.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum