Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pam-login is blocking sys-apps/shadow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
theomega
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2006
Posts: 88
Location: Germany

PostPosted: Tue Mar 14, 2006 4:15 pm    Post subject: pam-login is blocking sys-apps/shadow Reply with quote

Hy,
since my last sync i got the following message uppon updates:
Code:

[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.14-r2)


I normaly know how to handle blockings, but this time its different:
Both packages are needed for a running system I think! Without pam-login I can't logging on console (without kdm) and shadow is a core-package and emerge suggests not to remove it.

What can I do to fix this?

Distrib is ~x86


Thanks
TO
Back to top
View user's profile Send private message
carl.anderson
Apprentice
Apprentice


Joined: 05 Sep 2005
Posts: 162
Location: Mountain View

PostPosted: Tue Mar 14, 2006 4:16 pm    Post subject: check your use flags Reply with quote

I had the same problem. I fixed it by adding USE="pam" to my use flags.
Back to top
View user's profile Send private message
theomega
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2006
Posts: 88
Location: Germany

PostPosted: Tue Mar 14, 2006 4:23 pm    Post subject: Reply with quote

Hy,
thanks, but this didn't help, I still get this blocking!

Greetings
TO
Back to top
View user's profile Send private message
ttuegel
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 176
Location: Illinois, USA

PostPosted: Tue Mar 14, 2006 4:27 pm    Post subject: Reply with quote

I, too, suffer from the same problem on ~amd64. The suggestion about adding USE="pam" to my USE flags didn't help here, either. I've tried the merge with USE="pam" and USE="-pam", with no success.
Back to top
View user's profile Send private message
theomega
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2006
Posts: 88
Location: Germany

PostPosted: Tue Mar 14, 2006 4:29 pm    Post subject: Reply with quote

Hy,
i got the following "solution":
emerge -C pam-login

then do everything you want to emerge

and then

emerge pam-login

But this is not a right solution, only a workaround. Only try this if you are using kdm to log in, otherwise you might damage the whole system.
Back to top
View user's profile Send private message
bigbob73
Guru
Guru


Joined: 31 Dec 2004
Posts: 332
Location: Under the Lone Star

PostPosted: Tue Mar 14, 2006 4:29 pm    Post subject: Reply with quote

theomega wrote:
Hy,
thanks, but this didn't help, I still get this blocking!

Greetings
TO


Try emerge -C pam-login && emege shadow
_________________
A computers attention span is only as long as it's electrical cord (Murphy)
Back to top
View user's profile Send private message
drwook
Veteran
Veteran


Joined: 30 Mar 2005
Posts: 1322
Location: London

PostPosted: Tue Mar 14, 2006 4:34 pm    Post subject: Reply with quote

from a diff on the ebuilds for -r1 and -r2 of current shadow version

Code:
<       !pam? ( !sys-apps/pam-login )
---
>       !sys-apps/pam-login


Looks like a bug to me, but I'm not a dev - maybe the functionality's now in shadow too, but seems unlikely. Just going to go look on bugzilla to see...

[edit]Yeah figured I was probably being an idiot, from the changelog;
Quote:
12 Mar 2006; Diego Petten<C3><B2> <flameeyes@gentoo.org> +files/login.defs,
+files/login.pamd, +shadow-4.0.14-r2.ebuild:
Merge pam-login back into shadow, as 4.x version was already being used;
this means that upgrade from 4.0.14-r1 requires to remove pam-login before.
[/edit]

Last edited by drwook on Tue Mar 14, 2006 4:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
theomega
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2006
Posts: 88
Location: Germany

PostPosted: Tue Mar 14, 2006 4:35 pm    Post subject: Reply with quote

Hy,
i searched bugzilla already, but if you find a bug please post here!

Thanks
TO
Back to top
View user's profile Send private message
theomega
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2006
Posts: 88
Location: Germany

PostPosted: Tue Mar 14, 2006 4:54 pm    Post subject: Reply with quote

Hy,
but, as soon as I remove pam-login I cant login at console anymore. How can I fix this?

Thanks
TO
Back to top
View user's profile Send private message
ttuegel
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 176
Location: Illinois, USA

PostPosted: Tue Mar 14, 2006 5:06 pm    Post subject: Reply with quote

theomega wrote:
but, as soon as I remove pam-login I cant login at console anymore. How can I fix this?


The new version of shadow (shadow-4.0.14-r2) replaces the features that were in pam-login. Since I unmerged pam-login and merged shadow-4.0.14-r2, I've had no problems logging in on the console. Have you emerged shadow-4.0.14-r2 with the "pam" USE flag enabled?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Mar 14, 2006 5:36 pm    Post subject: Reply with quote

Please follow up to portage problem [SOLVED].

Moved from Portage & Programming to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum