Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amarok 1.4 beta : Compiling issue.[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Tue Mar 14, 2006 6:22 pm    Post subject: Amarok 1.4 beta : Compiling issue.[SOLVED] Reply with quote

I have tried to emerge the last amarok (you know, the player which take age to load ???), with this options :
package.keywords
Code:

media-sound/amarok ~x86
media-libs/gst-plugins-base ~x86
media-libs/gstreamer ~x86
media-libs/exscalibar ~x86


package.unmask
Code:

media-sound/amarok


But compilation fails for exscalibar.

Anyone succeeded in emerging it ?

Thx.
_________________
http://stan.openmod.org


Last edited by Frelon on Wed Mar 15, 2006 7:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
acid7711
n00b
n00b


Joined: 07 Dec 2005
Posts: 55
Location: Chicago

PostPosted: Wed Mar 15, 2006 1:13 am    Post subject: Reply with quote

I did, got it to work perfectly. I have almost the same setup you do, except I have 'media-libs/gstreamer' in my package.unmask as well. I don't remeber why I put it in there to tell you the truth. I don't think it was for amaroK. I keep notes of what I put in the keywords because I have quite a few, but not in the unmask file. Sorry I can't be of any more help. What error is exscalibar giving you?

If nothing else, you might want to compile it with use -exscalibar and see if that works. As far as I know, exscalibar is only used for the new moodbar feature that it has. Doesn't really do anything else that I know of.
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 15, 2006 10:50 am    Post subject: Reply with quote

Here the gcc output :

Code:
 g++  -o nite geddeinite.o main.o bobsview.o watchprocessor.o refresher.o bob.o bobport.o boblink.o processorview.o floatinglink.o capturer.o player.o hardbob.o domsoftbob.o softbob.o geddeinitebase.o qmake_image_collection.o moc_geddeinite.o moc_bobsview.o moc_watchprocessor.o moc_bob.o moc_bobport.o moc_geddeinitebase.o   -L../../src/qtextra -L../../src/geddei -L/usr/qt/3/lib -L/usr/X11R6/lib -lvorbisfile -lvorbis -logg -lmad -ldl -lasound -lsndfile -lqtextra -lgeddei -lqt-mt -lXext -lX11 -lm -lpthread
/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.4/../../../../powerpc-unknown-linux-gnu/bin/ld: cannot find -lsndfile
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [nite] Erreur 1
make[2]: Leaving directory `/var/tmp/portage/exscalibar-1.0.4/work/exscalibar-1.0.4/src/nite'
make[1]: *** [sub-nite] Erreur 2
make[1]: Leaving directory `/var/tmp/portage/exscalibar-1.0.4/work/exscalibar-1.0.4/src'
make: *** [sub-src] Erreur 2

!!! ERROR: media-libs/exscalibar-1.0.4 failed.
!!! Function src_compile, Line 44, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.



Sorry for the french locale !!!
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Mar 15, 2006 2:29 pm    Post subject: Reply with quote

You should always translate the error messages in the future.
It looks like there's a dependency on libsndfile, try emerging that first and then try again. If that works, you should probably report that as a bug.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 15, 2006 7:04 pm    Post subject: Reply with quote

Yes, it seems that this lib was not in the ebuild or something like that.
Thank.
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Mar 15, 2006 7:06 pm    Post subject: Reply with quote

Please report this as a bug if the dependency is missing from the ebuild.

Thanks!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 15, 2006 7:48 pm    Post subject: Reply with quote

Done.

(but I have another bug, when I try to play a file, it freeze, the same with amarok 1.3...btw, xmms works fine !!!)
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum