Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -e system fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Sun Mar 19, 2006 10:50 pm    Post subject: emerge -e system fails Reply with quote

Code:
config.status: executing krb5_config_prefix commands
(cd include && make krb5/autoconf.h)
make[1]: Entering directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/include'
make[1]: `krb5/autoconf.h' is up to date.
make[1]: Leaving directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/include'
making all in util...
make[1]: Entering directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/util'
making all in util/support...
make[2]: Entering directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/util/support'
i686-pc-linux-gnu-gcc -fPIC -DSHARED -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DKRB5_PRIVATE=1 -DKRB5_DEPRECATED=1 -DKRB5_DNS_LOOKUP_KDC=1 -DKRB5_DNS_LOOKUP_REALM=1 -DKRB5_DNS_LOOKUP=1 -DHAVE_LIBRESOLV=1 -DHAVE_RES_NINIT=1 -DHAVE_RES_NCLOSE=1 -DHAVE_RES_NSEARCH=1 -DHAVE_DN_SKIPNAME=1 -DHAVE_RES_SEARCH=1 -DHAVE_PRAGMA_WEAK_REF=1 -DDELAY_INITIALIZER=1 -DCONSTRUCTOR_ATTR_WORKS=1 -DDESTRUCTOR_ATTR_WORKS=1 -DENABLE_THREADS=1 -DHAVE_PTHREAD=1 -DHAVE_PTHREAD_MUTEXATTR_SETROBUST_NP_IN_THREAD_LIB=1 -DHAVE_PTHREAD_RWLOCK_INIT_IN_THREAD_LIB=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MEMMOVE=1 -DHAVE_REGCOMP=1 -DGETSOCKNAME_ARG2_TYPE=struct\ sockaddr -DGETSOCKNAME_ARG3_TYPE=size_t -DGETPEERNAME_ARG2_TYPE=GETSOCKNAME_ARG2_TYPE -DGETPEERNAME_ARG3_TYPE=GETSOCKNAME_ARG3_TYPE -DHAVE_LIBUTIL=1 -DHAVE_SYSLOG_H=1 -DHAVE_STDARG_H=1 -DHAVE_SYS_SELECT_H=1 -DHAVE_IFADDRS_H=1 -DHAVE_UNISTD_H=1 -DHAVE_OPENLOG=1 -DHAVE_SYSLOG=1 -DHAVE_CLOSELOG=1 -DHAVE_STRFTIME=1 -DHAVE_VSPRINTF=1 -DNEED_SWAB_PROTO=1 -DHAVE_STRUCT_SOCKADDR_STORAGE=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_NETDB_H=1 -DHAVE_INET_NTOP=1 -DHAVE_INET_PTON=1 -DHAVE_GETNAMEINFO=1 -DHAVE_GETADDRINFO=1 -DKRB5_USE_INET6=1 -DPOSIX_SIGNALS=1 -DUSE_RCACHE=1 -DRETSIGTYPE=void -DHAVE_GETHOSTBYNAME_R=1 -DHAVE_GETSERVBYNAME_R=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1   -I../../include -I./../../include -I../../include/krb5 -I./../../include/krb5 -I. -I.  -march=athlon-xp -pipe -O3 -fweb -frename-registers -fforce-addr -fomit-frame-pointer -ftracer -pthread -c threads.c -o threads.so.o && mv -f threads.so.o threads.so
threads.c: In function `krb5int_pthread_loaded':
threads.c:145: error: `pthread_mutexattr_setrobust_np' undeclared (first use in this function)
threads.c:145: error: (Each undeclared identifier is reported only once
threads.c:145: error: for each function it appears in.)
make[2]: *** [threads.so] Error 1
make[2]: Leaving directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/util/support'
make[1]: *** [all-recurse] Error 1
make[1]: Leaving directory `/var/tmp/portage/mit-krb5-1.4.3/work/krb5-1.4.3/src/util'
make: *** [all-recurse] Error 1

!!! ERROR: app-crypt/mit-krb5-1.4.3 failed.
Call stack:
  ebuild.sh, line 1565:   Called dyn_compile
  ebuild.sh, line 974:   Called src_compile

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

livecd / #


Code:
livecd / # emerge --info
Portage 2.1_pre6-r4 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.4-r1, 2.6.15-gentoo-r5 i686)
=================================================================
System uname: 2.6.15-gentoo-r5 i686 AMD Sempron(tm)
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -pipe -O3 -fweb -frename-registers -fforce-addr -fomit-frame-pointer -ftracer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -pipe -O3 -fweb -frename-registers -fforce-addr -fomit-frame-pointer -ftracer -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib acl acpi alsa apache2 apm arts avi berkdb bitmap-fonts bzlib cli crypt ctype cups curl dba dri dvd eds emboss encode esd expat fastbuild flash foomaticdb force-cgi-redirect fortran ftp gd gdbm ggi gif gmp gnome gpm gstreamer gtk gtk2 iconv imagemagick imap imlib ipv6 jpeg kde kerberos ldap libclamav libg++ libwww mad maildir mbox memlimit mhash mikmod mmap mmx motif mp3 mpeg mpi mysql ncurses nis nls nptl nptlonly oav ogg opengl oss pam pcre pdflib perl php png posix postgres python qdbm qt quicktime readline recode samba sasl sdl session shared simplexml slp soap sockets spell spl ssl svga symlink sysvipc tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev unicode vorbis xml xml2 xmms xsl xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, LINGUAS
Back to top
View user's profile Send private message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Sun Mar 19, 2006 11:01 pm    Post subject: Reply with quote

I changed my make.conf file to this. I am doing a emerge --sync and then emerge -e system.

Code:
#/etc/make.conf
CHOST="i686-pc-linux-gnu"
#
CFLAGS="-march=athlon-xp"
#
CFLAGS="${CFLAGS} -pipe"
CFLAGS="${CFLAGS} -O2"
#CFLAGS="${CFLAGS} -fweb"
#CFLAGS="${CFLAGS} -frename-registers"
#CFLAGS="${CFLAGS} -fforce-addr"
CFLAGS="${CFLAGS} -fomit-frame-pointer"
#CFLAGS="${CFLAGS} -ftracer"
#
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
#
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
#
ACCEPT_KEYWORDS="x86"
PORTAGE_TMPDIR=/var/tmp
PORTDIR=/usr/portage
DISTDIR=${PORTDIR}/distfiles
PKGDIR=${PORTDIR}/packages
PORT_LOGDIR=/var/log/portage
PORTDIR_OVERLAY=/usr/local/portage
MAKEOPTS="-j2"
USE="nptl nptlonly unicode distcc ccache acpi apache2 apm avi bzlib crypt cups \
     dvd encode flash ftp gd ggi gif gmp iconv imagemagick imap \
     imlib jpeg ldap libg++ libwww maildir mbox memlimit mhash mmap \
     mmx mpeg mpi mysql ncurses nis nls pam pcre pdflib perl php \
     png posix postgres python qdbm readline recode samba sasl \
     session shared slp png sockets spell spl ssl svga sysvipc \
     symlink tiff truetype xml xml2 libclamav zlib kerberos \
     mysql xml acl cups ldap pam readline python oav -snmp -X aalib -afs"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT=180
PORTAGE_NICENESS=3
CCACHE_SIZE="2G"
AUTOCLEAN="yes"
FEATURES="ccache distlocks sandbox userpriv usersandbox"
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Sun Mar 19, 2006 11:03 pm    Post subject: Reply with quote

try
Code:
emerge -e --resume --skipfirst system

I think you should make some order in USE flags. IMO you don't need some and especially during emerge -e sytem.
tak a look at mine : (I've got modular xorg so some may seem starnge;))
Code:

emerge --info | grep USE
USE="x86 X aac alsa apm arts avi bitmap-fonts cairo cdr cli crypt ctype cups dba divx dri dvd dvdr dvdread eds emboss encode esd expat fastbuild foomaticdb force-cgi-redirect ftp gd gif glitz gnome gpm gstreamer gtk2 imlib ipv6 jpeg kde libg++ libwww mad memlimit mikmod motif mp3 mpeg ncurses nls nptl nptlonly nvidia ogg opengl oss pam pcre pdflib perl png posix python qt quicktime readline sdl session simplexml sndfile soap sockets spell spl ssl tcpd theora tokenizer truetype truetype-fonts type1-fonts udev unicode vorbis win32codecs xml xmms xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_pl userland_GNU video_cards_nvidia"
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Sun Mar 19, 2006 11:04 pm    Post subject: Reply with quote

zecora wrote:
I changed my make.conf file to this. I am doing a emerge --sync and then emerge -e system.

Code:
#/etc/make.conf
CHOST="i686-pc-linux-gnu"
#
CFLAGS="-march=athlon-xp"
#
CFLAGS="${CFLAGS} -pipe"
CFLAGS="${CFLAGS} -O2"
#CFLAGS="${CFLAGS} -fweb"
#CFLAGS="${CFLAGS} -frename-registers"
#CFLAGS="${CFLAGS} -fforce-addr"
CFLAGS="${CFLAGS} -fomit-frame-pointer"
#CFLAGS="${CFLAGS} -ftracer"
#
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
#
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
#
ACCEPT_KEYWORDS="x86"
PORTAGE_TMPDIR=/var/tmp
PORTDIR=/usr/portage
DISTDIR=${PORTDIR}/distfiles
PKGDIR=${PORTDIR}/packages
PORT_LOGDIR=/var/log/portage
PORTDIR_OVERLAY=/usr/local/portage
MAKEOPTS="-j2"
USE="nptl nptlonly unicode distcc ccache acpi apache2 apm avi bzlib crypt cups \
     dvd encode flash ftp gd ggi gif gmp iconv imagemagick imap \
     imlib jpeg ldap libg++ libwww maildir mbox memlimit mhash mmap \
     mmx mpeg mpi mysql ncurses nis nls pam pcre pdflib perl php \
     png posix postgres python qdbm readline recode samba sasl \
     session shared slp png sockets spell spl ssl svga sysvipc \
     symlink tiff truetype xml xml2 libclamav zlib kerberos \
     mysql xml acl cups ldap pam readline python oav -snmp -X aalib -afs"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT=180
PORTAGE_NICENESS=3
CCACHE_SIZE="2G"
AUTOCLEAN="yes"
FEATURES="ccache distlocks sandbox userpriv usersandbox"

What is this? CFLAGS looks awful :P
Back to top
View user's profile Send private message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Sun Mar 19, 2006 11:38 pm    Post subject: Reply with quote

What should I change it to?

Also for USE flags what are some main ones I should use? I am setting up a samba/apache/ftp and this is just a server, No window mgr.
Back to top
View user's profile Send private message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Mon Mar 20, 2006 2:12 am    Post subject: Reply with quote

Most of the files after required krb5 to be built.
Back to top
View user's profile Send private message
zecora
l33t
l33t


Joined: 17 Aug 2004
Posts: 627
Location: Minneapolis, MN

PostPosted: Mon Mar 20, 2006 10:48 pm    Post subject: Reply with quote

/bump


Getting this error msg on 3 other boxes I am installing.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7080
Location: Saint Amant, Acadiana

PostPosted: Mon Mar 20, 2006 11:57 pm    Post subject: Reply with quote

CFLAGS="-O2 -pipe -march=athlon-xp"

This is just enough (and safe).
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Tue Mar 21, 2006 2:28 am    Post subject: Reply with quote

Hi.

Have you seen this bug report?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Tue Mar 21, 2006 7:58 am    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads. Please see and follow up to topic 440535
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum