Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iBook video output (with datashow)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
flaviomoura
n00b
n00b


Joined: 11 Jul 2005
Posts: 56
Location: Brazil

PostPosted: Mon Mar 20, 2006 5:23 pm    Post subject: iBook video output (with datashow) Reply with quote

Hello,

I have an iBook G4 (new generation) and I want to use a data show. When I had macosx it was just a matter of plug and everything worked. But I removed macosx from my computer and I didn't managed to use the video output with gentoo. I tried several key combinations to check if the data show could capture the image but nothing happens... did anyone succeeded to use a datashow with gentoo in iBook G4?

Any tip is very much appreciated.

Best regards,


Flavio.
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Tue Mar 21, 2006 3:43 am    Post subject: Reply with quote

If you have an ATI card, check the Xorg section on this article. Maybe it can help you. So far I've been unsuccessful with a datashow. :(
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Tue Mar 21, 2006 1:27 pm    Post subject: Reply with quote

I have a G4 iBook 1.33Ghz with an ATI Radeon 9550. I used it for awhile in dual screen mode with an external TFT screen.
In the section for your graphics device, you need something like the following. "MergedFB" gives you a kind of xinerama desktop.
Code:
Section "Device"
   Identifier   "ATI Technologies, Inc. M11 NV [FireGL Mobility T2e]"
   Driver      "radeon"
   BusID      "PCI:0:16:0"
   Option "BackingStore" "true"  # Increases performance
   Option "RenderAccel" "true"  # Hardware acceleration
   Option      "AccelMethod"      "EXA"
        Option          "MergedFB"              "true"
        Option          "CRT2HSync"             "25-80"
        Option          "CRT2VRefresh"          "56-75"
        Option          "CRT2Position"          "RightOf"
        Option          "MergedNonRectangular"  "true"
        Option          "MetaModes"             "1024x768-1280x1024"
        Option          "LVDSProbePLL"          "true"
EndSection

And in the screen section, you need to add "Virtual" for the total size of the desktop:
Code:
SubSection "Display"
      Depth      24
      Modes      "1024x768"
      Virtual      "2304x1024"
   EndSubSection

I hope this gets you going.

Ruben
Back to top
View user's profile Send private message
flaviomoura
n00b
n00b


Joined: 11 Jul 2005
Posts: 56
Location: Brazil

PostPosted: Tue Mar 21, 2006 11:17 pm    Post subject: Reply with quote

I am trying these changes in xorg.conf but I didn't succeed yet... But what I found strange is that even if I reboot the machine with the datashow connected it detects something but show just a blank screen. Is it normal? I mean it doesn work in text mode as well.

Cheers.
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Wed Mar 22, 2006 6:09 pm    Post subject: Reply with quote

It's normal that you won't see any text output on that screen during bootup. Only when X is started, it should come alive. Maybe you need to change the CRT2HSync, CRT2VSync and lower the resolution. And maybe look in /var/log/Xorg.0.log what is happening.
Back to top
View user's profile Send private message
flaviomoura
n00b
n00b


Joined: 11 Jul 2005
Posts: 56
Location: Brazil

PostPosted: Fri May 05, 2006 3:32 pm    Post subject: Reply with quote

Now it is partially working because the mouse appears only in the laptop screen and not in the projection, and to do so I need to restart the machine with the projector cable connected. Well... it is not perfect but at least it is working :-) My xorg.conf is avaible at http://flavio.mat.unb.br/xorg.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum