Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
APMD will not emerge correctly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
hkphoey154
n00b
n00b


Joined: 20 Mar 2006
Posts: 7

PostPosted: Mon Mar 20, 2006 6:32 pm    Post subject: APMD will not emerge correctly Reply with quote

I am trying to emerge apmd, but get the following error when I try to do so:

Code:

executor linux # emerge apmd
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/apmd-3.2.1_p4 to /
>>> md5 files   ;-) apmd-3.2.2_p5.ebuild
>>> md5 files   ;-) apmd-3.2.1_p4.ebuild
>>> md5 files   ;-) apmd-3.0.2-r3.ebuild
>>> md5 files   ;-) apmd-3.2.0.ebuild
>>> md5 files   ;-) files/apmd.confd
>>> md5 files   ;-) files/apmd-3.2.0.kernel26x.patch
>>> md5 files   ;-) files/digest-apmd-3.0.2-r3
>>> md5 files   ;-) files/apmd.kernel26x.patch
>>> md5 files   ;-) files/apmd-no-on_ac_power_script.patch
>>> md5 files   ;-) files/apmsleep.c.diff
>>> md5 files   ;-) files/apmsleep.c.diff.3.2.0
>>> md5 files   ;-) files/digest-apmd-3.2.1_p4
>>> md5 files   ;-) files/apmd.rc6
>>> md5 files   ;-) files/digest-apmd-3.2.2_p5
>>> md5 files   ;-) files/digest-apmd-3.2.0
>>> md5 src_uri ;-) apmd_3.2.1.orig.tar.gz
>>> md5 src_uri ;-) apmd_3.2.1-4.diff.gz
>>> Unpacking source...
>>> Unpacking apmd_3.2.1.orig.tar.gz to /var/tmp/portage/apmd-3.2.1_p4/work
>>> Unpacking apmd_3.2.1-4.diff.gz to /var/tmp/portage/apmd-3.2.1_p4/work
 * Applying apmd_3.2.1-4.diff ...                                                                                                          [ ok ]>>> Source unpacked.
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apmlib.c
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apm.c
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apmd.c
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" -DNARROWPROTO xapm.c
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apmsleep.c
libtool --quiet --mode=link gcc -o libapm.la apmlib.lo -rpath /usr/lib -version-info 1:0
apmsleep.c:60: warning: 'rcsid' defined but not used
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../crti.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/crtbeginS.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/crtendS.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../crtn.o: No such file or directory
make: *** [libapm.la] Error 1
make: *** Waiting for unfinished jobs....
rm apm.o

!!! ERROR: sys-apps/apmd-3.2.1_p4 failed.
!!! Function src_compile, Line 50, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.


I think this has to do with the version of gcc that I have installed on my system. I have gcc 3.4.5, but the ebuild points to 3.4.4. How do I remedy this?

Thanks in advance!

-Mark
Back to top
View user's profile Send private message
sickboy2583
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2004
Posts: 83
Location: UK

PostPosted: Mon Mar 20, 2006 6:55 pm    Post subject: Reply with quote

Re-emerge libtool
Back to top
View user's profile Send private message
hkphoey154
n00b
n00b


Joined: 20 Mar 2006
Posts: 7

PostPosted: Mon Mar 20, 2006 7:07 pm    Post subject: Sweet! Reply with quote

Thanks! That worked wonders! :D
Back to top
View user's profile Send private message
kardolus
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2005
Posts: 120
Location: Amsterdam

PostPosted: Fri Mar 24, 2006 11:37 am    Post subject: Reply with quote

Thanks, worked for me too, had the same problem
_________________
Smokey, this is not 'Nam. This is bowling. There are rules.

http://twitter.com/GKardolus
Back to top
View user's profile Send private message
spaceboy770
n00b
n00b


Joined: 10 Jun 2004
Posts: 2
Location: Chicago

PostPosted: Sat Mar 25, 2006 3:33 pm    Post subject: Thanks! Reply with quote

Thanks sickboy. That helped me out, too!

:)
Back to top
View user's profile Send private message
cessman4life
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2005
Posts: 141

PostPosted: Sat Mar 25, 2006 4:03 pm    Post subject: Reply with quote

'emerge libtool' did not work for me. any other ideas?
Back to top
View user's profile Send private message
djcronos
n00b
n00b


Joined: 02 Oct 2004
Posts: 53
Location: San Jose, CA

PostPosted: Fri Mar 31, 2006 11:23 pm    Post subject: Reply with quote

I was emerging Gnome when I came across this error. doing an 'emerge libtool' fixed this error for me as well!
_________________
Linux Lover #370481
Get Counted!
Back to top
View user's profile Send private message
x11perf
n00b
n00b


Joined: 30 Jul 2005
Posts: 10

PostPosted: Sun Apr 02, 2006 3:35 am    Post subject: Reply with quote

sickboy2583 wrote:
Re-emerge libtool


Thanks, worked for me.
Back to top
View user's profile Send private message
lukas.svoboda
n00b
n00b


Joined: 15 Feb 2005
Posts: 33
Location: Prague, CZ

PostPosted: Fri Apr 07, 2006 6:40 am    Post subject: Reply with quote

OK, it fixed it for me too. Just curious, what's wrong with libtool so we need to remerge it?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 17, 2006 11:33 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of jpeg-6b-r4 fails to compile, fix_libtool_files.sh is no help.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum