Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOUND] speechd lets your Computer speak
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
wrs4
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 98
Location: Alexandria, VA

PostPosted: Mon Jun 23, 2003 6:13 pm    Post subject: Reply with quote

Thanks. I'll give it a try when I get the computer back from the repair shop. It was freezing just about every time I ran gcc :cry: and when I checked the CPU temp via the bios, it said "0 C" after running for a whole week, so I think I'm going to be RMA'ing some part(s) or other.
Back to top
View user's profile Send private message
dylix
Apprentice
Apprentice


Joined: 20 Sep 2002
Posts: 261
Location: Atlanta

PostPosted: Wed Jun 25, 2003 4:55 am    Post subject: Reply with quote

haha.. i added (below) to my local.start, haha

Code:
echo "System security activated to high. Please stand away from the computer" > /dev/speech


my g/f tripped out about it.
_________________

Rape is such a strong word, I prefer surprise sex.
http://plutonic.mine.nu/
Back to top
View user's profile Send private message
ElzWhere
n00b
n00b


Joined: 13 Oct 2002
Posts: 26
Location: Seattle

PostPosted: Wed Jun 25, 2003 7:03 am    Post subject: HaHa Reply with quote

Hell yeah this is tyte! I had it reading my dmesg when i first got it installed and she thought someone else was in the house and tripped out too.

When i first saw this topic i had to get this installed. I had trouble on the laptop...so i thought i'd try it out on the server, and sure nuff it worked perfectly. I had to get the female voice on it though.

the reason why i had trouble on the speech tools compile with festival on the laptop was due to the day before i emerged -uP on accident...it Pruned my whole system so festival couldnt compile because of the gcc version issue. It was a bitch to fix with all the patches found on the festival site but well worth it. Thanks for
the post Tobi.!
Quote:
There is no chance for the mentally dead but there is a chance for the physically dead....so thats my job! To resurrect the physically dead, by diggin up dem graves!
[/code]
Back to top
View user's profile Send private message
wrs4
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 98
Location: Alexandria, VA

PostPosted: Wed Jun 25, 2003 11:46 am    Post subject: Reply with quote

Hmm...now you have me thinking about the possibilities of speechd, some x10 motion detectors, and audio inputs from my computer (in the bedroom) to my receiver in the front room. A la

Quote:

Intruder detected, please step away from the merchandise. Detonation will commence in 10 seconds. 10, 9, 8, ...
Back to top
View user's profile Send private message
JM_
n00b
n00b


Joined: 09 Apr 2003
Posts: 13
Location: Bucharest

PostPosted: Wed Jun 25, 2003 4:27 pm    Post subject: Reply with quote

Hello. I'm trying to compile speechd, but festival 1.4.2-r3 fails. I also tried the 1.4.3 (latest) downloaded from the official website and it fails too. Has anyone got this to work with gcc 3.3 and glibc 2.3.2-r2? (actually I have glibc 2.3.2 with 20030616 branch update)
This is what I get:

Making in directory ./siod ...
making dependencies -- siodeditline.c el_complete.c editline.c el_sys_unix.c slib.cc slib_core.cc slib_doc.cc slib_file.cc slib_format.cc slib_list.cc slib_math.cc slib_sys.cc slib_server.cc slib_str.cc slib_xtr.cc slib_repl.cc siod_fringe.cc siod_server.cc io.cc trace.cc EST_SiodServer.cc siod.cc siod_est.cc
gcc -c -fno-implicit-templates -O3 -Wall -Wno-non-template-friend -DSUPPORT_EDITLINE -I../include slib.cc
In file included from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3/include/g++-v3/backward/iostream.h:31,
from ../include/EST_iostream.h:53,
from ../include/EST_String.h:50,
from ../include/siod.h:17,
from slib.cc:88:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3/include/g++-v3/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To disable this warning use -Wno-deprecated.
In file included from ../include/EST_String.h:50,
from ../include/siod.h:17,
from slib.cc:88:
../include/EST_iostream.h:54:26: strstream.h: No such file or directory
In file included from ../include/EST_TList.h:50,
from ../include/EST_string_aux.h:43,
from ../include/siod.h:18,
from slib.cc:88:
../include/EST_TIterator.h:206: warning: `EST_TStructIterator<Container,
IPointer, Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:206: warning: implicit typename is deprecated,
please see the documentation for details
../include/EST_TIterator.h:206: warning: `EST_TStructIterator<Container,
IPointer, Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:206: warning: implicit typename is deprecated,
please see the documentation for details
../include/EST_TIterator.h:233: warning: `EST_TRwIterator<Container, IPointer,
Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:233: warning: implicit typename is deprecated,
please see the documentation for details
../include/EST_TIterator.h:233: warning: `EST_TRwIterator<Container, IPointer,
Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:233: warning: implicit typename is deprecated,
please see the documentation for details
../include/EST_TIterator.h:280: warning: `EST_TRwStructIterator<Container,
IPointer, Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:280: warning: implicit typename is deprecated,
please see the documentation for details
../include/EST_TIterator.h:280: warning: `EST_TRwStructIterator<Container,
IPointer, Entry>::Iter' is implicitly a typename
../include/EST_TIterator.h:280: warning: implicit typename is deprecated,
please see the documentation for details
make[1]: *** [slib.o] Error 1
make: *** [siod] Error 2

!!! ERROR: media-sound/festival-1.4.2-r3 failed.
!!! Function src_compile, Line 69, Exitcode 2
!!! (no error message)
_________________
Powered by 220V AC
Back to top
View user's profile Send private message
JM_
n00b
n00b


Joined: 09 Apr 2003
Posts: 13
Location: Bucharest

PostPosted: Wed Jun 25, 2003 5:35 pm    Post subject: Reply with quote

Ok... sorry, my mistake. I forgot to check bugs.gentoo.org. :oops:
_________________
Powered by 220V AC
Back to top
View user's profile Send private message
Schwin97
n00b
n00b


Joined: 25 Oct 2002
Posts: 65
Location: Frisco, TX

PostPosted: Wed Jun 25, 2003 5:56 pm    Post subject: Reply with quote

Not sure about this but...

Since this is just a device... with permissions, couldn't you have your server ssh into your workstation (or any computer with this installed) to notify you of problems, intrusions, etc? Just for those who may have the server in a different room/building...

Just a thought

Schwin97
Back to top
View user's profile Send private message
schlehmil
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2003
Posts: 110
Location: Berlin, Germany

PostPosted: Sun Jun 29, 2003 7:50 am    Post subject: Reply with quote

Hello,

at first I would like to say thank you for that fine tutorial.
but there is one problem with using the mbrola voise set by default.
I've created .festivalrc with following content:

Quote:

(set! voice default 'voice_us1_mbrola)


But everytime I restart the computer and init-Script "speechd" (found in this thread" is load the default male voice is loaded. When I restart the init-Script by "/etc/init.d/speechd restart" everything is working fine.
Does anybody has the same problem?[/quote]
Back to top
View user's profile Send private message
smouge
n00b
n00b


Joined: 22 Jan 2003
Posts: 66
Location: Oosterhout, the Netherlands

PostPosted: Sun Jun 29, 2003 9:55 pm    Post subject: Reply with quote

Great post,

I have just changed the local.start and local.stop a little. The meaning is to do an extra check if speechd is running besides the existence of /dev/speech.

The first time I tried to use these scripts my computer hang because I had not added speechd to the start-up scripts. With this extra check this will be prevented if for some reason speechd had not been started, or stopped before shutting down the system.

/etc/conf.d/local.start

Code:
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/local.start,v 1.2 2002/05/12 21:48:18 azarah Exp $

# This is a good place to load any misc.
# programs on startup ( 1>&2 )


if [ -e "/dev/speech" ] ; then
   pid=`ps ax | grep "/usr/bin/perl -w /usr/bin/speechd" | grep -v grep | awk '{print $1;}'`
   if [ "X${pid}" != "X" ] ; then
      date="$(date +%H)"
      if [ "$date" -ge "6" -a "$date" -le "12" ] ; then
         say "Good morning"
      else
         if [ "$date" -gt "12" -a "$date" -le "18" ] ; then
            say "Good afternoon"
         else
            if [ "$date" -gt "18" -a "$date" -le "24" ] ; then
               say "Good evening"
            else
               if [ "$date" -gt "0" -a "$date" -lt "6" ] ; then
                  say "Good night or is it morning already"
               fi
            fi
         fi
      fi
      sleep 1
      say "Gentoo system $HOSTNAME is ready" && sleep 4 && saytime
   else
      echo 'Error .. speechd not loaded'
   fi
else
      echo 'Error .. speechd not loaded'
fi


/etc/conf.d/local.stop

Code:

# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/local.stop,v 1.2 2002/05/12 21:48:18 azarah Exp $

# This is a good place to unload any misc.
# programs you started above.
# For example, if you are using OSS and have
# "/usr/local/bin/soundon" above, put
# "/usr/local/bin/soundoff" here.

RUNLV=`runlevel | cut -d ' ' -f 2`
if [ -e "/dev/speech" ] ; then
   pid=`ps ax | grep "/usr/bin/perl -w /usr/bin/speechd" | grep -v grep | awk '{print $1;}'`
   if [ "X${pid}" != "X" ] ; then
      if [ "$RUNLV" == "0" ] ; then
         say "$HOSTNAME is shutting down" && sleep 3
      elif [ "$RUNLV" == "6" ] ; then
         say "$HOSTNAME is rebooting now" && sleep 3
      else
         echo "Found invalid runlevel"
      fi
   else
      echo 'Error .. speechd not loaded'
   fi
else
   echo 'Error .. speechd not loaded'
fi
Back to top
View user's profile Send private message
ErnieS
n00b
n00b


Joined: 14 Jan 2003
Posts: 49
Location: South FL

PostPosted: Tue Jul 08, 2003 2:00 am    Post subject: festival --server bind failed Reply with quote

Has anyone found the fix for this?
Code:
# /etc/init.d/speechd stop
 * Stopping speechd...                                                    [ ok ]
# festival --server
socket: bind failed

_________________
Regards, Ernie
100% Microsoft and Intel free
Back to top
View user's profile Send private message
MaGuS
Guru
Guru


Joined: 13 Jun 2002
Posts: 303
Location: Luebeck, Germany

PostPosted: Tue Jul 08, 2003 2:26 pm    Post subject: Re: This is cool, Reply with quote

It's relay cool, but it would be nice to get the german languages out of my pc. 8)

Anyone knows a solution?

nephros wrote:
thanks, that thing is way cool.

God, this reminds me of old Amiga times!

Now, anyone know how to set up other languages.

I downloaded the German deX packages, and unzipped them to /usr/lib/mbrola/voices/german/de{1..5},
edited voices.scm to include "de1" on top of the list
Code:

(defvar default-voice-priority-list
  '(de1
    en1_mbrola
    ...


and edited festivalrc to:
(set! voice_default 'voice_de1)

but that does not work...
Back to top
View user's profile Send private message
Chris Finch
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2003
Posts: 106
Location: Darmstadt, Germany

PostPosted: Wed Jul 09, 2003 12:22 pm    Post subject: Reply with quote

Sharing my experience:

I've had some troubles with the init scripts posted in this thread (btw. mind that in one of them two closing brackets are missing, in case you stumbled over that). So what I did was plainly adding
Code:
speechd
echo "Welcome to gentoo linux." >/dev/speech
echo "Today is $(date +"%A, %B %-d. The time is %-M minutes after %-I")." >/dev/speech
to /etc/conf.d/local.start and
Code:
if [ -e "/dev/speech" ] ; then
   pid=`ps ax | grep "/usr/bin/perl -w /usr/bin/speechd" | grep -v grep | awk '{print $1;}'`
   if [ "X${pid}" != "X" ] ; then
        echo "Shutting dow the computer at $(date +"%-M minutes after %-I.")" >/dev/speech && sleep 6
   fi
fi
to local.stop. The checking (taken from one of the foregoing posts) is advisable in order to avoid a hang on shutdown in case that speechd was killed for some reason. I don't kill the demons, they're going to get killed, anyway. Is there any disadvantage of doing things in this way?

Two hints: If you have a problem with speechd but none with festival, have a look at http://www.speechio.org. There is a faq entry that helped me. The reason for my problems was that I had /etc/hosts set up wrong. On the same site you find a little perl script called "speechbiff" that you can call from procmail and that reads sender and subject of new mail on arrival to you. Was very easy to set up and is a fancy gadget to have.
Back to top
View user's profile Send private message
akiross
Veteran
Veteran


Joined: 02 Mar 2003
Posts: 1170
Location: Mostly on google.

PostPosted: Sun Jul 13, 2003 12:42 pm    Post subject: Reply with quote

Hey, It's wonderfoul! :lol:
but, i dont like the voice... is there a way to have a voice like a robot?
a mechanized voice a mean...

thnx very much :)

bye
_________________
Libera scienza in libero stato.
Horizon of Events
Back to top
View user's profile Send private message
nalin
Apprentice
Apprentice


Joined: 27 Sep 2002
Posts: 172
Location: Long Beach

PostPosted: Sat Jul 26, 2003 12:10 am    Post subject: Reply with quote

Just a question here, and probably one that is not directly due to speechd, but...

I have a desktop where speechd works fine, I have never noticed a long lag whatsoever, i echo, it talks

I just set this up on my notebook, and sometimes (~50% of the time) it seems to buffer output, so that I echo and speech occurs anywhere from immediately to say a minute down the road. If it occurs a minute down the road and I have echoed multiple things, it says them all at once (in sequence, not concurrently). If I do something else that causes sound it plays as normal and does not suffer this buffering effect, so I dont believe it is a module unloading or arts shutting down, etc.

My question here is whether anyone else has noticed this, and is there something I can do to avoid this lag.

The desktop is using oss drivers for a sblive card, the laptops alsa drivers for an intel ac97 codec card.
Back to top
View user's profile Send private message
niltonvolpato
n00b
n00b


Joined: 28 May 2003
Posts: 68
Location: Campinas, Brazil

PostPosted: Sat Jul 26, 2003 3:20 am    Post subject: Same problem Reply with quote

nalin wrote:

I have a desktop where speechd works fine, I have never noticed a long lag whatsoever, i echo, it talks


I have the same problem. It happen also with xmms, or mpg123. There is a BIG delay till the real sound plays. I almost trying to suicide. :wink:

If someone had the same problem or know how to solve it, please help!

Thanks,
-- Nilton
Back to top
View user's profile Send private message
Oxidative
n00b
n00b


Joined: 25 Jun 2003
Posts: 33

PostPosted: Sat Jul 26, 2003 12:25 pm    Post subject: Reply with quote

I have had the same problem. I fixed it by replacing my /usr/bin/say script with

Code:
echo $1 | festival --tts


Now when you use the say script, it's much faster!

Good luck
Back to top
View user's profile Send private message
nalin
Apprentice
Apprentice


Joined: 27 Sep 2002
Posts: 172
Location: Long Beach

PostPosted: Sat Jul 26, 2003 6:58 pm    Post subject: Reply with quote

nalin wrote:
Just a question here, and probably one that is not directly due to speechd, but...

I have a desktop where speechd works fine, I have never noticed a long lag whatsoever, i echo, it talks

I just set this up on my notebook, and sometimes (~50% of the time) it seems to buffer output, so that I echo and speech occurs anywhere from immediately to say a minute down the road. If it occurs a minute down the road and I have echoed multiple things, it says them all at once (in sequence, not concurrently). If I do something else that causes sound it plays as normal and does not suffer this buffering effect, so I dont believe it is a module unloading or arts shutting down, etc.

My question here is whether anyone else has noticed this, and is there something I can do to avoid this lag.

The desktop is using oss drivers for a sblive card, the laptops alsa drivers for an intel ac97 codec card.


I figured out my problem:
My soundblaster desktop system has hardware sound mixing, arts takes up a single channel, and the other channels remain open for things such as /dev/speech without explicitly piping them through artsdsp
My ac97 laptop lacks hardware mixing and thus has a single sound channel which arts monopolizes for 60 seconds after any sound has played. [when kde or gnome or any wm that has a program such as esd, artsd, etc which handles sound output and is running] /dev/speech explicitly waits for the channel to become available, in my case it takes 60 sec for arts to timeout and unload...hence the delay

I *could* fix this to some extent by changing my settings so that arts unloads after say 5 seconds, that way, as long as I am not doing anything which explicitly hogs the channel such as listening to mp3's, the speech will be delayed minimally.

I would be more interested in piping the /dev/speech output through artsdsp, but cannot seem to get this to work properly (I bought the soundblaster in my desktop soley to avoid piping through artsdsp and associated software mixing problems, and the ease of use and avioded hassle was worth every penny). Speechd has a esd command line option as well as a compilation flag, but nothing yets exists for arts, and im not sure it would work without significant modification (it is implemented by calling "esdsp festival --server" rather then "festival --server", I have tried killing all festival and speechd stuff and runing "artsdsp festival --server," and then "echo text | festival -tts", but it does not pipe through arts, it still waits for /dev/dsp to becomee available.

Anyone with a workaround or suggestions would be appreciated.

p.s. Just a thought but is ln -s /usr/kde/3.1/bin/artsdsp /usr/bin/esdplay a viable option for creating a fake esd interface (and vice versa if your using gnome) when programs support exactly one of the sound systems?

EDIT
echo 'Hello from Festival'| artsdsp festival --tts
it works...working on making it pipe through /dev/speech
END EDIT
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Mon Jul 28, 2003 3:08 am    Post subject: Re: festival and speech-tools update in bugzilla Reply with quote

Gio wrote:
In bugzilla #22053 I updated festival and speech-tools to compile on gcc-3.2.3. Also did some seperation and clean up - comments welcome.

** update ** compiles on gcc 3.3 too.

8O wish you were a girl :D :D :D :D
THANK YOU

peace
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1317
Location: UK

PostPosted: Mon Jul 28, 2003 5:51 am    Post subject: Reply with quote

BradB wrote:
OK, now for an interesting use of /dev/speech - where abouts would be fun places to symlink it to?
ie ln -s /dev/null with /dev/speech - (urg I'd think)
or could you hook it up so that kernel logs got spoken out?

Probably annoying, but maybe fun :)

Brad


i tryed "echo /var/log/syslog > /dev/speech"

when i hit CTRL-C it didn't stop, it's still going.

I HATE YOU, it's 6:54am now.....the log is up to reading out 1:23am logs.....
i'm going to surf aroud top to find it and kill it.
Back to top
View user's profile Send private message
panserg
Apprentice
Apprentice


Joined: 16 Apr 2003
Posts: 188

PostPosted: Mon Jul 28, 2003 4:49 pm    Post subject: Reply with quote

Does anyone know any good place to download some new voices? I, personally, would like to find the voice of "John Frink", the comuter geek from Simpsons.
Back to top
View user's profile Send private message
glamdringlfo
n00b
n00b


Joined: 30 Jul 2003
Posts: 15
Location: Grand Rapids, MI

PostPosted: Fri Aug 01, 2003 8:14 pm    Post subject: Reply with quote

Hey, that's awesome.

I wrote up some short scripts so that when gkrellm notices my cpu temp passes a certain threshhold, the computer warns the user with audible alerts. I set the threshold low to test it, and it freaked my roommate out.

Thanks for explaining how it works. The different voices bit, too.

Stay cool.

Skal!
Glamdringlfo
Back to top
View user's profile Send private message
iplayfast
l33t
l33t


Joined: 08 Jul 2002
Posts: 642
Location: Cambridge On,CA

PostPosted: Mon Aug 04, 2003 7:24 am    Post subject: this all works good but... Reply with quote

Is there some way to make festival go to it's own audio channel? The offical way of making it louder doesn't work, and it's a mutter against my music.
Back to top
View user's profile Send private message
herring
Apprentice
Apprentice


Joined: 22 Jul 2002
Posts: 187
Location: Norway

PostPosted: Tue Aug 05, 2003 12:37 am    Post subject: Reply with quote

carrett wrote:
hey, this is awesome. when i do: echo "Hello world" > /dev/speech
the system just sits there, no sound comes out and i have to ctl-C to stop the command. however, echo "Hello world" | festival --tts -
works perfectly, anybody know how to make the device work?


Hi !
Had this problem myself.
Examining /var/log/speechd (EDIT: and festival --server), I found festival was rejecting my localhost client. Reason was, localhost was not named localhost, but gentoo :-)

However, making a /root/.festivalrc
containing

Code:
(set! server_access_list '("gentoo"))


festival happily accepted my localhostclient, and finally piping to /dev/speech worked as expected

EDIT: This was probably a /etc/hosts issue (see Chris Finch post above)
http://www.speechio.org/speechio.faq.html
Back to top
View user's profile Send private message
error26
n00b
n00b


Joined: 22 Feb 2003
Posts: 65
Location: Vienna

PostPosted: Mon Aug 11, 2003 4:45 pm    Post subject: on KDE it queqes Reply with quote

Hm, when i write to /dev/speech on a kde terminal it qeuques until i logg out, but w/ fluxbox it works.
Do you have any idea why this could be?
Back to top
View user's profile Send private message
gmoney
n00b
n00b


Joined: 04 Aug 2003
Posts: 20
Location: Santa Barbara

PostPosted: Thu Aug 21, 2003 7:12 pm    Post subject: Security? Reply with quote

Anyone know how to get festival to bind just to localhost (127.0.0.1) instead of *? I would like to use it but leaving ait running as root and waiting for connections from the whole internet isn't an option. Firewalling off ports doesn't give me the warm fuzzy feeling that forcing it to bind to localhost would......
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 4 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum