Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! This is a bug, please report it. (virtual/libintl-0)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Athernigy
n00b
n00b


Joined: 30 Mar 2005
Posts: 25

PostPosted: Tue Mar 21, 2006 11:32 pm    Post subject: !!! This is a bug, please report it. (virtual/libintl-0) Reply with quote

getting this during emerge --sync


>>> Updating Portage cache: 88%!!! Cannot resolve a virtual package name to an ebuild.
!!! This is a bug, please report it. (virtual/libintl-0)
Back to top
View user's profile Send private message
DieselPower
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 216
Location: TN

PostPosted: Tue Mar 21, 2006 11:46 pm    Post subject: Reply with quote

This is not a bug! Your portage is out of date

Code:

emerge -u portage


Should fix it
Back to top
View user's profile Send private message
fats-t
n00b
n00b


Joined: 30 Mar 2006
Posts: 2

PostPosted: Thu Mar 30, 2006 5:27 am    Post subject: Still no luck Reply with quote

I am having the same problem. portage was fine up until I tried emerge -sync the other night. I tried "emerge -u portage" but it gives me a new error message

bash-2.05b# emerge -u portage
!!! ARCH is not set... Are you missing the /etc/make.profile symlink?
!!! Is the symlink correct? Is your portage tree complete?


I'm pretty sure that my portage tree is now incomplete because of the previous error. how can I update portage and fix this problem?
Back to top
View user's profile Send private message
PMcCauley
Apprentice
Apprentice


Joined: 14 Mar 2006
Posts: 283
Location: Alberta, Canada

PostPosted: Thu Mar 30, 2006 5:30 am    Post subject: Reply with quote

fats-t. Try extracting the snapshot again and then update. Here's the link.

http://distfiles.gentoo.org/releases/snapshots/2006.0/


Patrick

Edit also verify /etc/make.profile
Code:
ls -l /etc/make.profile
Back to top
View user's profile Send private message
fats-t
n00b
n00b


Joined: 30 Mar 2006
Posts: 2

PostPosted: Thu Mar 30, 2006 6:30 am    Post subject: still no luck Reply with quote

I tried downloading the portage snapshot and then updating portage with no luck. this is the message i received:

bash-2.05b# emerge portage


Performing Global Updates: /usr/portage/profiles/updates/1Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
.........
!!! ARCH is not set... Are you missing the /etc/make.profile symlink?
!!! Is the symlink correct? Is your portage tree complete?


this is after i put the new snapshot in /usr


here is whats in /etc/make.profile. I don't see anything wrong with it. but i might have overlooked something.

lrwxrwxrwx 1 root root 48 Mar 17 2005 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2004.3

anymore ideas?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Mar 30, 2006 8:00 am    Post subject: Reply with quote

Please follow up to Emerge Bug (SOLVED).

Moved from Portage & Programming to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum