Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
alsa-driver compilation errors - what to do ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
vm
n00b
n00b


Joined: 19 Mar 2006
Posts: 50

PostPosted: Thu Mar 23, 2006 11:09 pm    Post subject: alsa-driver compilation errors - what to do ? Reply with quote

Code:
 * Updating module dependencies for 2.6.15-gentoo-r5 ...
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/ppc/snd-powermac.ko needs unknown symbol local_irq_save
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/ppc/snd-powermac.ko needs unknown symbol local_irq_disable
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/ppc/snd-powermac.ko needs unknown symbol local_irq_restore
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/ppc/snd-powermac.ko needs unknown symbol local_irq_enable
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/seq/snd-seq.ko needs unknown symbol local_irq_save
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/seq/snd-seq.ko needs unknown symbol local_irq_disable
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/seq/snd-seq.ko needs unknown symbol local_irq_restore
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/seq/snd-seq.ko needs unknown symbol local_irq_enable
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/snd.ko needs unknown symbol local_irq_save
WARNING: //lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/snd.ko needs unknown symbol local_irq_disable



and
Code:
ibook ~ # /etc/init.d/alsasound start
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...
WARNING: Error inserting snd (/lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/sn
d.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.15-gentoo-r5/alsa-driver/ac
ore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.15-gentoo-r5/alsa-driver/acor
e/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_powermac (/lib/modules/2.6.15-gentoo-r5/alsa-driver/p
pc/snd-powermac.ko): Unknown symbol in module, or unknown parameter (see  [ !! ]
 *   Loading: snd-seq ...
WARNING: Error inserting snd (/lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/sn
d.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_seq_device (/lib/modules/2.6.15-gentoo-r5/alsa-driv
er/acore/seq/snd-seq-device.ko): Unknown symbol in module, or unknown parameter
(see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.15-gentoo-r5/alsa-driver/ac
ore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_seq (/lib/modules/2.6.15-gentoo-r5/alsa-driver/acore/
seq/snd-seq.ko): Unknown symbol in module, or unknown parameter (see dme  [ !! ]
 * ERROR: Failed to load necessary drivers


after i was upset with my recording quality from the microphone with the help of ALSA provided with kernel, I'v decided to build alsa-driver, and it does not works at all.

what to DO ?
Back to top
View user's profile Send private message
vm
n00b
n00b


Joined: 19 Mar 2006
Posts: 50

PostPosted: Thu Mar 23, 2006 11:25 pm    Post subject: Reply with quote

according this https://forums.gentoo.org/viewtopic-t-427327-highlight-alsadriver.html it seemes to be impossible to solve it with current linux kernel,
or maybe Im wrong ?
Back to top
View user's profile Send private message
vm
n00b
n00b


Joined: 19 Mar 2006
Posts: 50

PostPosted: Fri Mar 24, 2006 12:51 am    Post subject: Reply with quote

ok, no matter,
I have recompiled builded-in-kernel ALSA,
all works, but internal microphone recording quality is VERY BAD -- too noisy
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Mar 24, 2006 4:55 pm    Post subject: Reply with quote

This sounds like a bug with the ALSA driver. If you could, I would recommend filing a bug upstream in the ALSA bugzilla so they're aware of the problem.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum