Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] MODULAR X xorg-x11-7.0-r1 and KDE 3.5.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
NEW
n00b
n00b


Joined: 25 Jan 2005
Posts: 74
Location: Czech Republic, Prague

PostPosted: Tue Mar 28, 2006 6:04 pm    Post subject: [SOLVED] MODULAR X xorg-x11-7.0-r1 and KDE 3.5.2 Reply with quote

I'am using KDE 3.5.1 and xorx-x11-7.0, and I would like to update tu KDE 3.5.2 but there is problem, It seams that KDE 3.5.2 are depended on xorx-x11-6.8.2.

I think that by
Quote:
NEW packages # emerge --nodeps -av kdebase

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] kde-base/kdebase-3.5.2 [3.5.1-r3] USE="arts cups hal ieee1394 java lm_sensors opengl pam ssl -debug -kdeenablefinal -ldap -logitech-mouse -openexr -samba* -xcomposite -xinerama -xscreensaver -zeroconf" 23,037 kB

Total size of downloads: 23,037 kB



but is this safe ? Does anyone try it ?

Quote:
NEW packages # eix xorg-x11
* x11-base/xorg-x11
Available versions: 6.8.2-r4 6.8.2-r6 [M]6.9.0 7.0-r1
Installed: 7.0-r1
Homepage: http://xorg.freedesktop.org
Description: An X11 implementation maintained by the X.Org Foundation (meta package)


Found 1 matches


Quote:
NEW packages # eix kdebase
* kde-base/kdebase
Available versions: 3.3.2-r1 3.3.2-r2 3.3.2-r3 3.4.1-r1 3.4.2 3.4.2-r1 3.4.2-r2 3.4.3 3.4.3-r1 3.5.0-r1 3.5.1 3.5.1-r1 3.5.1-r2 3.5.1-r3 3.5.2
Installed: 3.5.1-r3
Homepage: http://www.kde.org/
Description: KDE base packages: the desktop, panel, window manager, konqueror...



Quote:

NEW packages # emerge -av kdebase

These are the packages that would be merged, in order:

Calculating dependencies... done!
[blocks B ] x11-libs/libXft (is blocking x11-base/xorg-x11-6.8.2-r6)
[ebuild U ] kde-base/arts-3.5.2 [3.5.1] USE="alsa arts mp3 vorbis -artswrappersuid -debug -esd jack -kdeenablefinal -nas -xinerama" 0 kB
[ebuild U ] kde-base/kdelibs-3.5.2 [3.5.1-r1] USE="alsa arts cups jpeg2k spell ssl -acl -debug doc -kdeenablefinal -kerberos -openexr -tiff* -xinerama -zeroconf" 0 kB
[ebuild UD] x11-base/xorg-x11-6.8.2-r6 [7.0-r1] USE="3dnow% bitmap-fonts% mmx% nls% opengl% pam sse% truetype-fonts% type1-fonts% xv% -3dfx -cjk% -debug% -dlloader% -dmx% -doc% -font-server% -in ecure-drivers% -ipv6% -minimal% -nocxx% -sdk% -static% -xprint%" 1,803 kB
[ebuild N ] virtual/x11-6.8 0 kB
[ebuild U ] kde-base/kdebase-3.5.2 [3.5.1-r3] USE="arts cups hal ieee1394 java lm_sensors openg pam ssl -debug -kdeenablefinal -ldap -logitech-mouse -openexr -samba* -xcomposite -xinerama -xscre nsaver -zeroconf" 23,037 kB

Total size of downloads: 24,841 kB

!!! Error: The above package list contains packages which cannot be installed
!!! at the same time on the same system.



Last edited by NEW on Tue Mar 28, 2006 7:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Tue Mar 28, 2006 6:59 pm    Post subject: Reply with quote

Add « virtual/x11-6.8 » to package.provided file.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Ferdinando
Veteran
Veteran


Joined: 25 Nov 2003
Posts: 1027
Location: Gaeta (LT) - Italy

PostPosted: Tue Mar 28, 2006 7:04 pm    Post subject: Reply with quote

Looking at the ebuild it seems it only depends on virtual/x11, it does not specify a version: what do you get if you run 'emerge -pv =virtual/x11-7.0'?

Bye
_________________
La risposta, non la devi cercare fuori, la devi cercare dentro di te: e però è SBAGLIATA!
-- Corrado Guzzanti, "Pippo Chennedy Show", 1997
Back to top
View user's profile Send private message
NEW
n00b
n00b


Joined: 25 Jan 2005
Posts: 74
Location: Czech Republic, Prague

PostPosted: Tue Mar 28, 2006 7:52 pm    Post subject: Reply with quote

Ferdinando wrote:
Looking at the ebuild it seems it only depends on virtual/x11, it does not specify a version: what do you get if you run 'emerge -pv =virtual/x11-7.0'?

Bye


well there are a lot of dependencies but meantime i had tried to do this

Quote:
Add the following to /etc/portage/package.mask:
File: /etc/portage/package.mask

<=virtual/x11-6.8

This will force many of the dependency checks to want modular Xorg libraries to be installed instead of immediately wanting to install virtual/x11-6.8 when one of the modular Xorg dependencies is missing. Most packages have been ported to modular dependencies at this point, so this should be sufficient.
Note: People, please do some research and look at the ebuilds and read about portage resolver. The above won't fix nor work around anything, at best it can help to discover the real ebuild that has not been ported yet.


http://gentoo-wiki.com/HOWTO_Modular_Xorg

and it seems to work

also a have to edit /etc/portage/package.keywords

Quote:

x11-apps/xmessage ~x86
x11-apps/xsetroot ~x86
x11-misc/imake ~x86
x11-misc/xorg-cf-files ~x86
x11-drivers/xf86-video-imstt ~x86
x11-drivers/xf86-video-nsc ~x86
x11-drivers/xf86-video-s3virge ~x86
x11-drivers/xf86-video-i128 ~x86
x11-drivers/xf86-video-vmware ~x86
x11-drivers/xf86-video-trident ~x86
x11-drivers/xf86-video-neomagic ~x86
x11-drivers/xf86-video-cirrus ~x86
x11-drivers/xf86-video-sisusb ~x86
x11-drivers/xf86-video-tga ~x86
x11-drivers/xf86-video-s3 ~x86
x11-drivers/xf86-video-glint ~x86
x11-drivers/xf86-video-fbdev ~x86
x11-drivers/xf86-video-i740 ~x86
x11-drivers/xf86-video-tdfx ~x86
x11-drivers/xf86-video-dummy ~x86
x11-drivers/xf86-video-voodoo ~x86
x11-drivers/xf86-video-savage ~x86
x11-drivers/xf86-video-siliconmotion ~x86
x11-drivers/xf86-video-ark ~x86
x11-drivers/xf86-video-chips ~x86
x11-drivers/xf86-video-ati ~x86
x11-drivers/xf86-video-mga ~x86
x11-drivers/xf86-video-v4l ~x86
x11-drivers/xf86-video-sis ~x86
x11-drivers/xf86-video-tseng ~x86
x11-drivers/xf86-video-vga ~x86
x11-drivers/xf86-video-cyrix ~x86
x11-drivers/xf86-video-apm ~x86
x11-drivers/xf86-video-rendition ~x86
x11-drivers/xf86-video-i810 ~x86
x11-libs/libXvMC ~x86
x11-drivers/xf86-video-via ~x86


But thanks for advice
Back to top
View user's profile Send private message
NEW
n00b
n00b


Joined: 25 Jan 2005
Posts: 74
Location: Czech Republic, Prague

PostPosted: Tue Mar 28, 2006 7:57 pm    Post subject: Reply with quote

Quote:
NEW ~ # update

These are the packages that would be merged, in order:

Calculating world dependencies |
... done!
[ebuild U ] kde-base/arts-3.5.2 [3.5.1] USE="alsa arts mp3 vorbis -artswrappersuid -debug -esd -jack -kdeenablefinal -nas -xinerama" 0 kB
[ebuild U ] kde-base/kdelibs-3.5.2 [3.5.1-r1] USE="alsa arts cups jpeg2k spell ssl -acl -debug -doc -kdeenablefinal -kerberos -openexr -tiff* -xinerama -zeroconf" 0 kB
[ebuild N ] x11-apps/xmessage-1.0.1 USE="-debug -xprint" 81 kB
[ebuild N ] x11-apps/xsetroot-1.0.1 USE="-debug" 75 kB
[ebuild U ] kde-base/kdebase-3.5.2 [3.5.1-r3] USE="arts cups hal ieee1394 java lm_sensors opengl pam ssl -debug -kdeenablefinal -ldap -logitech-mouse -openexr -samba* -xcomposite -xinerama -xscreensaver -zeroconf" 23,037 kB
[ebuild U ] kde-base/kdegraphics-3.5.2 [3.5.1-r2] USE="arts gphoto2 imlib opengl -debug -kdeenablefinal -openexr -pdf -povray -scanner -tetex -xinerama" 7,123 kB
[ebuild U ] media-libs/libdvdread-0.9.5 [0.9.4-r1] USE="-static" 372 kB
[ebuild U ] kde-base/kde-i18n-3.5.2 [3.5.1] USE="arts -debug -kdeenablefinal -xinerama" LINGUAS="cs% -af% -ar% -az% -bg% -bn% -br% -bs% -ca% -cy% -da% -de% -el% -en_GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -fy% -ga% -gl% -he% -hi% -hr% -hu% -is% -it% -ja% -km% -ko% -lt% -lv% -mk% -mn% -ms% -nb% -nds% -nl% -nn% -pa% -pl% -pt% -pt_BR% -ro% -ru% -rw% -se% -sk% -sl% -sr% -sr@Latn% -ss% -sv% -ta% -tg% -tr% -uk% -uz% -zh_CN% -zh_TW%" 3,282 kB
[ebuild U ] kde-base/kdemultimedia-3.5.2 [3.5.1] USE="alsa arts encode flac gstreamer mp3 theora vorbis xine -audiofile* -debug -kdeenablefinal -musicbrainz -xinerama" 6,125 kB
[ebuild U ] kde-base/kdepim-3.5.2 [3.5.1] USE="arts crypt -debug -gnokii -kdeenablefinal -pda -xinerama" 12,585 kB
[ebuild U ] kde-base/kdenetwork-3.5.2 [3.5.1-r1] USE="arts rdesktop slp ssl xmms -debug -kdeenablefinal -sametime -wifi -xinerama" 7,347 kB
[ebuild U ] kde-base/kdeedu-3.5.2 [3.5.1] USE="arts -debug -kdeenablefinal -kig-scripting -xinerama" 29,169 kB
[ebuild N ] x11-drivers/xf86-video-imstt-1.0.0.5 USE="-debug" 217 kB
[ebuild N ] x11-drivers/xf86-video-nsc-2.7.6.5 USE="-debug" 474 kB
[ebuild N ] x11-drivers/xf86-video-s3virge-1.8.6.5 USE="-debug" 266 kB
[ebuild N ] x11-drivers/xf86-video-i128-1.1.0.5 USE="-debug" 247 kB
[ebuild N ] x11-drivers/xf86-video-vmware-10.12.0.0 USE="-debug" 233 kB
[ebuild N ] x11-drivers/xf86-video-trident-1.0.1.3 USE="-debug" 273 kB
[ebuild N ] x11-drivers/xf86-video-neomagic-1.0.0.5 USE="-debug" 249 kB
[ebuild N ] x11-drivers/xf86-video-cirrus-1.0.0.5 USE="-debug" 248 kB
[ebuild N ] x11-drivers/xf86-video-sisusb-0.7.1.3 USE="-debug" 275 kB
[ebuild N ] x11-drivers/xf86-video-tga-1.0.0.5 USE="-debug" 243 kB
[ebuild N ] x11-drivers/xf86-video-s3-0.3.5.5 USE="-debug" 236 kB
[ebuild N ] x11-drivers/xf86-video-glint-1.0.1.3 USE="dri -debug" 326 kB
[ebuild N ] x11-drivers/xf86-video-tdfx-1.1.1.3 USE="dri -debug" 255 kB
[ebuild N ] x11-drivers/xf86-video-fbdev-0.1.0.5 USE="-debug" 214 kB
[ebuild N ] x11-drivers/xf86-video-i740-1.0.0.5 USE="-debug" 241 kB
[ebuild N ] x11-drivers/xf86-video-dummy-0.1.0.5 USE="-debug" 211 kB
[ebuild N ] x11-drivers/xf86-video-voodoo-1.0.0.5 USE="-debug" 227 kB
[ebuild N ] x11-drivers/xf86-video-savage-2.0.2.3 USE="dri -debug" 275 kB
[ebuild N ] x11-drivers/xf86-video-siliconmotion-1.3.1.5 USE="-debug" 256 kB
[ebuild N ] x11-drivers/xf86-video-ark-0.5.0.5 USE="-debug" 214 kB
[ebuild N ] x11-drivers/xf86-video-chips-1.0.1.3 USE="-debug" 291 kB
[ebuild N ] x11-drivers/xf86-video-ati-6.5.7.4_alpha20060318 USE="dri -debug" 0 kB [1]
[ebuild N ] x11-drivers/xf86-video-mga-1.2.1.3 USE="dri -debug" 338 kB
[ebuild N ] x11-drivers/xf86-video-v4l-0.0.1.5 USE="-debug" 216 kB
[ebuild N ] x11-drivers/xf86-video-sis-0.8.1.3 USE="dri -debug" 579 kB
[ebuild N ] x11-drivers/xf86-video-tseng-1.0.0.5 USE="-debug" 259 kB
[ebuild N ] x11-drivers/xf86-video-vga-4.0.0.5 USE="-debug" 215 kB
[ebuild N ] x11-drivers/xf86-video-cyrix-1.0.0.5 USE="-debug" 232 kB
[ebuild N ] x11-drivers/xf86-video-apm-1.0.1.5 USE="-debug" 252 kB
[ebuild N ] x11-drivers/xf86-video-rendition-4.0.1.3 USE="-debug" 272 kB
[ebuild N ] x11-libs/libXvMC-1.0.1-r1 USE="-debug" 213 kB
[ebuild N ] x11-drivers/xf86-video-i810-1.4.1.3 USE="dri -debug" 368 kB
[ebuild N ] x11-drivers/xf86-video-via-0.1.33.2 USE="dri -debug" 355 kB
[ebuild U ] kde-base/kdeadmin-3.5.2 [3.5.1] USE="arts -debug -kdeenablefinal -xinerama" 2,061 kB
[ebuild N ] app-text/sgml-common-0.6.3-r4 74 kB
[ebuild U ] app-text/docbook-xml-dtd-4.1.2-r6 [4.1.2-r5] 0 kB
[ebuild U ] app-text/docbook-xml-dtd-4.4-r1 [4.4] 0 kB
[ebuild U ] kde-base/kdeutils-3.5.2 [3.5.1] USE="arts crypt xmms -debug -kdeenablefinal -snmp -xinerama" 2,906 kB

Total size of downloads: 103,032 kB
Portage overlays:
[1] /usr/local/xgl-coffee/xgloverlay

Do you want me to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
Ferdinando
Veteran
Veteran


Joined: 25 Nov 2003
Posts: 1027
Location: Gaeta (LT) - Italy

PostPosted: Tue Mar 28, 2006 8:00 pm    Post subject: Reply with quote

I think you should set VIDEO_CARDS in /etc/make.conf

Bye
_________________
La risposta, non la devi cercare fuori, la devi cercare dentro di te: e però è SBAGLIATA!
-- Corrado Guzzanti, "Pippo Chennedy Show", 1997
Back to top
View user's profile Send private message
NEW
n00b
n00b


Joined: 25 Jan 2005
Posts: 74
Location: Czech Republic, Prague

PostPosted: Wed Mar 29, 2006 4:33 am    Post subject: Reply with quote

Ferdinando wrote:
I think you should set VIDEO_CARDS in /etc/make.conf

Bye


Oups, yes, you are right ... (somewhere i read that if i use nvidia so i have to put in VIDEO_CARDS="none" because i'am using nvidia-kernel

THX ,bye
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Wed Mar 29, 2006 11:19 am    Post subject: Reply with quote

Desintegr wrote:
Add « virtual/x11-6.8 » to package.provided file.


That's no a solution, that's an evil hack. Please don't advise this.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jun 05, 2006 7:29 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of xorg-x11-6.9 -> xorg-x11-7.0-r1 everything blocked.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum