Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2006 tar unpacking fails Oldworld problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
maccabbi
n00b
n00b


Joined: 31 Mar 2006
Posts: 1

PostPosted: Fri Mar 31, 2006 11:06 pm    Post subject: 2006 tar unpacking fails Oldworld problems Reply with quote

I have a TAM (twentieth anniversary mac) which is basically a 7500 powermack with a powerbook lcd for a monitor. ANyways I managed to get bootX to work with the OW-kernel i found on this forum. It seems to work better with the 2005 cd then the 2006 cd. 2006 expects a slightly newer kernel but still boots up. I was able to run fdisk and mkfs and I was able to mount the partition unde /mnt/gentoo, but when i run tar xvjpf /mnt/cdrom/stages/stage3-ppc-2006.0.tar.bz2 it starts to unpack but eventually it stops saying there is an input output error. I tried to uncompress this file on my OS X machine and it also fails, may mean nothing.

I haven't tried this via internet instead of cd because my ethernet card is a Comm II, tulip detects it and says it is okay but i have never been able to get it to see an ip adress on any form of linux. I think the tulip driver is designed for pci mainly. If anyone knows how to fix that i would like some ideas.

The kernel on the 2006 disk wouldn't work for me either. It would start to boot but when it got to the part where it list the partitions it would just freeze. So right now i am installing 2005.0, which seems to unpack fine. I am wondering if there is a way to upgrade after I install or is it better to try to get the 2006 install to work.

Any help is much appreciated
Back to top
View user's profile Send private message
8-bitDesigner
n00b
n00b


Joined: 14 Jan 2006
Posts: 25
Location: Orange, CA

PostPosted: Sat Apr 08, 2006 5:58 am    Post subject: Reply with quote

I hear you, brutha. I've got a Powermac 8500 (just a few steps up from your fabled TAM), and 2006 just gave me fits. On my end of it, it just flaked whenever I tried to write a filesystem to a mac-fdisk partitioned partition. In my experience, 2005.1 is a really solid installer, and I've just completeed a full system reinstall with it, where 2006 just fluked out.

I'd highly recommend a 2005.1 boot CD with the 2005.0 kernel and image (for BootX... long story). Unless you're dying to use the 2.6.15 kernel on the 2006 install CD, 2005.1 should do wonders for you.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Apr 08, 2006 2:17 pm    Post subject: Reply with quote

You can use the stage tarballs from the 2006.0 release, there's no reason to install the older stage tarballs. Do whatever it takes to boot the machine and get it partitioned, then install the latest stage3 tarball. I still don't know why 2006.0 is failing for some people, but I'm looking into it. Any messages from dmesg, or other error messages would be really helpful!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum