Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage 'sync' taking longer and longer...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Mon Apr 03, 2006 9:43 pm    Post subject: Portage 'sync' taking longer and longer... Reply with quote

Is it me, my system or is something playing up?

My portage is a couple of years old now and emerge sync seems to be taking longer and longer.

Particularly around the 51% mark when it sits there for about 15 minutes of cpu on my 2.8ghz P4 with 2gb memory.

Is there something I can do to 'tune' this? Some 'obsolete' cleanup?

...Lyall
_________________
...Lyall
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Mon Apr 03, 2006 10:33 pm    Post subject: Reply with quote

You could update to portage-2.1 (currently in ~arch), or use RSYNC_EXLUDEFROM, or try any other of the portage speedup tricks described in the forums or the wiki (though those are generally unofficial/unsupported).
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Tue Apr 04, 2006 7:18 am    Post subject: Reply with quote

As a general feel, how stable would you say portage 2.1 is?

If I move to it by updating my '/etc/portage/package.keywords' to have 'sys-apps/portage ~x86', what would my backout strategy be if 2.1 fails?

I would prefer to stay with 'standard' than include non-supported modules and am happy to 'test' 2.1, I just want a way to recover if things go drastically wrong (short of restore from backup or complete re-install)
_________________
...Lyall
Back to top
View user's profile Send private message
hiziki_gard
n00b
n00b


Joined: 05 Jan 2006
Posts: 50
Location: dark side of the moon

PostPosted: Tue Apr 04, 2006 8:17 am    Post subject: Reply with quote

Been using the latest ~amd64 portage for a while now. Haven't had any problems with it.
_________________
default-linux/amd64/2007.0, gcc-4.2.3, glibc-2.7-r2, 2.6.25-hh5 x86_64
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Apr 04, 2006 11:06 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-384292.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum