Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-lang/php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Wed Apr 05, 2006 10:28 am    Post subject: dev-lang/php Reply with quote

Just emerging this (dev-lang/php) and see that there are 26 packages 8O

One of these is xorg, one of these is mysql....

Whilst I was going to have some of these anyway, are they really dependancies? Why do I need xorg for php?

Mark
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Wed Apr 05, 2006 10:29 am    Post subject: Reply with quote

Some of them are already compiled but here are what is in the queue to do:

marky ~ # USE="cli apache2" emerge --pretend 'dev-lang/php'

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild N ] x11-base/xorg-x11-6.8.2-r4
[ebuild N ] virtual/x11-6.8
[ebuild N ] media-libs/t1lib-5.0.2
[ebuild N ] app-arch/rpm2targz-9.0-r3
[ebuild N ] sys-apps/utempter-0.5.5.6
[ebuild N ] x11-terms/xterm-207
[ebuild N ] media-libs/jpeg-6b-r5
[ebuild N ] dev-db/mysql-4.1.14
[ebuild N ] dev-lang/php-5.0.5-r5
[ebuild N ] perl-core/Storable-2.15
[ebuild N ] dev-perl/Net-Daemon-0.38
[ebuild N ] dev-perl/PlRPC-0.2018
[ebuild N ] dev-perl/DBI-1.48
[ebuild N ] dev-perl/DBD-mysql-2.9007
Back to top
View user's profile Send private message
loki99
Advocate
Advocate


Joined: 10 Oct 2003
Posts: 2056
Location: Vienna, €urope

PostPosted: Wed Apr 05, 2006 10:39 am    Post subject: Reply with quote

Well, that is what USE Flags are for. If you do not want mysql support, you gotta set the "-mysql" flag in your "/etc/make.conf" or in your "/etc/portage/packages.use" file.

Same with X support, I'd guess.
Back to top
View user's profile Send private message
loki99
Advocate
Advocate


Joined: 10 Oct 2003
Posts: 2056
Location: Vienna, €urope

PostPosted: Wed Apr 05, 2006 10:41 am    Post subject: Reply with quote

Try....
Code:
USE="cli apache2 -X" emerge --pretend 'dev-lang/php'


Edit: X is set as default. So if you want a server without X11 put "-X" in your USE Flags in your "/etc/make.conf"
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Apr 05, 2006 10:47 am    Post subject: Reply with quote

Please see this FAQ: Why is <y> getting pulled in when I emerge <x>?

Moved from Portage & Programming to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum