Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-util/intltool-0.34.1 error: XML::Parser perl required!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
themaster.dk
n00b
n00b


Joined: 31 Dec 2005
Posts: 10

PostPosted: Thu Apr 06, 2006 3:28 am    Post subject: dev-util/intltool-0.34.1 error: XML::Parser perl required!! Reply with quote

Hey :)

I get this problem,

Code:
Calculating dependencies ...done!
>>> emerge (1 of 207) dev-util/intltool-0.34.1 to /
>>> md5 files   ;-) intltool-0.31.2.ebuild
>>> md5 files   ;-) intltool-0.32.1.ebuild
>>> md5 files   ;-) intltool-0.33.ebuild
>>> md5 files   ;-) intltool-0.34.1.ebuild
>>> md5 files   ;-) intltool-0.34.2.ebuild
>>> md5 files   ;-) files/digest-intltool-0.33
>>> md5 files   ;-) files/digest-intltool-0.32.1
>>> md5 files   ;-) files/digest-intltool-0.34.1
>>> md5 files   ;-) files/digest-intltool-0.31.2
>>> md5 files   ;-) files/digest-intltool-0.34.2
>>> md5 src_uri ;-) intltool-0.34.1.tar.bz2
>>> Unpacking source...
>>> Unpacking intltool-0.34.1.tar.bz2 to
/var/tmp/portage/intltool-0.34.1/work
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/intltool-0.34.1/work/intltool-0.34.1/config.log

!!! ERROR: dev-util/intltool-0.34.1 failed.
!!! Function econf, Line 495, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status
message.



when i emerge this:

Code:
# emerge gnome mozilla-firefox gftp bluefish xmms gdm gxine


I don't know what the true problem is, but i think it has something to do with the USE-flags.
Here is my /etc/make.conf:

Code:
CFLAGS="-O3 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKE_OPTS="-j2"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://mirror.uni-c.dk/pub/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ http://mirror.pudas.net/gentoo ftp://mirror.pudas.net/gentoo"
USE="xml xml2 nptlonly -nls X aalib aim alsa apm audiofile avi bcmath bonobo bzlib cdr cpdflib crypt cups curlwrappers dio directfb divx4linux dvd dvdr encode escreen exif fbcon flac flash foomaticdb ftp gif ginac glx gnome gphoto2 graphviz gstreamer gtk gtk2 gimpprint imagemagick imlib java jpeg kde lcms libedit libwww mad mikmod mime ming mng mozilla mp3 mpeg nocd nsplugin oav openal opengl oss pam pdflib png qt readline sdl speex spell svg szip theora tiff truetype usb videos xine xinerama bmp xmms xpm xv zlib x86"


So if anyone knows how this can be solved, please leave an answer.
_________________
TheMaster.dk | Gentoo @ 2.40
Back to top
View user's profile Send private message
p_ansell
n00b
n00b


Joined: 12 May 2005
Posts: 33
Location: Brisbane, AU

PostPosted: Thu Apr 06, 2006 3:48 am    Post subject: Reply with quote

This is related to the following thread about the expat breakages, emerging dev-perl/XML-Parser whould fix your first problem, you will find many more after that though

https://forums.gentoo.org/viewtopic-t-448550.html
Back to top
View user's profile Send private message
themaster.dk
n00b
n00b


Joined: 31 Dec 2005
Posts: 10

PostPosted: Sun Apr 09, 2006 7:03 pm    Post subject: Reply with quote

I found the answer in a other forum.

This is the solution:

Code:
emerge -va1 dev-libs/libxslt dev-libs/libxml2 dev-perl/XML-Parser app-text/gnome-doc-utils

_________________
TheMaster.dk | Gentoo @ 2.40
Back to top
View user's profile Send private message
ribx
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 219
Location: germany

PostPosted: Sun Apr 16, 2006 2:16 pm    Post subject: Reply with quote

i got the same problem on a complete fresh installation. i'm using the -minimal USE-flag because of very limited disk space.
this are the package, available on my system, which i already tried to fix:
Code:
USE="-minimal" emerge -1 -dev-libs/libxml2 dev-perl/XML-Parser


revdep-rebuild also doesnt complain about anything. i stuck :(

[EDIT]
i check the link mentioned above, but this is a stable system -- with expat 1.95.8.
[/EDIT]

[EDIT2]
i also tried the unstale version of intltool (0.34.2) with the same result.
[/EDIT2]
_________________
The adopt an unanswered post initiative
Back to top
View user's profile Send private message
ribx
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 219
Location: germany

PostPosted: Sun Apr 16, 2006 2:39 pm    Post subject: Reply with quote

SOLUTION:

the reemerge of XML-Parser didnt do anything. but if i unmerge and remerge it, it works -- huray!

btw: i found the solution in this bug report: gnomemeeting 1.2 fails to emerge because of missing XML::Parser perl module

EDIT: link to bug didnt worked :)
_________________
The adopt an unanswered post initiative
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Sun Apr 16, 2006 4:04 pm    Post subject: Reply with quote

The problem is, that you did not ran the perl-cleaner script after updating perl. This affects all perl related packages, so do it.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
ribx
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 219
Location: germany

PostPosted: Sun Apr 16, 2006 9:12 pm    Post subject: Reply with quote

maybe this is correct, i cant check. but the next problem was the missing module AutoSplit.pm, which isnt installed when the minimal use flag is set for perl - also see here: http://www.netsc.ch/forum/viewtopic.php?p=209&sid=e6228747204aa8abfc5a7347c2a96342

btw: a "perl-cleaner all" didnt found any missing modules/libs/whatever
_________________
The adopt an unanswered post initiative
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Mon Apr 17, 2006 2:23 pm    Post subject: Reply with quote

ribx wrote:
maybe this is correct, i cant check. but the next problem was the missing module AutoSplit.pm, which isnt installed when the minimal use flag is set for perl - also see here: http://www.netsc.ch/forum/viewtopic.php?p=209&sid=e6228747204aa8abfc5a7347c2a96342

Please file a bug about it, if you can't find any relevant existing ones.

ribx wrote:
btw: a "perl-cleaner all" didnt found any missing modules/libs/whatever

Search /usr/lib/perl5/vendor_perl/5.* for perl modules that are not present in the directory of the latest version. If you find some, there may be a problem with perl-cleaner and it's worth filing a bug, otherwise there was nothing to fix.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Apr 21, 2006 8:15 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Can't emerge (maybe deps problem)
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum