Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Serious problems compiling and running multiple packages.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
joho8705
n00b
n00b


Joined: 27 Oct 2005
Posts: 2

PostPosted: Mon Apr 10, 2006 4:46 pm    Post subject: Serious problems compiling and running multiple packages. Reply with quote

I tried running Gaim, and it wouldn't start, and when i tried to compile:
Code:
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/gaim-1.5.0/work/gaim-1.5.0/config.log

!!! ERROR: net-im/gaim-1.5.0 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  gaim-1.5.0.ebuild, line 128:   Called econf '--disable-nas' '--disable-tcl' '--disable-tk' '--enable-gnutls=no' '--with-nspr-includes=/usr/include/nspr' '--with-nss-includes=/usr/include/nss' '--with-nspr-libs=/usr/lib/nspr' '--with-nss-libs=/usr/lib/nss'
  ebuild.sh, line 527:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


GTK+ is there, though:
Code:
tux josh # emerge -vp gtk+

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-libs/gtk+-2.8.13 [2.8.8] USE="jpeg -debug -doc -tiff* -xinerama%" 0 kB

Total size of downloads: 0 kB

However, i try to re-compile GTK+,
Code:
checking Pango flags... -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo   -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
configure: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see http://www.pango.org

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/gtk+-2.8.13/work/gtk+-2.8.13/config.log

!!! ERROR: x11-libs/gtk+-2.8.13 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  gtk+-2.8.13.ebuild, line 114:   Called econf '--disable-gtk-doc' '--with-libjpeg' '--without-libtiff' '--disable-xinerama' '--with-libpng' '--with-gdktarget=x11' '--with-xinput'
  ebuild.sh, line 527:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



i read a post https://forums.gentoo.org/viewtopic-t-420213.html, and tried to follow those directions with USE="cairo", but cairo recompiled fine, and pango gave me the error:
Code:
Writing a pango.modules file to use when running examples before installing Pango.
mkdir .libs
/var/tmp/portage/pango-1.10.4/work/pango-1.10.4/pango/.libs/lt-pango-querymodules: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[2]: *** [pango.modules] Error 127
make[2]: *** Waiting for unfinished jobs....
i386-pc-linux-gnu-gcc -O2 -mcpu=i686 -Wall -o .libs/pangoft2topgm pangoft2topgm.o renderdemo.o argcontext.o  ../pango/.libs/libpango-1.0.so ../pango/.libs/libpangoft2-1.0.so /var/tmp/portage/pango-1.10.4/work/pango-1.10.4/pango/.libs/libpango-1.0.so -lm /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so /usr/lib/libfontconfig.so /usr/lib/libexpat.so /usr/lib/libfreetype.so -lz
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.6/../../../../i386-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib/libfontconfig.so, not found (try using -rpath or -rpath-link)
creating pangoft2topgm
make[2]: Leaving directory `/var/tmp/portage/pango-1.10.4/work/pango-1.10.4/examples'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pango-1.10.4/work/pango-1.10.4'
make: *** [all] Error 2

!!! ERROR: x11-libs/pango-1.10.4 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  ebuild.sh, line 1236:   Called gnome2_src_compile
  gnome2.eclass, line 56:   Called die

!!! compile failure
!!! If you need support, post the topmost build error, and the call stack if relevant.


i also cannot compile the latest glib or qt. some programs are inop as well, including gaim, xine, mplayer, gimp...
whats going on here?
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Mon Apr 10, 2006 6:18 pm    Post subject: Reply with quote

Oh, for the love of Benji. The expat thread is sticky smack at the top of this very forum. Please LOOK at the page once in a while...
https://forums.gentoo.org/viewtopic-t-448550.html
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18070

PostPosted: Mon Apr 10, 2006 6:21 pm    Post subject: Reply with quote

Moved from Portage & Programming
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum