Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gensplash: initramfs fails to load
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
vandalman
n00b
n00b


Joined: 16 Mar 2005
Posts: 52

PostPosted: Wed Apr 12, 2006 7:45 am    Post subject: Gensplash: initramfs fails to load Reply with quote

I am having issues with gensplash, the initramfs doesn't load. It waits until the /ete/init.d/splash starts and it looks for the /etc/splash/default symlink and loads that correctly. Is there something I am missing in my config that causes initramfs to not load? Sometimes my G4 iBook stalls during the boot sequence, but after a hard restart it loads correctly. There doesn't seem to happen on a set frequency.

Here is the version of splashutils I have
Code:

[ebuild   R   ] media-gfx/splashutils-1.1.9.10-r1  -hardened -kdgraphics +png +truetype 0 kB


Here is my yaboot.conf
Code:

boot=/dev/hda4
device=/pci@f4000000/ata-6@d/disk@0:
partition=6
root=/dev/hda6
timeout=300
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot


image=/boot/kernel-2.6.15
        label=Linux-2.6.15-splash
        read-only
        append="quite video=radeonfb:1024x768-32 splash=silent,theme=livecd-2006.0 console=tty1"
        initrd=/boot/fbsplash-livecd-1024x768

image=/boot/kernel-2.6.15
        label=Linux-2.6.15
        read-only

# OSX setup
macosx=hd:3

# CD-ROM boot
enablecdboot

# setup colors
fgcolor=green
bgcolor=black


Command used to create initramfs
Code:
splash_geninitramfs livecd-2006.0 -r 1024x768 -g /boot/fbsplash-livecd-1024x768 -v
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum