Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage Blocks Help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
linkinpark342
n00b
n00b


Joined: 08 Jan 2006
Posts: 29

PostPosted: Thu Apr 13, 2006 2:30 am    Post subject: Portage Blocks Help Reply with quote

Well I'm confused. I just rebuilt the OS after a bit of... hardware... issues (completely unrelated). so i installed my xorg-x11 and kde and was happy, then i did an emerge-webrsync and tried to do the little "emerge -vauDN world" and i get flooded by hundreds of things like "[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-i810-1.4.1.3)"
The full log of what i get from -vauDN is at http://pastebin.com/656905

So now I'm stuck here without -vauDN support since i just get stuck at "package list contains blah blah." I'm running a ~amd64 gentoo system with KDE-3.5.1 and xorg-x11-6.8.2-r6

What can I do to remedy this? should i just remove xorg-x11 from world (which is at http://pastebin.com/656909 for reference)? ways that take <11 hours (according to genlop) are preferred :wink:

[edit typo]
Back to top
View user's profile Send private message
baeksu
l33t
l33t


Joined: 26 Sep 2004
Posts: 609
Location: Seoul, Korea

PostPosted: Thu Apr 13, 2006 3:21 am    Post subject: Reply with quote

The new modular X has been unmasked, so portage wants to upgrade to that. But your current x.org is blocking it. You have to remove your current x.org before you can upgrade.

You can find a guide to the upgrade here.
_________________
Gnome:
1. A legendary being.
2. A never ending quest to make unix friendly to people who don't want unix and excruciating for those that do.
Back to top
View user's profile Send private message
brims
Guru
Guru


Joined: 19 Apr 2004
Posts: 492
Location: Arizona

PostPosted: Thu Apr 13, 2006 3:23 am    Post subject: Reply with quote

If I'm not mistaken I believe your system is trying to install modular X, >= xorg 7.0. If you don't want to try modular X, mask >=x11-base/xorg-x11-7.0 in /etc/portage/package.mask.
_________________
Adopt an Unanswered Post
Report violations, duplicates, misplaced, etc
Back to top
View user's profile Send private message
linkinpark342
n00b
n00b


Joined: 08 Jan 2006
Posts: 29

PostPosted: Thu Apr 13, 2006 4:09 am    Post subject: Reply with quote

Would anyone know where i could get a changelog and see if its worth the major time to compile?
Back to top
View user's profile Send private message
brims
Guru
Guru


Joined: 19 Apr 2004
Posts: 492
Location: Arizona

PostPosted: Thu Apr 13, 2006 8:11 am    Post subject: Reply with quote

Changelog for xorg-x11 is at $PORTDIR/x11-base/xorg-x11/Changelog. You might want to check out that upgrade guide link, and look around the forums. From what I've read, there are some packages that aren't compatible with modular X, what those packages are, I don't know. It's a big changeover, like GCC 3.3 to 3.4 was.
_________________
Adopt an Unanswered Post
Report violations, duplicates, misplaced, etc
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jun 05, 2006 7:35 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of xorg-x11-6.9 -> xorg-x11-7.0-r1 everything blocked.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum