Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge ogre 1.0.7 crashes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
EnlightedGnome
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2005
Posts: 126
Location: Denmark, Odense

PostPosted: Sun Apr 16, 2006 5:26 pm    Post subject: emerge ogre 1.0.7 crashes Reply with quote

When I try to
Code:
emerge ogre -av

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] dev-games/ogre-1.0.7 [0.15.1] +cegui* +cg* +devil* +doc -double-precision +gtk -openexr +opengl +sdl -threads

I get a damn lot of errors.... I'm not sure what to post, but the output ends like this:
Code:
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o): In function `Ogre::GLSLProgramFactory::GLSLProgramFactory()':
OgreGLSLProgramFactory.cpp:(.text+0x68): undefined reference to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()'
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o): In function `Ogre::GLSLProgramFactory::GLSLProgramFactory()':
OgreGLSLProgramFactory.cpp:(.text+0xe0): undefined reference to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()'
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o): In function `Ogre::GLSLProgramFactory::~GLSLProgramFactory()':
OgreGLSLProgramFactory.cpp:(.text+0x134): undefined reference to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()'
OgreGLSLProgramFactory.cpp:(.text+0x14e): undefined reference to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()'
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o): In function `Ogre::GLSLProgramFactory::~GLSLProgramFactory()':
OgreGLSLProgramFactory.cpp:(.text+0x19e): undefined reference to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()'
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o):OgreGLSLProgramFactory.cpp:(.text+0x1b8): more undefined references to `Ogre::HighLevelGpuProgramFactory::~HighLevelGpuProgramFactory()' follow
../../../RenderSystems/GL/src/GLSL/src/.libs/libGLSL.a(OgreGLSLProgramFactory.o):(.gnu.linkonce.d._ZTIN4Ogre18GLSLProgramFactoryE+0x8): undefined reference to `typeinfo for Ogre::HighLevelGpuProgramFactory'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x14): undefined reference to `Ogre::StringInterface::setParameterList(std::map<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::less<std::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::basic_string<char, std::char_traits<char>, std::allocator<char> > const, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > > > const&)'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x20): undefined reference to `Ogre::GpuProgram::loadImpl()'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x2c): undefined reference to `Ogre::Resource::load()'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x30): undefined reference to `Ogre::Resource::reload()'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x48): undefined reference to `Ogre::GpuProgram::setSyntaxCode(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
../../../RenderSystems/GL/src/atifs/src/.libs/libatifs.a(ATI_FS_GLGpuProgram.o):(.gnu.linkonce.d._ZTVN4Ogre19ATI_FS_GLGpuProgramE+0x54): undefined reference to `Ogre::GpuProgram::setType(Ogre::GpuProgramType)'
collect2: ld returned 1 exit status
libtool: install: error: relink `RenderSystem_GL.la' with the above command before installing it
make[5]: *** [install-pkglibLTLIBRARIES] Error 1
make[5]: Leaving directory `/var/tmp/portage/ogre-1.0.7/work/ogrenew/RenderSystems/GL/src'
make[4]: *** [install-am] Error 2
make[4]: Leaving directory `/var/tmp/portage/ogre-1.0.7/work/ogrenew/RenderSystems/GL/src'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/ogre-1.0.7/work/ogrenew/RenderSystems/GL/src'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/ogre-1.0.7/work/ogrenew/RenderSystems/GL'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/ogre-1.0.7/work/ogrenew/RenderSystems'
make: *** [install-recursive] Error 1

!!! ERROR: dev-games/ogre-1.0.7 failed.
!!! Function src_install, Line 91, Exitcode 2
!!! make install failed
!!! If you need support, post the topmost build error, NOT this status message.

it also seems to have a lot of
Code:
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../..//libfreetype.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../..//libzzip.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../..//libILU.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../..//libIL.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../..//libSDL.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/3.4.4//libstdc++.la' seems to be moved

everywhere....

This is my emerge info, if that's any help...
Code:
# emerge info
Portage 2.0.54 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://rsync.gentoo.diku.dk/"
LINGUAS="da en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.diku.dk/gentoo-portage"
USE="x86 X aalib alsa apm arts audiofile avi berkdb bitmap-fonts browserplugin bzip2 cdb cdparanoia cdr crypt cups curl directfb divx4linux doc dri dts eds emboss encode esd exif expat fam fbcon ffmpeg flac foomaticdb fortran gcj gd gdbm gif gik ginac glut gmp gnome gpm gstreamer gtk gtk2 hal howl icq idn imagemagick imlib ipv6 isdnlog jack java jpeg junit kde lcms libcaca libg++ libwww mad matroska mhash mikmod mng motif mozilla mp3 mpeg mysql mythtv nas ncurses nls nsplugin nvidia oav ogg oggvorbis openal opengl osc oss pam pcre pda pdflib perl php png pppd python qt quicktime readline real recode samba sdl shorten sockets speex sse ssl svga talkfilter tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb vcd videos vorbis win32codecs xine xml2 xmms xv xvid xvmc zlib linguas_da linguas_en userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS



I've tried before, but nobody were answering...
_________________
checking for -lifesign in -Kenny... no
- oh my god, they killed Kenny
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Mon Apr 17, 2006 12:22 am    Post subject: Re: emerge ogre 1.0.7 crashes Reply with quote

EnlightedGnome wrote:
I've tried before, but nobody were answering...
So you reposted creating a pointless duplicate. You could have just as well replied to your old thread. Please don't do this.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
curtis119
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 2160
Location: Phoenix, AZ USA, North America, Earth, SOL System, Milky Way, The Universe, The Cosmos, and Beyond.

PostPosted: Mon Apr 17, 2006 1:11 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

Like moocha said, please don't post the same exact question twice. Bump the old one instead.
_________________
Gentoo: it's like wiping your ass with silk.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum