Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ solved ] No sound on iBook G4 1.33
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
chr1stopher
n00b
n00b


Joined: 16 Apr 2006
Posts: 3

PostPosted: Sun Apr 16, 2006 8:21 pm    Post subject: [ solved ] No sound on iBook G4 1.33 Reply with quote

Hi!

I've read many topics here but no one fixed my problem.

I've installed for the very first time a gentoo on my iBookG4 1.33 (which came out around oct.04) and everything seems to work fine except sound.. Nothing about sound in a "dmesg" nor in "lspci"..

It seems that the system doesnt detect any soundcard..

When I made the make menuconfig I tried several things : with or without the "PowerMac DMA sound support" and with or without the "Advanced Linux Sound Architecture"..

Thanks a lot for you help!

Cheers,

Christopher


Last edited by chr1stopher on Mon Apr 17, 2006 12:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Sun Apr 16, 2006 9:15 pm    Post subject: Reply with quote

On my Powerbook I have:

No Powermac DMA Sound Support

Alsa - Advanced Linux Sound Architecture, Sequencer support, Sequencer dummy client, OSS Mixer API, OSS PCM (digital audio) API all as modules, and OSS Sequencer API compiled in the kernel.

Under ALSA -> ALSA Powermac devices, I have Powermac (AWACS, DACA, Burgundy, Tumbler, Keywest)

On kernel 2.6.16-rc3.

I don't know how different iBook sound is, but just in case they are the same, I hope that helps![/list]
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Sun Apr 16, 2006 9:27 pm    Post subject: Reply with quote

I think you need i2c support for sound, maybe that's what's missing.
that's why no sound devs show up in lspci, too ;)
_________________
[/garbage]
Back to top
View user's profile Send private message
chr1stopher
n00b
n00b


Joined: 16 Apr 2006
Posts: 3

PostPosted: Sun Apr 16, 2006 10:27 pm    Post subject: Reply with quote

Thanks for your help, I tried to take it into account and recompiled my kernel..

Stil nothing in "lspci"

But "dmesg | grep -i sound" now gives

Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC).
No soundcards found.


Any ideas?
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Sun Apr 16, 2006 10:36 pm    Post subject: Reply with quote

Maybe something here will help?

Btw, I don't know about the needing to press the key 4 times, but on my Powerbook I have an alternate key config for you to consider: the right Apple buttons as right click, and the little Enter button next to it as middle-click. Just an idea :wink:
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
chr1stopher
n00b
n00b


Joined: 16 Apr 2006
Posts: 3

PostPosted: Mon Apr 17, 2006 12:18 pm    Post subject: [ solved ] Reply with quote

hello there

discovered my problem.. didn't check carefully enough the "make xconfig" there was a "m" instead of a "y" in "Advanced Linux Sound Architecture"..

then just recompile, reboot

start engine : # /etc/init.d/alsasound start
configure sound : # alsamixer
check that the Mute option is not checked! (press "m" to uncheck)
then add it to startup # rc-update add alsasound boot

then everything should work fine!
test it on a wav file : $ aplay testfile.wav

thanks for your help

cheers

christopher
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum